Вы находитесь на странице: 1из 140

CORPORACIN UNIVERSITARIA DEL

CARIBE CECAR

ELECTIVA
PROFESIONAL II
Conmutacin y enrutamiento intermedio

DAIRO ALFONSO ALVAREZ


PRIETO
Especialista en Redes de
Computadores
DISEO DE LA RED LAN
OBJETIVOS

Identificar los aspectos fundamentales del diseo


de redes de rea locales.

Analizar el diseo de red jerrquico que utiliza el


modelo en capas.

Describir las funciones de cada uno de los tres


niveles del modelo de diseo de una red jerrquica.

Seleccionar los dispositivos apropiados para operar


en cada nivel de la jerarqua
ANTECEDENTES DE DISEOS

10base2
ANTECEDENTES DE DISEOS

10baseT
ANTECEDENTES DE DISEOS

El diseos de red varan segn el


tamao y las necesidades de las
organizaciones
MODELO DE REDES JERRQUICO
El diseo de redes jerrquicas divide la red en 3 capas
independientes

Backbo
ne

Control
a el
flujo de
datos
MODELO DE REDES JERRQUICO
Diseo de Ncleo
Contrado
MODELO DE REDES JERRQUICO
Independientemente del tamao o los requisitos de la red,
cualquier diseo de red debe seguir unos buenos principios de
ingeniera estructurada. Estos principios incluyen lo siguiente:

Confiabilidad

Resistente
MODELO DE REDES JERRQUICO

Beneficios de una red jerrquica


DISEO DE RED MODULAR
Un diseo de red modular separa la red en varios mdulos de red
funcionales, y cada uno de estos apunta a un lugar o un propsito
especfico en la red
DISEO DE RED MODULAR
Benefic
ios
Las fallas que ocurren dentro de un mdulo se pueden aislar
del resto de la red,

Los cambios, las actualizaciones o la introduccin de nuevos


servicios de redes se pueden realizar de forma controlada y
gradual

Cuando un mdulo especfico ya no posee la capacidad


suficiente o no tiene una funcin o un servicio nuevos, se
puede actualizar o reemplazar con otro mdulo que tenga la
misma funcin estructural en el diseo jerrquico general.

Se puede implementar seguridad de forma modular, lo que


permite un control ms detallado de la seguridad.
CONSIDERACIONES DE DISEO

Las redes deben


satisfacer las
necesidades
actuales de las
organizaciones y
admitir tecnologas
emergentes a
medida que se
adoptan nuevas
tecnologas
CONSIDERACIONES DE DISEO
Principios de diseo de redes jerrquicas: Existen guas
simples que ayudan a diferenciar entre redes jerrquicas con un buen
diseo y las que presentan un diseo deficiente

El dimetro de la red: es el nmero de dispositivos que una


trama debe cruzar antes de alcanzar su destino
CONSIDERACIONES DE DISEO
Agregado de ancho de banda
CONSIDERACIONES DE DISEO
Enlaces Redundantes
REQUISITOS DEL DISEO DE RED
Definir y
documentar
los
objetivos

Funcional: La red debe suministrar conectividad de usuario a


usuario y de usuario a aplicacin con una velocidad y
confiabilidad razonables.

Escalable: La red debe poder aumentar de tamao.

Adaptable: La red debe poder incorporar nuevas tecnologas

Fcil de administrar: La red debe estar diseada para


facilitar su monitoreo y administracin.
METODOLOGA DE DISEO DE UNA LAN

Reunir requisitos y expectativas


Anlisis de requisitos
lan ific
P Disear la topologa lgica de la red
ar
Disear la topologa fsica
Metodologa de diseo de una LAN
Paso 1 Reunir requisitos y expectativas

Proceso destinado a obtener informacin de la empresa y la red

Analizar metas de negocio y restricciones


Metodologa de diseo de una LAN
Paso 1 Reunir requisitos y expectativas

Se deben formular las siguientes


preguntas:

Quines son las personas que utilizarn la


red?
Cul es el nivel de capacitacin de estas
personas?
Cules son sus actitudes con respecto a las
computadoras y las aplicaciones
informticas?
Metodologa de diseo de una LAN
Paso 1 Reunir requisitos y expectativas

Algunos de los datos han sido declarados crticos


para el trabajo?
Algunas operaciones han sido declaradas crticas
para el trabajo?
Slo se soportan determinados hosts de escritorio?
Quin es responsable de las direcciones, el diseo de
topologa y la configuracin de las LAN?
Metodologa de diseo de una LAN
Paso 1 Reunir requisitos y expectativas

Cules son los recursos hardware y de software?

Cmo se vinculan y comparten estos recursos


actualmente?

Cules son los recursos financieros de los que


dispone la organizacin?
Metodologa de diseo de una LAN
Paso 2 Anlisis de requisitos

Se analiza los requisitos de la red y de sus usuarios


Caractersticas de la red existente
Entrega 1 fase
Metodologa de diseo de una LAN
Paso 3 DISEO LGICO

topologa lgica:identifican dispositivos, puertos y el esquema de


direccionamiento IP.
Fase 2: Disear la topologa lgica de
la red
Metodologa de diseo de una LAN
Paso 3 Diseo Fsico

Diagrama fsico: identifican la ubicacin fsica de los


dispositivos intermediarios, los puertos configurados y la
instalacin de los cables.
Metodologa de diseo de una LAN
Paso 3 Plan de distribucin

Consultar norma
606A
Fase 3 Diseo de la topologa fsica
Metodologa de diseo de una LAN
Paso 3 Direccionamiento IP

Mapa lgico de la
capa 3
Metodologa de diseo de una LAN
Paso 3 Direccionamiento IP

Mapa de
direcciones
Fase 4 Direccionamiento IP
Fase 5 y 6 Enrutamiento
Metodologa de diseo de una LAN
Paso 3 Mapa lgico de las VLAN

Mapa lgico de las


VLAN
CARACTERSTICAS CLAVE DE LOS
SWITCHES
CARACTERSTICAS CLAVE DE LOS
SWITCHES
e q u i sito s
R
d
de la re

Configuracin fija

configuracin
modular
Apilable o no
No se pueden agregar
apilable.
caractersticas u opciones al
switch ms all de las que
originalmente vienen con l.
CARACTERSTICAS CLAVE DE LOS
SWITCHES
Configuracin Vienen con chasis (Bastidor) de
Modular diferentes tamaos que
permiten la instalacin de
diferentes nmeros de tarjetas
de lneas modulares

Switches apilables

Pueden interconectarse con


el uso de un cable especial
del backplane que otorga
rendimiento de ancho de
banda alto entre los
switches.
CARACTERSTICAS CLAVE DE LOS
Desempeo:
SWITCHES
esta Velocidad de
determinado por. reenvo
Densidad de
puertos

Agregado de
enlaces
CARACTERSTICAS CLAVE DE LOS
SWITCHES
Funcionalidad de Power over Ethernet
(PoE) y de la Capa 3
Power over Ethernet
(PoE): permite que el
switch suministre energa
a un dispositivo por el
cableado de Ethernet
existente

unciones de capa 3
CARACTERSTICAS DEL SWITCHES DE
CAPA DE ACCESO
CARACTERSTICAS DEL SWITCHES DE CAPA DE
DISTRIBUCIN
CARACTERSTICAS DEL SWITCHES DE CAPA DE
NUCLEO
CARACTERSTICAS DEL SWITCHES CISCO
Actualizar el diseo lgico
especificando los Switches a utilizar
CONCEPTOS BSICOS DE SWITCH
CONMUTACIN DE CAPA 2 Y CAPA 3

Un switch de Capa 2 lleva a cabo


los procesos de conmutacin y
filtrado basndose solamente en
la direccin MAC de la Capa 2

Un switch de Capa 3, funciona de


modo similar a un switch de Capa
2, pero puede tambin emplear la
informacin de la direccin IP.
CONCEPTOS BSICOS Y CONFIGURACIN DE
SWITCH
Tablas de direcciones MAC de
Tablas de direcciones MAC de
los switches
CONCEPTOS BSICOS Y CONFIGURACIN DE
SWITCH
i mie
d
Ren o
nt
Latencia de
red
CONCEPTOS BSICOS Y CONFIGURACIN DE
SWITCH
Segmentacin de
Segmentacin de
las LAN

Las LAN se segmentan en varios


dominios de broadcast y de
colisiones ms pequeos
mediante el uso de routers y
switches
CONCEPTOS BSICOS Y CONFIGURACIN DE
SWITCH
Segmentacin de
Segmentacin de
las LAN
REENVO DE TRAMAS MEDIANTE SWITCH
CONCEPTOS BSICOS Y CONFIGURACIN DE
SWITCH
Mtodos de reenvo de trama
del switch

nami
ace
Alm y envo
ento
CONCEPTOS BSICOS Y CONFIGURACIN DE
SWITCH
Mtodos de reenvo de trama del switch (Conmutacin
Mtodos de reenvo de trama del switch (Conmutacin
por mtodo de corte) n
u taci
u taci m
Con re de
m
Con e nvo lib nt os
r e
n po ido m
frag byte)
rp ( 64
CONCEPTOS BSICOS Y CONFIGURACIN DE
SWITCH
Conmutacin simtrica y
Conmutacin simtrica y
asimtrica
CONCEPTOS BSICOS Y CONFIGURACIN DE
SWITCH
Bfer de
Bfer de
Memoria
CONFIGURACIN BSICA DEL SWITCH
MODOS INTERFAZ DE LA LNEA DE COMANDO
(IOS)
EXEC usuario
EXEC privilegiado
Modo de configuracin global
Otros modos de configuracin especficos
CONFIGURACIN BSICA
Proteccin de Acceso a Consola Proteccin Modo Exec

Switch#configure terminal Switch#configure terminal


Switch(config)#line console Switch(configenable
0 secret class
Switch(config- Switch(config-line)#end
line)#password cisco
Switch(config-line)#login
Switch(config-line)#end
Proteccin de los
puertos vty
Switch#configure terminal hostname
Switch(config)#line vty 0 4 no ip domain-lookup
Switch(config- mensaje de inicio
line)#password cisco
Switch(config-line)#login
Switch(config-line)#end
Service password-
encryption
CONFIGURAR LA SEGURIDAD DE
PUERTO
CONFIGURAR LA SEGURIDAD DE PUERTO

La seguridad de puerto limita la cantidad de direcciones MAC


vlidas permitidas en el puerto

Se implementa seguridad de puerto para:


Permitir un grupo de direcciones MAC accedan a un puerto
Permitir que solo una direccin MAC acceda a un puerto
Especificar que el puerto se desactive de manera automtica
si se detectan direcciones MAC no autorizadas
CONFIGURAR LA SEGURIDAD DE PUERTO

Tipos de direcciones
MAC seguras
Direcciones MAC seguras estticas: Las direcciones MAC se
configuran manualmente, mediante el comando
switchport port-security mac-address direccin
MAC

se almacenan en la tabla de direcciones y se agregan a


la configuracin en ejecucin del switch.

Direcciones MAC seguras dinmicas: Las direcciones MAC


se aprenden de manera dinmica y se almacenan slo en la
tabla de direcciones. (Se eliminan cuando el switch se
reinicia).

Direcciones MAC seguras persistentes: pueden


detectarse de forma dinmica o configurarse de forma
manual, y que despus se almacenan en la tabla de
direcciones y se agregan a la configuracin en ejecucin. Se
configuran con el comando switchport port-security
CONFIGURACIN DE DIRECCIONES MAC SEGURAS
ESTTICAS
Paso 1: Configurar la interfaz en modo acceso o trunk
mode
S1(config-if)# switchport mode Access

Paso 2: Activar Port Security


S1(config-if)#switchport port-security
Paso 3: Configurar la direccin MAC a permitir
manualmente
switchport port-security mac-address direccin MAC
Paso 4: Accin tomar cuando se detecte una violacin
S1(config-if)# switchport
Protect: slo se permite trfico port-security violation
de las MAC permitidas en la{configuracin
protect |
restrict | shutdown
descartando } resto, no se notifica sobre la intrusin.
el trfico del
Restrict: se enva una notificacin SNMP al administrador y el trfico del
puerto se permite nicamente a las MAC especificadas, del resto se
descarta.
Shutdown: el puerto se deshabilita
CONFIGURAR DIRECCIONES MAC SEGURAS
PERSISTENTES
Paso 1: Poner la interfaz en modo acceso (access
mode) o trunk mode
S1(config-if)# switchport mode Access
Paso 2: Activar la seguridad de puertoy
S1(config-if)#switchport port-security

Paso 3: Definir el nmero mximo de direcciones MAC a


permitir
S1(config-if)#switchport port-security maximum 1

Paso 4: Configurarel puerto como pegajoso (sticky)


S1(config-if)# switchport port-security mac-address
sticky

Paso 4: Accin tomar cuando se detecte una violacin


S1(config-if)# switchport port-security violation { protect |
Actividad 1

Realizar la configuracin
Bsica
Configurar la seguridad de
puerto
Configurar seguridad de
puertos sin utilizar
Configurar un Servidor DHCP
LAS VLAN
VLAN
VLAN: es una red de rea local que agrupa un conjunto de equipos de manera
lgica y no fsica.
Una VLAN es una red
independiente.

Cada VLAN crea un dominio de difusin


independiente.

Las VLAN se aslan mutuamente y los paquetes


pueden pasar entre ellas solamente mediante un
router.

La particin de la red de capa 2 se lleva a cabo dentro de un dispositivo de


capa 2 (por lo general, un switch).
BENEFICIOS DE UNA VLAN
RANGOS DE ID DE LAS VLAN
VLAN de rango normal VLAN de rango extendido

Se utiliza en redes pequeas y Son utilizadas por los proveedores


medianas. de servicios.

Se identifica mediante un ID de Se identifican mediante un ID de


VLAN entre 1 y 1005. VLAN entre 1006 y 4094.

Los ID de 1002 a 1005 se reservan Admiten menos caractersticas de


para las VLAN Token Ring y FDDI. VLAN que las VLAN de rango normal.

Los ID 1 y 1002 a 1005 se crean Se guardan en el archivo de


automticamente y no se pueden configuracin en ejecucin.
eliminar
VTP no aprende las VLAN de rango
Las configuraciones se almacenan extendido.
dentro de un archivo de datos,
denominado vlan.dat
Un switch de Cisco Catalyst 2960
Usan el protocolo de enlace troncal puede admitir hasta 255 VLAN de
rango normal y extendido,
de la VLAN (VTP) para administrar la
configuracin de las VLAN entre
TIPOS DE VLAN

VLAN DE DATOS: Son las VLAN configurada para enviar slo trfico de
datos generado por el usuario. (no de voz ni de administracin)

VLAN PREDETERMINADA: Todos los puertos de un switch son


miembro de la VLAN predeterminada luego del arranque inicial del
switch. La VLAN predeterminada de los switch Cisco es la VLAN 1.

La VLAN 1 tiene todas las caractersticas de cualquier VLAN, excepto


que no la puede volver a denominar y no la puede eliminar. De manera
predeterminada, el trfico de control de la Capa 2, como CDP, y el trfico
del protocolo spanning tree, estn asociados con la VLAN 1

VLAN NATIVA: Asigna a un puerto


VLAN de administracin:
troncal 802.1Q. Para admitir trfico
Es cualquier VLAN que se
que llega de muchas VLAN (trfico
configura para acceder a las
etiquetado) como tambin el trfico
capacidades administrativas
que no llega de una VLAN (trfico no
de un switch.
etiquetado).
TIPOS DE VLAN
VLAN DE VOZ: Son las VLAN configuradas para admitir exclusivamente
el trfico de la Voz sobre IP (VoIP).
Ancho de banda garantizado para asegurar la calidad de la voz
Prioridad de la transmisin sobre los tipos de trfico de la red
Capacidad para ser enrutado en reas congestionadas de la red
Demora de menos de 150 milisegundos (ms) a travs de la red
CREACIN DE VLAN
Deshabilitar todos los puertos del Switch (Recomendacin)

Switch(config)#interface range fa0/1-24


Switch(config-if-range)#shutdown
Switch(config-if-range)#interface range gi0/1-2
Switch(config-if-range)#shutdown

Habilitar los puertos en uso

S2(config)#interface range fa0/6, fa0/11, fa0/18


S2(config-if-range)#switchport mode access
S2(config-if-range)#no shutdown

Crar las Vlan


S1(config)#vlan 10 Asignar la Interfaces a la Vlan creada
S1(config-vlan)#name redes S3(config)#interface fa0/6
S3(config-if-range)#switchport access
Verificar que las vlan estn creadas vlan 10
S1#show vlan brief
CONFIGURACIN DE LA ADMIISTRACIN DE
SWITCH
Aspectos importantes sobre la interfaz de
administracin
Para manejar un switch en forma remota mediante
TCP/IP, se necesita asignar al switch una direccin
IP, una mascara y un Gateway
CONFIGURACIN DE LA ADMIISTRACIN DE
SWITCH
nfiguracin de la interfaz de administracin
CONFIGURACIN DE LA ADMIISTRACIN DE
SWITCH
onfiguracin del Gateway Predeterminado
CONFIGURACIN DE LA ADMIISTRACIN DE
SWITCH
onfiguracin Duplex y Velocidad
ENLACES TRONCALES

Un enlace troncal es un enlace punto a punto entre dos


dispositivos de red, configurados para transmitir el trfico que
proviene de las VLAN
Un enlace troncal de VLAN no pertenece a una VLAN especfica,
sino que es un conducto para las VLAN entre switches y routers.
ENLACES TRONCALES

Red sin enlaces troncales Red con enlaces troncales


ETIQUETADO DE TRAMA 802.1Q

El encabezado de trama no
contiene la informacin
que indique a qu VLAN
pertenece la trama
CONFIGURACIN DE UN ENLACE TRONCAL

S1(config)#interface range fa0/1-5


S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99
S1(config-if-range)#no shutdown
S1(config-if-range)#end
OPERACIN DE ENLACE TRONCAL
CONFIGURACIN DE LA
ADMIISTRACIN DE SWITCH
CONFIGURACIN DE LA ADMIISTRACIN DE
SWITCH
Para manejar un switch en forma remota mediante TCP/IP,
se necesita asignar al switch una direccin IP, una
mascara y un Gateway
CONFIGURACIN DE LA ADMIISTRACIN DE
SWITCH
nfiguracin de la interfaz de administracin
CONFIGURACIN DE LA ADMIISTRACIN DE
SWITCH
onfiguracin del Gateway Predeterminado
CONFIGURACIN DE LA ADMIISTRACIN DE
SWITCH
onfiguracin Duplex y Velocidad
CONFIGURACIN DE LA ADMIISTRACIN DE
SWITCH
ministracin de la tabla de direcciones MAC

w mac-address-table: Muestra el contenido de la tabla de direcciones

El tiempo de expiracin de las direcciones MAC es de 300 Seg

Para agregar una asignacin esttica: (mac-address-


table static)
Sintaxis: En el modo de configuracin global
mac-address-table static <direccin MAC> vlan {1-4096, ALL}
interface id de la interfaz. Ej.

S1(config)#mac-address-table static 0060.3EDD.19A3


vlan 99 int fa0/24

Para eliminar una asignacin esttica


Se usa el comando: no mac-address-table static <direccin
MAC> vlan {1-4096, ALL} interface id de la interfaz .
CONCEPTOS BSICOS Y CONFIGURACIN DE
SWITCH
Configuracin del puerto de
switch

S1(config)#interface
fa0/18
S1(config-if)#duplex
full
S1(config-if)#speed
100
CONFIGURACIN DE LA ADMISTRACIN BSICA
DEL SWITCH

Por
ejemp
lo

Recordar ARP
Intentar Asignar una
direccin IP a un Nombrar el Sw
puerto Crear Vlan
Duplex
Password

Act 2.3.8
CONFIGURACIN DE LAS VLAN Y LOS ENLACES
TRONCALES
CONFIGURACIN DE LAS VLAN Y LOS ENLACES
TRONCALES
CONFIGURACIN DE LAS VLAN Y LOS ENLACES
Crear la VLAN TRONCALES

Show
vlan
brief
CONFIGURACIN DE LAS VLAN Y LOS ENLACES
TRONCALES
Asignar un puerto de switch
Asignar un puerto de switch

Show
Show
vlan
vlan
brief
name
CONFIGURACIN DE UN ENLACE TRONCAL
PROTOCOLO DE ENLACES TRONCALES (VTP)
OBJETIVOS

Explicar la funcin del VTP en una red conmutada convergente.

Describir la operacin del VTP incluidos dominios, modos,


publicaciones y depuracin.

Configurar el VTP en los switches de una red convergente.


ANTECEDENTES

e
Qu si
a
pas d
re
ce
cre
ANTECEDENTES
QUE ES VTP

El VTP permite al administrador de red configurar un switch de modo que


propague las configuraciones de la VLAN hacia los otros switches en la
red.
COMPONENTES DEL VTP
Dominio del VTP: consiste
en uno o ms switches
interconectados. Un router o
switch de Capa 3 define el
lmite de cada dominio.
Modos del VTP: un switch se
puede configurar en uno de
tres modos: servidor, cliente o
transparente.
Servidor del VTP: Publican
la informacin VLAN del
dominio del VTP a otros
switches habilitados por el
VTP en el mismo dominio del
VTP
Publicaciones del VTP:
Mensajes para distribuir y
sincronizar las
configuraciones de la VLAN a
travs de la red.
COMPONENTES DEL VTP
Cliente del VTP: los clientes
funcionan de la misma manera
que los servidores VTP pero no
pueden crear, cambiar ni
eliminar las VLAN en un cliente
VTP.
VTP transparente: los
switches transparentes envan
publicaciones del VTP a los
clientes VTP y servidores VTP.
Los switches transparentes no
participan en el VTP.

Depuracin del VTP: la


depuracin del VTP aumenta el
ancho de banda disponible para
la red mediante la restriccin del
trfico saturado a esos enlaces
troncales que el trfico debe
utilizar para alcanzar los
dispositivos de destino.
DOMINIOS DEL VTP

El VTP le permite separar su red en dominios de


administracin ms pequeos para ayudarlo a reducir la
administracin de la VLAN.
Publicaciones del VTP

Existen 3 tipos de
publicaciones:
Resumen
Subconjuntos
Solicitud
CONFIGURACIN BSICA DEL VTP

Configuracin del Servidor

S1(config)#vtp mode
server
S1(config)#vtp domain
Lab4
S1(config)#vtp password VTP Transparente
cisco
Configuracin del Cliente
S1(config)#end S3(config)#vtp mode
transparent
S2(config)#vtp mode S3(config)#vtp domain Lab4
client S3(config)#vtp password
cisco
S2(config)#vtp domain
S3(config)#end
Lab4
S2(config)#vtp password
cisco
S2(config)#end
PRCTICA DE LABORATORIO 4.4.1: CONFIGURACIN
BSICA DEL VTP
PROTOCOLO SPANNING-TREE (STP)
PROTOCOLO SPANNING-TREE (STP)

El Protocolo de rbol de Extensin (STP), es un protocolo de capa dos

El objetivo del rbol de extensin es mantener una red libre de


bucles.

i o n
c as
O a
PROTOCOLO SPANNING-TREE (STP)
Tormenta de Broadcast: se produce cuando existen tantas
tramas de broadcast atrapadas en un bucle de Capa 2, que se
consume todo el ancho de banda disponible.
PROTOCOLO SPANNING-TREE (STP)
Tramas de unicast
duplicadas
DHCP

Para asignar automticamente la informacin de direccin en la red, configure el


R2 como servidor de DHCPv4 y el R1 como agente de retransmisin DHCP.
DHCP
R1(config)# interface g0/0
R1(config-if)# ip helper-address 192.168.2.254
R1(config-if)# exit
R1(config-if)# interface g0/1
R1(config-if)# ip helper-address 192.168.2.254

Router R2
R2(config)# ip dhcp excluded-address 192.168.0.1 192.168.0.9
R2(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9
R2(config)# ip dhcp pool R1G1
R2(dhcp-config)# network 192.168.1.0 255.255.255.0
R2(dhcp-config)# default-router 192.168.1.1
R2(dhcp-config)# dns-server 209.165.200.225
R2(dhcp-config)# domain-name ccna-lab.com
R2(dhcp-config)# lease 2
R2(dhcp-config)# exit
R2(config)# ip dhcp pool R1G0
R2(dhcp-config)# network 192.168.0.0 255.255.255.0
R2(dhcp-config)# default-router 192.168.0.1
TRADUCCIN DE DIRECCIONES DE RED PARA
IPv4
OBJETIVOS

Describir las caractersticas de NAT.

Identificar las ventajas y las desventajas de NAT.

Configurar la NAT esttica mediante la CLI.

Configurar la NAT dinmica mediante la CLI.

Configurar PAT mediante la CLI.

Configurar el reenvo de puertos mediante la CLI.

Configurar NAT-PT (de v6 a v4).

Usar los comandos show para verificar el funcionamiento de NAT


ANTECEDENTES DE NAT

El espacio de direcciones IPv4 no es lo suficientemente grande


como para asignar de forma exclusiva una direccin IP a todos los
dispositivos que necesitan una conexin a Internet.

Las direcciones de red privadas se describen en RFC 1918 y estn


diseadas para utilizarse solo dentro de una organizacin o un sitio.

Los routers de Internet no enrutan direcciones privadas, pero s


enrutan direcciones pblicas.

Las direcciones privadas pueden mitigar la escasez de IPv4, pero


dado que los dispositivos de Internet no las enrutan, primero se las
debe traducir.

La NAT se utiliza para realizar esta traduccin.


ANTECEDENTES DE NAT

Problema Solucin
IPv4 No tiene
suficientes
direcciones para Direccionamiento
asignar una Privado (RFC
direccin nica a 1918)
cada host
conectado a la red

NAT
Direccionamiento
Privado no es
enrutables
QUE ES NAT?
NAT es un proceso que se utiliza para traducir direcciones privadas a
direcciones pblicas.
Esto permite que un dispositivo con una direccin IPv4 privada
acceda a recursos fuera de su red privada, como los que se
encuentran en Internet
DONDE SE CONFIGURA NAT?
TERMINOLOGA DE NAT

Red interna:Conjunto de dispositivos que utilizan direcciones privadas. El


resto de las redes son las redes externas.
NAT incluye cuatro tipos de direcciones:
Direccin local interna Direccin global interna
Direccin local externa Direccin global externa
FUNCIONAMIENTO NAT
TIPOS DE NAT

Existen tres tipos de traduccin NAT:


NAT esttica: Mapea una direccin IP privada con una
direccin IP pblica de forma esttica. cada equipo en
la red privada debe tener su correspondiente IP pblica
asignada para poder acceder a Internet.

NAT dinmica: Utiliza un pool de IPs pblicas para un


pool de IPs privadas que sern mapeadas de forma
dinmica de acuerdo a la demanda. .

Traduccin de la direccin del puerto


(PAT):Consiste en utilizar una nica direccin IP
pblica para mapear mltiples direcciones IPs privadas.
Este mtodo tambin se conoce como sobrecarga
(NAT con sobrecarga).
NAT ESTTICA

La NAT esttica consiste en una asignacin uno a uno entre


direcciones locales y globales
CONFIGURACIN DE NAT ESTTICA

Nota: No olvidar que se debe configurar enrutamiento estatico hacia el router


Gateway. Usando la direccin de red dada por el ISP
Paso 1: Configurar el mapeo esttico:
Gateway(config)#ip nat inside source static 192.168.1.20
209.165.200.225
Sh
tr ow
Paso 2: Especificar las interfaces an na ip
Gateway(config)# interface g0/1 sl t
a
s ti o
Gateway(config-if)#ip nat inside n
Gateway(config)# interface s0/0/1
Gateway(config-if)#ip nat outside
NAT DINMICA

La NAT dinmica utiliza un conjunto de direcciones pblicas y las asigna


segn el orden de llegada.
Cuando un dispositivo interno solicita acceso a una red externa, la NAT
dinmica asigna una direccin IPv4 pblica disponible del conjunto.
La NAT dinmica requiere que haya suficientes direcciones pblicas
disponibles para satisfacer la cantidad total de sesiones de usuario
simultneas.
CONFIGURACIN DE NAT DINMICA

Paso 1: Crear una lista de control de acceso que coincida con el rango de
direcciones IP privadas de la LAN
Gateway(config)#access-list 1 permit 192.168.1.0 0.0.0.255

Paso 2: Especificar las interfaces:Ip nat inside e Ip nat outside

Paso 3: Definir el conjunto de Ip pblicas utilizables


Gateway(config)#ip nat pool Nat-Acceso 209.165.200.242 209.165.200.254
netmask 255.255.255.224

Paso 4: Definir Nat desde la lista de origen interna hasta el conjunto externo
Gateway(config)#ip nat inside source list 1 pool Nat-Acceso
NAT DE TRADUCCIN DE LA DIRECCIN
DEL PUERTO (PAT)
PAT asigna varias direcciones IPv4 privadas a una nica direccin IPv4
pblica o a unas pocas direcciones.
PAT utiliza la combinacin de puerto de origen y direccin IP de origen
para poder seguir el trfico que pertenece a cada cliente interno.
PAT tambin se conoce como NAT con sobrecarga.
Mediante el nmero de puerto, PAT tambin puede reenviar los
paquetes de respuesta al dispositivo interno correcto.
El proceso de PAT tambin valida que los paquetes entrantes se hayan
solicitado, lo que aade un grado de seguridad a la sesin.
CONFIGURACIN DE TRADUCCIN DE LA
DIRECCIN DEL PUERTO (PAT)

Paso 1: Configurar el enrutamiento esttico

Paso 2: Definir una lista de control de acceso que coincida con las
direcciones IP privadas de LAN.
Gateway(config)# access-list 1 permit 192.168.1.0 0.0.0.255

Paso 3: Definir el conjunto de direcciones IP pblicas utilizables.


Gateway(config)# ip nat pool public_access 209.165.200.225
209.165.200.230 netmask 255.255.255.248
CONFIGURACIN DE TRADUCCIN DE LA
DIRECCIN DEL PUERTO (PAT)

Paso 4: Definir la NAT desde la lista de origen interna hasta el conjunto


externo.
Gateway(config)# ip nat inside source list 1 pool
public_access overload

Paso 5: Emita los comandos ip nat inside e ip nat outside en las


interfaces.
Gateway(config)# interface g0/1
Gateway(config-if)# ip nat inside
Gateway(config-if)# interface s0/0/1
Gateway(config-if)# ip nat outside
Paso 6:verificar la configuracin del conjunto de NAT con sobrecarga
Gateway# show ip nat statistics
COMPARACIN ENTRE NAT Y PAT
NAT traduce direcciones IPv4 en una relacin de 1:1 entre
direcciones IPv4 privadas y direcciones IPv4 pblicas.
PAT modifica la direccin y el nmero de puerto.
NAT reenva los paquetes entrantes a su destino interno mediante la
direccin IPv4 de origen de entrada proporcionada por el host en la
red pblica.
En general, con PAT hay solo una o muy pocas direcciones IPv4
pblicamente expuestas.
PAT tambin puede traducir protocolos que no utilizan nmeros de
puerto, como ICMP. PAT admite cada uno de estos protocolos de
manera diferente.
VENTAJAS Y DESVENTAJAS DE NAT

Reenvo de puertos
Reenvo de puerto
El reenvo de puertos es el acto de reenviar un puerto de red de
un nodo de red a otro.
Un paquete que se enva a la direccin IP pblica y al puerto de
un router se puede reenviar a una direccin IP privada y a un
puerto en la red interna.
Esto es til en situaciones en las que los servidores tienen
direcciones privadas a las que no se puede llegar desde las redes
externas.
Reenvo de puertos
Ejemplo de SOHO
Reenvo de puertos
Configuracin de reenvo de puertos con
IOS
En IOS, el reenvo de puertos es, bsicamente, una traduccin de
NAT esttica con un nmero de puerto TCP o UDP especfico.
Configuracin de NAT e IPv6
NAT para IPv6?
NAT es una solucin alternativa para la escasez de direcciones
IPv4.
Con una direccin de 128 bits, IPv6 proporciona 340 sextillones
de direcciones.
El espacio de direcciones no presenta un problema para IPv6.
Por su diseo, IPv6 hace que la NAT para IPv4 pblica y privada
sea innecesaria.
Sin embargo, IPv6 implementa una forma de direcciones privadas
que se aplica de una manera diferente que para IPv4.
Configuracin de NAT e IPv6
Direcciones IPv6 locales nicas
Las direcciones IPv6 locales nicas (ULA) estn diseadas para
permitir las comunicaciones IPv6 dentro de un sitio local.
Las ULA no estn diseadas para proporcionar espacio de
direcciones IPv6 adicional.
Las ULA tienen el prefijo FC00::/7, lo que deriva en un primer
rango de hextetos que va de FC00 a FDFF.
Las direcciones locales nicas se definen en RFC 4193.
Las ULA tambin se conocen como direcciones IPv6 locales (que
no se deben confundir con las direcciones IPv6 link-local).
Configuracin de NAT e IPv6
NAT para IPv6?
IPv6 tambin utiliza NAT, pero en un contexto muy diferente.
En IPv6, NAT se utiliza para proporcionar una comunicacin
transparente entre IPv6 e IPv4.
NAT64 no tiene como fin ser una solucin permanente. Est diseada
para ser un mecanismo de transicin.
La traduccin de direcciones de red/traduccin de protocolos (NAT-
PT) era otro mecanismo de transicin basado en NAT para IPv6, pero
el IETF lo dej en desuso.
Ahora se recomienda utilizar NAT64.
Configuracin de NAT e IPv6
NAT para IPv6?
Configuracin de NAT e IPv6
Resolucin de problemas de NAT:
comandos show
Configuracin de NAT e IPv6
Resolucin de problemas de NAT: comando
debug
Captulo11: Resumen

En este captulo, se explic cmo se utiliza NAT para contribuir a


mitigar el agotamiento del espacio de direcciones IPv4.
NAT conserva el espacio de direcciones pblicas y reduce la
sobrecarga administrativa de forma considerable al administrar las
adiciones, los movimientos y las modificaciones.
En este captulo, se analiz la NAT para IPv4, incluido lo siguiente:
Las caractersticas, la terminologa y las operaciones generales de
NAT
Los diferentes tipos de NAT, incluidas la NAT esttica, la NAT
dinmica y la NAT con sobrecarga
Las ventajas y las desventajas de NAT
Captulo 11: Resumen (cont.)
La configuracin, la verificacin y el anlisis de la NAT esttica, la
NAT dinmica y la NAT con sobrecarga
La forma en que se puede usar el reenvo de puertos para acceder
a los dispositivos internos desde Internet
La resolucin de problemas de NAT mediante los comandos show y
debug
La forma en que se utiliza NAT para IPv6 para traducir entre
direcciones IPv6 y direcciones IPv4