Вы находитесь на странице: 1из 133

WELCOME TO

Agenda BDCOM

Chapter 1 BDCOM Company overview

Chapter 2 BDCOM switch products


Professional Network
Technology
Chapter 3 BDCOM Switch Training

2005, BDCOM
Agenda

Chapter 1 BDCOM Company overview

2005, BDCOM
BDCOM Overview
Company name

Shanghai Baud Data Communication Co. Ltd.

Headquarters

Zhangjiang Hi-Tech Park, Pudong, Shanghai

Established June, 1994

Registered capital RMB 50 million (US $6m)

Employees 600

2005, BDCOM
Organisation Chart

Directorate

President

R&D Manufacturing Marketing Services Administration

2005, BDCOM
Human Resource

Administration
9% R&D
Manufacturing 41%
15%

Marketing & Service


35%

2005, BDCOM
Main Customers

2005, BDCOM
Products Lines

BDCOM router series

BDCOM switch series

BDCOM VoIP product series

BDCOM access product series

BDCOM Security firewall series

BDCOM EMS s/w series

2005, BDCOM
Business Relationships
Forms of cooperation
OEM / ODM
Distributorship
Technical cooperation
More than 300 domestic SI agencies are using BDCOM products
in their IT Projects
BDCOM brand name ranked among top 3 domestic middle/low-
end router manufacturers.
Products sold to Europe, America, India, SE Asia, Middle East,
etc.

2005, BDCOM
Agenda

Chapter 2 BDCOM switch products

2005, BDCOM
BDCOM Switches Selling Points

Excellent system design to ensure good performance


Support rich software features and multiple protocols
Multi-function and services
High security: VPN, ACL, firewall and 802.1x etc.
Reliability
Cisco Command easy to manage and troubleshoot
Expansibility
Competitive price, excellent cost-effectiveness

2005, BDCOM
Case Study1: Broadband Carrier
ISP POP
Internet
NMC VRRP
BAS
S5308

DNS S6508 S6508 Reliability by VRRP


Server
Giga
link L3 load balancing and
Mail Server S3224 S3224 100-M router redundancy
link
Single IP/MAC address
for outside access
Distribution Distribution Distribution
s2524 s2524 S2226

S2008 Access S2008 S2116 Access S2116 S2026 Access S2026

2005, BDCOM
Broadband Carrier: Characteristics

BDCOM focuses on devices of the Access


layer
These devices are needed in great quantity
and ordered in lots
Most Access-layer devices are floor
switches
Access-layer devices are simple and not expensive

2005, BDCOM
Case Study2: Campus

2005, BDCOM
Campus: Characteristics

Student apartments require many access points


(switches) over a large area
Access switches need to support 802.1x
accounting/authentication
Must provide gateway to both CERNET and Internet
Must provide tight security through logical
separation of office and apartment networks
Large-scale, wide-spread, 3-layer networks with
redundant core devices
IPv6 test site as required by the Dept. of Education

2005, BDCOM
Case Study3: Government LAN

2005, BDCOM
Government LAN: Characteristics

Densely located, usually in one building


Simple 2-layer (core and access) architecture
Uncomplicated applications requiring only L3
switching
Small scale, easy network management
Gigabit backbone
Access switches is capable of network management

2005, BDCOM
Cast Study4: Financial Services

2005, BDCOM
Financial Services: Characteristics

Core devices provided by Cisco


Most nodes require only one switch
VLAN used to separate transaction network and
office network
Little network management requirement

2005, BDCOM
Visualized Network Management

BDCOM BroadDirector
manages all SNMP-enabled
devices

Monitors in real time the


status and topological
structure of networks
Node coloring shows
changes in network/device
status

2005, BDCOM
BDCOM S2524 Switches

BDCOM S2524

2005, BDCOM
BDCOM S2524 Switches Features (1)

Specification

20 ports 10/100/1000M TX
4 combo SFP Module
1 Console Port Rate 9600bps, RJ 45
AC power supply
Forwarding Mode - Store-and-forward
Support Jumbo Frame up to 12270

2005, BDCOM
BDCOM S2524 Switches Features (2)

Supported Standard

IEEE 802.1D Spanning Tree Protocol

IEEE 802.1p Class of Service


IEEE 802.1q tagged VLAN
IEEE 802.3x Flow control
IEEE 802.3ad Link aggregation
IEEE 802.1AB Link Layer Discovery Protocol

2005, BDCOM
BDCOM S2524 Switches Features (3)

Security

IEEE 802.1x port-based user authentication


Port Mirror, Port Security
Access Control List
Remote authentication through RADIUS
User privilege classification and password protection

2005, BDCOM
BDCOM S2524 Switches Features (4)

Traffic and broadcast management

Broadcast, Unicast, Multicast storm control


IGMP snooping for multicast control
Full and Half duplex traffic control

Rate limit per port 128Kbps step size

2005, BDCOM
BDCOM S2524 Switches Features (5)

Maintenance

Adequate LED indication facilitates switch monitoring and failure


tracing
Automatic negotiation between MDI and MDI-X, automatic
recognition of straight-through and crossover cables
Management via console port, Telnet, Web, SNMP, etc.
Support BDCOM network management tools suite: Broad
Director
Software upgrade through TFTP/Z-MODEM

2005, BDCOM
Agenda

Chapter 3 BDCOM Switch Training

2005, BDCOM
BDCOM
Switch Training

2005, BDCOM
Basic Layer 2 Switching and
Bridging Functions

2005, BDCOM
2002, Cisco Systems, Inc. All rights reserved. 28
Basic Layer2 Switch

Content
1. Overview
2. Transmitting Frames
3. MAC Address Table
4. Broadcast and Multicast frame

2005, BDCOM
Ethernet Switches and Bridges

Address learning
Forward/filter decision
Loop avoidance

2005, BDCOM
Transmitting Frames
Cut-Through Store and Forward
Switch checks destination Complete frame is received
address and immediately and checked before
begins forwarding frame. forwarding.

Fragment-Free
Switch checks the first 64 bytes,
then immediately
begins forwarding frame.

2005, BDCOM
MAC Address Table

Initial MAC address table is empty.

2005, BDCOM
Learning Addresses

Station A sends a frame to station C.


Switch caches the MAC address of station A to port E0 by
learning the source address of data frames.
The frame from station A to station C is flooded out to all
ports except port E0 (unknown unicasts are flooded).
2005, BDCOM
Learning Addresses (Cont.)

Station D sends a frame to station C.


Switch caches the MAC address of station D to port E3 by
learning the source address of data frames.
The frame from station D to station C is flooded out to all
ports except port E3 (unknown unicasts are flooded).
2005, BDCOM
Filtering Frames

Station A sends a frame to station C.


Destination is known; frame is not flooded.

2005, BDCOM
Filtering Frames (Cont.)

Station A sends a frame to station B.


The switch has the address for station B in the MAC
address table.
2005, BDCOM
Broadcast and Multicast Frames

Station D sends a broadcast or multicast frame.


Broadcast and multicast frames are flooded to all ports
other than the originating port.
2005, BDCOM
Redundant Topology Overview

2005, BDCOM
2002, Cisco Systems, Inc. All rights reserved. 38
Redundant Topology

Content
1. Redundant Topology Overview
2. Broadcast Storms
3. Multiple Frame Copies
4. MAC Database Instability
5. Spanning Tree Protocol

2005, BDCOM
Redundant Topology

Redundant topology eliminates single points of failure.


Redundant topology causes broadcast storms, multiple frame copies, and MAC address table
instability problems.

2005, BDCOM
Broadcast Storms

Host X sends a broadcast.


Switches continue to propagate broadcast traffic
over and over.
2005, BDCOM
Multiple Frame Copies

Host X sends a unicast frame to router Y.


MAC address of router Y has not been learned by
either switch yet.
Router Y will receive two copies of the same frame.
2005, BDCOM
MAC Database Instability

Host X sends a unicast frame to router Y.


MAC address of router Y has not been learned by either switch.
Switches A and B learn the MAC address of host X on port 0.
The frame to router Y is flooded.
Switches A and B incorrectly learn the MAC address of Router Y
on port 1.
2005, BDCOM
Spanning-Tree Protocol
Overview

2005, BDCOM
2002, Cisco Systems, Inc. All rights reserved. 44
Spanning-Tree Protocol

Provides a loop-free redundant network topology by


placing certain ports in the blocking state.

2005, BDCOM
Spanning-Tree Operation
One root bridge per network
One root port per nonroot bridge
One designated port per segment
Nondesignated ports are unused

2005, BDCOM
Spanning-Tree Protocol
Root Bridge Selection

Bpdu = Bridge Protocol Data Unit


(default = sent every two seconds)
Root bridge = Bridge with the lowest bridge ID
Bridge ID =

In the example, which switch has the lowest


bridge ID?
2005, BDCOM
Spanning-Tree Port States
Spanning-tree transits each port
through several different states:

2005, BDCOM
Spanning-Tree Port States (Cont.)

2005, BDCOM
Spanning-Tree Path Cost

2005, BDCOM
Spanning-Tree Example

2005, BDCOM
OAM 802.3ah Overview

2005, BDCOM
2002, Cisco Systems, Inc. All rights reserved. 52
OAM Overview
Ethernet OAM protocol for monitoring and
troubleshooting Metro Ethernet Networks which can
implement on any full-duplex point-to-point

2005, BDCOM
OAM Features
Discovery Identified the devices in the networks

Link Monitoring Detects and Indicates link fault

Remote Failure Indicates a loss of signal ( Link Fault )


and a loss of power ( Dying Gasp )

2005, BDCOM
VLAN Operation Overview

2005, BDCOM
2002, Cisco Systems, Inc. All rights reserved. 55
VLAN Operation

Content
1. Segmentation
2. VLAN Overview
3. 802.1Q VLAN Trunk

2005, BDCOM
Segmentation with LAN Switch

A switch eliminates the impact of collision through micro-segmentation


Low latency and high frame-forwarding rates at each interface port
Works with existing 802.3 (CSMA/CD) compliant network interface cards and
cabling

2005, BDCOM
Segmentation with Routers

More manageable, greater functionality, multiple active paths


Broadcast domain
Smaller broadcast

2005, BDCOM
VLAN Overview

Segmentation

Flexibility

Security

A VLAN = A Broadcast Domain = Logical Network (Subnet)

2005, BDCOM
VLAN Operation

Each logical VLAN is like a separate physical bridge.


VLANs can span across multiple switches.
Trunks carry traffic for multiple VLANs.
Trunks use special encapsulation to distinguish between
different VLANs.
2005, BDCOM
VLAN Membership Modes

2005, BDCOM
802.1Q VLAN Trunk

2005, BDCOM
Importance of Native VLANs

2005, BDCOM
Configuring a BDCOM Switch

2005, BDCOM
2002, Cisco Systems, Inc. All rights reserved. 64
BDCOM Switch

Content
1. Connect via Console use Hyper Terminal
2. Overview Switch mode.
3. Default Configuration
4. Configuration IP address, Gateway, Security
Command
5. Upgrade IOS via TFTP

2005, BDCOM
Console CLI

Console port

DB9 pin to
COM port

2005, BDCOM
How to set HyperTerminal?

2005, BDCOM
How to set HyperTerminal?

2005, BDCOM
How to set HyperTerminal?

2005, BDCOM
System Boot Information

System Bootstrap, Version 0.2.5, Serial No:S27060621


Copyright (c) 2005 by Shanghai Baud Data Communication Co., Ltd.
BDCOM-S2524B RISC processor
Current time: 1970-1-1 0:00:00
SDRAM Fast Test...............................PASS!
Flash Fast Test...............................PASS!
RTC Test......................................PASS!
Switch Internal Loopback Test.................PASS!
Loading Switch.bin......
Start Decompress Switch.bin
#################################################
#############
Decompress 1660299 byte. Please wait system up...

System startup OK

Switch console 0 is now available

2005, BDCOM
Software EXEC Mode
There are two main EXEC modes for
entering commands.

2005, BDCOM
Software EXEC Mode

2005, BDCOM
Overview of Switch Modes

2005, BDCOM
BDCOM S2524 Default Configuration

All ports are on.


All ports are in VLAN1.
IP address: 0.0.0.0
Spanning tree: enabled RSTP
Username & Password: none
Console password: none

2005, BDCOM
Port Names on
BDCOM S2524 Switches
Switch#sh run
Building configuration...

Current configuration:
!
version 2.0.1K
service timestamps log date
service timestamps debug date
!
!
spanning-tree mode rstp
!
!
interface GigaEthernet0/1
!
interface GigaEthernet0/2
!
interface GigaEthernet0/3
!
2005, BDCOM
Configuring the
Switch IP Address
BDCOM S2524
1. Setup interface VLAN-id
2. Setup ip address
3. Assign vlan-id at interface

Switch#conf
Switch_config#interface vlan 10
Switch_config_v10#ip address 192.168.1.1 255.255.255.0
Switch_config_v10#exit
Switch_config#int g0/1
Switch_config_g0/1#switchport pvid 10
Switch_config_g0/1#exit
Switch_config#exit
Switch#

2005, BDCOM
Configuring the Switch Default
Gateway

switch(config)#ip default-gateway {ip address}

Configures the switch default gateway for the BDCOM s2524


switches

Switch(config)#ip default-gateway 10.5.5.3

2005, BDCOM
Showing the Switch IP Address

BDCOM S2524 Show IP address on interface VLAN

Switch#sh interface vlan 10


VLAN10 is up, line protocol is down
Hardware is EtherSVI, Address is 00e0.0f92.36c8(00e0.0f92.36c8)
Interface address is 192.168.1.1/24
MTU 1500 bytes, BW 1000000 kbit, DLY 2000 usec
Encapsulation ARPA
ARP type: ARPA, ARP timeout 04:00:00
0 packets input, 0 bytes
Received 0 broadcasts, 0 multicasts
0 input errors, 0 input discards
0 packets output, 0 bytes
Transmited 0 broadcasts, 0 multicasts
0 output errors, 0 discards

2005, BDCOM
Configuring the
Switch Security Command
Configure username & password, enable password for console
and Telnet.

S2224(config)#aaa authentication login default local


S2224(config)#aaa authentication enable default
enable
S2224(config)#username bdcom password bdcom
S2224(config)#enable password bdcom
S2224(config)#service password-encryption

2005, BDCOM
Upgrade Device System

2005, BDCOM
Upgrade via TFTP

1. Set up IP address of TFTP server and Switch in the same network.


2. Ping Test

2005, BDCOM
Upgrade via TFTP

3. Install and Open TFTP server program such as 3CDaemon

2005, BDCOM
Upgrade via TFTP

4. Click Configure TFTP Server and select Directory keep IOS.

2005, BDCOM
Upgrade via TFTP

5. Type command into Switch.

Switch#copy tftp flash ---------------------Copy .bin file into router FLASH


Source file name[]?Switch.bin --------------File name in TFTP Server
Remote-server ip address[]?192.168.1.2 -----TFTP server IP address
Destination file name[Switch.bin]? ---------Keep the old file name
######################################################################
######################################################################
######################################################################
TFTP:successfully receive 12028 blocks ,6158179 bytes
-----Succeed upgrading
Switch#reboot ------------------------------- Reboot Switch

2005, BDCOM
Basic Command

Basic Command
1. Configure Hostname and Description
2. Configure Duplex
3. Configure Speed
4. Show MAC Address table
5. Save and Clear NVRAM

2005, BDCOM
Hostname and Description
Hostname
Default hostname is Switch
Change hostname use hostname command.

Switch#conf
Switch_config#hostname CAT-PATTAYA
CAT-PATTAYA_config#

Description
Add description at port.

CAT-PATTAYA_config_g0/1#
CAT-PATTAYA_config_g0/1#description connect_DSLAM
CAT-PATTAYA_config_g0/1#

2005, BDCOM
Duplex Overview

Half Duplex (CSMA/CD)


Unidirectional data flow
Higher potential for collision
Hubs connectivity

Full Duplex
Point-to-point only
Attached to dedicated switched port
Requires full-duplex support on both ends
Collision-free
Collision detect circuit disabled

2005, BDCOM
Setting Duplex Options

BDCOM S2524

Switch_config#int g0/1
Switch_config_g0/1#duplex ?
auto -- Enable AUTO duplex configuration
full -- Force full duplex operation
half -- Force half-duplex operation

2005, BDCOM
Setting Speed Options

BDCOM S2524

Switch_config#int g0/1
Switch_config_g0/1#speed ?
10 -- Force 10 Mbps operation
100 -- Force 100 Mbps operation
1000 -- Force 1000 Mbps operation
auto -- Enable AUTO speed configuration

2005, BDCOM
Showing Duplex and Speed

Switch#sh int g0/1


GigaEthernet0/1 is down, line protocol is down
Hardware is GigaEthernet-TX, address is 00e0.0f92.36c9 (bia 00e0.0f92.36c9)
MTU 1500 bytes, BW 1000000 kbit, DLY 10 usec
Encapsulation ARPA
Half-duplex, 10Mb/s
flow-control off
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
Received 0 packets, 0 bytes
0 broadcasts, 0 multicasts
0 discard
Transmited 0 packets, 0 bytes
0 broadcasts, 0 multicasts
0 discard

2005, BDCOM
Show MAC Address Table
BDCOM S2524

Switch#sh mac address-table


Mac Address Table
------------------------------------------

Vlan Mac Address Type Ports


---- ----------- ---- -----
1 001f.3c9a.c7f5 DYNAMIC g0/1
1 0010.c6cd.53f3 DYNAMIC g0/2
1 001f.3c24.2a7b DYNAMIC g0/2
1 000e.9ba3.dc1c DYNAMIC g0/2
1 0012.3fbc.0b4f DYNAMIC g0/2
1 00e0.0f2c.3163 DYNAMIC g0/2
1 0004.ed42.66d7 DYNAMIC g0/2
1 0012.f04b.7ffe DYNAMIC g0/1
1 001f.3c24.5d37 DYNAMIC g0/1
1 00c0.9f85.3c33 DYNAMIC g0/1
1 0012.3fbc.19a5 DYNAMIC g0/2
Total Mac Addresses for this criterion: 11
2005, BDCOM
Saving Configurations

switch#
Switch#wr
Saving current configuration...
OK!
Switch#

Copies the current configuration to NVRAM

2005, BDCOM
Clearing NVRAM

Switch#delete
this file will be erased,are you sure?(y/n)y
Switch#

Resets the system configuration to factory defaults

2005, BDCOM
Advance Configure

2005, BDCOM 94
Advance Configure

Advance Configure
1. MAC Address Security
2. VLAN and 802.1Q VLAN Trunk
3. Spanning Tree Configuration ( STP )
4. CAR Configuration
5. System MTU Configuration

2005, BDCOM
Advance Configure

Advance Confiugre
6. SNMP Configuration
7. LLDP Configuration
8. Port Aggregation Configure
9. 802.3ah Configure
10. Password Recovery

2005, BDCOM
MAC Address Security

MAC Address Security


Reject or Accept MAC address at port.

Switch#conf
Switch_config#int g0/1
Switch_config_g0/1#switchport port-security mode static
accept -- Accept mode
reject -- Reject mode

2005, BDCOM
MAC Address Security

MAC Address Security


Reject MAC address 00:0e:35:c2:14:8a connect at port G0/1.

interface GigaEthernet0/4
switchport port-security static mac-address 0022.b061.917d
switchport port-security mode static reject

2005, BDCOM
VLAN Configuration Guidelines

VLAN1 is the factory default Ethernet VLAN.


By factory default, all ports on BDCOM switch are
membership of VLAN1.
The BDCOM switch IP address is in the management
VLAN (VLAN1 by default).

2005, BDCOM
Adding a VLAN

BDCOM S2524

Switch#config
Switch_config_#vlan 9
Switch_config_vlan9#name vlan9

2005, BDCOM
Assigning Switch Ports to a VLAN
BDCOM S2524

switch(config-if)#switchport pvid vlan#

Example

Switch#conf
Switch_config#int g 0/1
Switch_config_g0/1#switchport pvid 9

2005, BDCOM
Verifying a VLAN

The show vlan command

Switch_config#show vlan
VLAN Status Name Ports
---- ------- ---------------- ------------------------------------
1 Static Default G0/1, G0/2, G0/3, G0/4, G0/5
G0/6, G0/7, G0/8, G0/9, G0/10
G0/11, G0/12, G0/13, G0/14, G0/15
G0/16, G0/17, G0/18, G0/19, G0/20
G0/21, G0/22, G0/23, G0/24
9 Static vlan9

2005, BDCOM
802.1Q VLAN Trunk

802.1Q VLAN Trunk Tag VLAN in 1 port

2005, BDCOM
Configuring 802.1Q VLAN Trunk

config-if)#switchport mode trunk

Configures the port as a VLAN trunk

Example

Switch_config#int g0/1
Switch_config_g0/1#switchport mode trunk

2005, BDCOM
Troubleshooting Switched LANs

2005, BDCOM
Problem: One Device Cannot
Communicate with Another

Make sure the IP address, subnet mask, and VLAN


membership of the switch interface is correct.
If the host is in the same subnet as the switch interface,
make sure the switch interface and the switch port to which
the host is connected are assigned to the same VLAN.
If the host is in a different subnet, make sure the default
gateway on the switch is configured with the address of a
router in the same subnet as the switch interface.

2005, BDCOM
Problem: One Device Cannot
Communicate with Another (Cont.)

If the port is in listening or learning mode, wait until the


port is in forwarding mode and try to connect to the host
again.
Make sure the speed and duplex settings on the host and
the appropriate switch ports are correct.
If the connected device is an end station, enable
spanning-tree PortFast, disable trunking, and disable
chaneling on the port.
Make sure the switch is learning the MAC address of
the host.

2005, BDCOM
Problem: A Device Cannot Establish a
Connection Across a Trunk Link

Make sure the trunking mode configured on both


ends of the link is valid. The trunking mode
should be on or desirable on one end and on,
desirable, or auto on the other end.
Make sure the trunk encapsulation type
configured on both ends of the link is valid.
On IEEE 802.1Q trunks, make sure the native
VLAN is the same on both ends of the trunk.

2005, BDCOM
Configuration
Spanning Tree Protocol

Switch_config#spanning-tree mode ?
sstp -- Setup spanning-tree protocol sstp mode
rstp -- Setup rapid spanning-tree protocol mode

Example

Switch#conf
Switch_config#spanning-tree mode rstp
Switch_config#spanning-tree rstp priority 32768

2005, BDCOM
Verifying Spanning Tree Protocol
The show spanning-tree command
Switch#sh spanning-tree

Spanning tree enabled protocol RSTP

RSTP
Root ID Priority 0
Address 00E0.0F8B.4487
Cost 200019
Hello/MaxAge/FwdDly 4/20/15 (s)

Bridge ID Priority 32768


Address 00E0.0F92.36C8
Hello/MaxAge/FwdDly 4/20/15 (s)

Intf Port ID Designated Port ID


Name Pri.Nbr Role Sts Cost Bridge ID Pri.Nbr Cost
------- ------- ---- --- --------- -------------------- ------- --------
G0/1 128.1 Desg FWD 200000 32768 00E0.0F92.36C8 128.1 200019
G0/2 128.2 Root FWD 200000 32768 00E0.0F2C.315B 128.8 19
G0/22 128.22 Desg FWD 200000 32768 00E0.0F92.36C8 128.22 200019
G0/24 128.24 Desg FWD 200000 32768 00E0.0F92.36C8 128.24 200019
2005, BDCOM
CAR Configure

CAR Commit Access Rate


Limit bandwidth of switch port.

Switch#conf
Switch#int g0/1
Switch_config_g0/1#switchport rate-limit ?
<1-31> -- Configure Bandwidth(unit:128kbps)

2005, BDCOM
CAR Configure

Example
Limit bandwidth 128Kbps

Switch#conf
Switch#int g0/1
Switch_config_g0/1#switchport rate-limit 1 ingress
Switch_config_g0/1#switchport rate-limit 1 egress

2005, BDCOM
MTU Configure

MTU Maximum Transfer Unit


Configure MTU more than 1500 bytes

Switch#conf
Switch_config#system mtu ?
<1500-12270> MTU size in bytes

2005, BDCOM
MTU Configure

MTU Configure
Configure MTU 1530 bytes

Switch#conf
Switch_config#system mtu 1530
Switch_config#

Show system MTU

Switch#show system mtu


System MTU size is 1530 bytes
Switch#

2005, BDCOM
SNMP Configure

SNMP Simple Network Management Protocol


Configure SNMP community for use with SNMP software
such as BroadDirector.

Switch#conf
Switch_config#snmp-server community ?
WORD -- SNMP community string

2005, BDCOM
SNMP Configure

SNMP Simple Network Management Protocol


Configure SNMP community public and private

Switch#conf
Switch_config#snmp-server community public rw
Switch_config#snmp-server community public ro

2005, BDCOM
LLDP Configure

LLDP Link Layer Discover Protocol


Update information between switch.

Switch#conf
Switch_config#lldp ?
holdtime -- Specify the holdtime (in sec) to be sent in packets
reinit -- Delay (in sec) for LLDP initialization on any interface
run -- Enable PTOPO discovery protocol to run
timer -- Specify the interval at which packets are sent
tlv-select -- Selection of LLDP TLVs to send

2005, BDCOM
LLDP Configure

Show lldp neighbors

Switch#show lldp neighbors


Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device-ID Local-Intf Hldtme Port-ID Platform Capability


Switch Giga0/4 141 Giga0/8 BDCOM S2524, RISC S

2005, BDCOM
LLDP Configure

Show lldp neighbors detail

Switch#sh lldp neighbor detail

Device ID: Switch


Entry address(es): IP address: 192.168.2.51
Platform: BDCOM S2524, RISC processor, Capabilities: Switch
Interface: GigaEthernet0/4, Port ID(outgoing port): GigaEthernet0/8
Holdtime : 142 sec

Version :
BDCOM(tm) S2524 Software, Version 2.0.1L
Serial: S24001986, System Address: 00E00F2C315B
Copyright by Shanghai Baud Data Communication CO. LTD.
Compiled: 2006-3-6 14:7:40 by TAN-WORK

advertisement version:2
Native VLAN: 1
Duplex: full(01)
2005, BDCOM
Port Aggregation Configure

Port Aggregation or Port trunking


Eliminate bottleneck between switch.

Switch#conf
Switch_config#int port-aggregator ?
<1-12> -- Port-aggregator interface number

Switch_config#int g0/1
Switch_config_g0/1#aggregator-group ?
<1-12> -- aggregator group number

2005, BDCOM
Port Aggregation Configure

Port Aggregation Configure

interface Port-aggregator1
!
interface GigaEthernet0/1
aggregator-group 1 mode static
!
interface GigaEthernet0/2
aggregator-group 1 mode static

Configure both switch 1 and switch 2.

2005, BDCOM
802.3ah Configure

1. Discovery

DUT1_config#interface gigaEthernet 0/1


DUT1_config_g0/1#ethernet oam

DUT2_config#interface gigaEthernet 0/1


DUT2_config_g0/1#ethernet oam

Result
DUT1 and DUT2 will detect MAC address of each other by show ethernet oam discovery.

2005, BDCOM
802.3ah Configure

2. Link- Monitor

DUT1_config#interface gigaEthernet 0/1


DUT1_config_g0/1#ethernet oam

DUT2_config#interface gigaEthernet 0/1


DUT2_config_g0/1#ethernet oam

Result
When interfaces G0/1 of DUT1 and DUT2 receive error frames, the following information
appears and you can browse it by running show ethernet oam statistics link-monitor

2005, BDCOM
802.3ah Configure

3. Remote - Failure

DUT1_config#interface gigaEthernet 0/1


DUT1_config_g0/1#ethernet oam

DUT2_config#interface gigaEthernet 0/1


DUT2_config_g0/1#ethernet oam

Result
When DUT1 power off Dying Gasp alarm display which browse it by running show
ethernet oam statistics remote-failure interface GigaEthernet 0/1

2005, BDCOM
Password Recovery

Password Recovery
Go to monitor mode for check your username & password.
Reboot and pressing ctrl-p make switches go to monitor mode

System Bootstrap, Version 0.2.5, Serial No:S27060621


Copyright (c) 1994-2005 by Shanghai Baud Data Communication Co., Ltd.
BDCOM-S2524B RISC processor
Current time: 1970-1-1 0:00:00
SDRAM Fast Test...............................PASS!
Flash Fast Test...............................PASS!
RTC Test......................................PASS!
Switch Internal Loopback Test.................PASS!

Welcome to S2524B Ethernet Switch

monitor#

2005, BDCOM
Password Recovery

Type show configuration command.


monitor#show configuration
version 2.0.1N
service timestamps log date
service timestamps debug date
!
!
spanning-tree mode rstp
!
!
!
aaa authentication login default local
aaa authentication enable default enable
!
username admin password 0 admin
enable password 0 admin level 15
2005, BDCOM
Password Recovery

If your password was encryption.


monitor#show configuration
version 2.0.1N
service timestamps log date
service timestamps debug date
!
!
spanning-tree mode rstp
!
!
!
aaa authentication login default local
aaa authentication enable default enable
!
username admin password 7 101b433d384f
enable password 7 101B433D384F level 15
2005, BDCOM
Password Recovery
Save your configure before delete configure.

2005, BDCOM
Password Recovery
Select directory for keep configure file.

2005, BDCOM
Password Recovery
show configuration.

2005, BDCOM
Password Recovery
Stop Capture Text .

2005, BDCOM
Password Recovery
Delete configure and reboot.

2005, BDCOM
Question & Answer

2005, BDCOM