Вы находитесь на странице: 1из 18

ESTRUCTURAS SELECTIVAS

En las estructuras
Se utilizan para selectivas se evalúa
tomar decisiones una condición, y en
lógicas función del resultado
de la misma se toma
también se conocen como: un camino u otro.
estructuras de decisión o alternativas.
SINTAXIS
ESTRUCTURA SELECTIVA SIMPLE

Esta compuesta
únicamente de una
sola condición si es
verdadera ejecutara
la acción o acciones
si la condición es
falsa no hará nada
EJEMPLO
Se desea implementar un algoritmo para
determinar si una persona es mayor de edad
(a partir de los 18 años), para ello se debe
solicitar que ingrese la edad por teclado.
ANÁLISIS
1.- Se necesita ingresar la edad de una persona
20 años  edad
2.- se necesita hacer una comparación para conocer
si es mayor de edad
edad >= 18
3.- Realizada la comparación se debe mostrar:
Si es verdadera Usted es mayor de edad ó Falsa nada
Elementos de entrada edad

Proceso
edad > =18

Comparación para conocer Usted es

si es mayor de edad mayor de edad

Elementos de salida

Mensaje de mayor de edad o nada


proceso ProgramaEdad
PSEUDOCÓDIGO
Edad<-0;
Escribir “Programa que determina si es mayor de edad";
Escribir "Ingrese su edad";
Leer edad;
Si edad >= 18 Entonces
Escribir “Usted es mayor de edad”;
FinSi
FinProceso
DIAGRAMA DE FLUJO
ESTRUCTURA SELECTIVA DOBLE

Esta compuesta únicamente


de una sola condición si es
verdadera ejecutara la
acción o acciones y si la
condición es falsa ejecutara
las acciones para la
condición falsa
EJERCICIO
Se desea implementar un algoritmo para
determinar el mayor de dos números
ingresados por teclado. Representarlo con
pseudocódigo y diagrama de flujo
ANÁLISIS
1.- se necesita 2 números
5  num1 8  num2

2.- se necesita hacer una comparación


num1 > num2
3.- Realizada la comparación se debe mostrar:
num1 Si num1 es mayor ó num2 Si num2 es mayor
Elementos de entrada num1 num2

Proceso num1 > num2

Comparación para “ num1 es > “ “ num2 es > “

conocer el mayor

Elementos de salida
El mayor de los dos números
proceso Mayor2numeros PSEUDOCÓDIGO
num1<-0;
num2<-0;
Escribir “Programa que determina el mayor de dos números";
Escribir “Ingrese el primer numero";
Leer num1;
Escribir “Ingrese el segundo numero";
Leer num2;
Si num1>num2 Entonces
Escribir "El mayor de los dos números ingresados es:", num1;
SiNo
Escribir "El mayor de los dos números ingresados es:", num2;
FinSi
FinProceso
DIAGRAMA DE FLUJO
TAREA 1
Se desea implementar un algoritmo para
determinar que dado como dato la calificación
de un alumno en un examen, escriba aprobado
en caso que la calificación obtenida sea mayor
o igual a 7
TAREA 2
Se desea implementar un algoritmo para
determinar el menor de dos números
ingresados por teclado. Representarlo con
pseudocódigo, diagrama de flujo
TAREA 3
Realice un algoritmo para determinar si un número
es positivo o negativo. Represéntelo en
pseudocódigo y diagrama de flujo