Вы находитесь на странице: 1из 34

Configuring Routers

Oh No! I’ve got to program a router!

What do I have to do
Log on to the router

Router>
Router>enable
Router#
Router#config t

Config t is the place to be!


Name the router!
Step One

Router(config)#hostname Lab-A

Lab-A
Password protect the Privilege
Mode
Step Two
Lab-A(config)#enable secret class

Commands Password
Results in:
enable secret 5 $1$emBK$WxqLahy7YOAf0nifub.hU
Configure the Interfaces

Step Three

Lab-A(config)#interface serial 0
Lab-A(config-if)#

(Note prompt change)


Address the Interface(S0)

Lab-A(config-if)#ip address 201.100.11.1 255.255.255.0

Ip address Subnet mask

S0
S0=201.100.11.1
Clock ticks MUST be set
between routers on the interface
with the serial cable DCE end.

Serial0 is where the


DCE connects in our
lab.
We use Serial0

• Lab-A(config-if)#clock rate 56000


Address the next Interface (E0)
Lab-A(config-if)#interface ethernet 0

(This changes to program interface e0)


Lab-A(config-if)#ip address 192.5.5.1 255.255.255.0
E0=192.5.5.1
E0
S0
S0=201.100.11.1
Address the next Interface (e1)
Lab-A(config-if)#interface ethernet 1

(This changes to program interface e1)


Lab-A(config-if)#ip address 205.7.5.1 255.255.255.0
E0=192.5.5.1 S1=No address
E0
S0 E1
S0=201.100.11.1
E1=205.7.5.1
Control z

Lab-A#
Lab-A#show running-config
Results:
• version 12.0
• service timestamps debug uptime
• service timestamps log uptime
• no service password-encryption
• service udp-small-servers
• service tcp-small-servers
• !
• hostname Lab-A
• !
• enable secret 5 $1$emBK$WxqLahy7YOAf0nifub.hU.
• !
• ip subnet-zero

--More--
interface Ethernet0
ip address 192.5.5.1 255.255.255.0
no ip directed-broadcast
shutdown
!
interface Ethernet1
ip address 205.7.5.1 255.255.255.0
no ip directed-broadcast
shutdown
--More--
interface Serial0
ip address 201.100.11.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
clockrate 56000
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
Like people, routers have to talk
to one another!
Like people, routers have to talk
to one another!

Step Four

Set up routing protocols


Routing Protocols:

RIP RIPv2
IGRP EIGRP
OSPF
Set up the routing protocol

Lab-A(config)#router rip
(Note prompt change)

Lab-A(config-router)#network 192.5.5.0
Lab-A(config-router)#network 205.7.5.0
Lab-A(config-router)#network 201.100.11.0
Note!
• You have to configure for EACH network
• (remember network # is the “wire” #)
• Each network is on a separate line
• Hit Control z to activate and return to:

• Lab-A#
Lab-A#show run
(router portion of show run)

!
router rip
network 192.5.5.0
network 201.100.11.0
network 205.7.5.0
!
Control Access

Control and secure access from:


CONSOLE
VTY (telnet)
AUX (modem)
Control Access
Step Five

Lab-A(config)#line console 0
Lab-A(config-line)#password cisco

(Note prompt change)

Lab-A(config-line)#login
Continue

Lab-A(config)#line vty 0 4
Lab-A(config-line)#password cisco
Lab-A(config-line)#login
Control Z
(typing the word “exit” at the prompt takes
you up one level)
Lab-A#show run will give the following results:
line con 0
password cisco
login
transport input none
line aux 0
line vty 0 4
password cisco
login
Want to save time and move fast
between routers?

Step Six
A REAL time Saver!

Lab_A(config)#ip host Lab_A 192.5.5.1 205.7.5.1 201.100.11.1


Lab_A(config)#ip host Lab_B 219.17.100.1 199.6.13.1 201.100.11.2
Lab_A(config)#ip host Lab_C 223.8.151.1 204.204.7.1 199.6.13.2
Lab_A(config)#ip host Lab_D 210.93.105.1 204.204.7.2
Lab_A(config)#ip host Lab_E 210.93.105.2
Lab_A(config)# ^z
Turn on the interfaces:
Step Seven
• Lab-A(config)#interface s0
• Lab-A(config-if)#no shutdown
• Lab-A(config-if)#interface e0
• Lab-A(config-if)#no shutdown
• Lab-A(config-if)#interface e1
• Lab-A(config-if)#no shutdown
For Lab-A router, you
are through!
Program the other routers the
same way, BUT:
• Use the interfaces in use on each particular
router
• Use the correct ip address/network address
for each port on that router
• Check and save your configuration!
• Router#show run (Check)
• Router#copy run start (Save)
Let’s Review:
• Step 1 – name router
• Hostname xxxxx
• Step 2 – set “privilege” password and
encode it
• Enable secret xxxxx
• Step 3 – configure interfaces
• Interface sX (or eX)
• Step 4 – Set the routing protocols
• Router rip
• Step 5 – Set who and where access comes
from
• Line console (vty)
• Step 6 – Save Time
• Ip host xxx.xxx.xxx yyy.yyy.yyy
• Step 7 – Turn on interfaces
• Router(config-if)#no shutdown
Check and Save your work!
• Check your config
• Router#show run
• Save your configuration from RAM to
NVRAM
• Router#copy run start
You’re Through!

Вам также может понравиться