Вы находитесь на странице: 1из 50

Protocolo BGP Configuración

 Introducción
 Análisis de BGP
Protocolo BGP  Configuración
Propiedad intelectual de Daniel Díaz @ 2014

Profesor Daniel Díaz Ataucuri


Profesor Titular de Telecomunicaciones
Universidad Nacional de Ingeniería

ddiaz@inictel-uni.edu.pe
Universidad Nacional Mayor de San Marcos

http://www.danieldiaza.com
ddiaz@inictel-uni.edu.pe
ddiaz1610@gmail.com

Lima, Enero– Diciembre de 2014


INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

INTRODUCCIÓN
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

LAN 1 LAN 2 LAN 4 LAN 5


Sistema Autónomo
Sistema Autónomo

Se como Se como
como
Se como Se
llegar a llegar aa
llegar a llegar
LAN a, b y LAN
LAN a, b LAN a, a,bby
4,5,6 1,2,3

LAN 1, 2, 3, LAN 4, 5, 6,
Propiedad intelectual de Daniel Díaz @ 2014

LAN 3 etc Se Sistema Autónomo Se como etc LAN 6


Se como
como Se como
llegar llegar a
llegar aa llegar a
LAN LAN 4,5,6 y
LAN1,2,3
1,2,3y LAN 4,5,6
4,5,6 1,2,3
eBGP eBGP

iBGP

ddiaz@inictel-uni.edu.pe
LAN a, b, LAN a, b,
etc etc
Cada router
de borde
tienen dos tablas
LAN a LAN b

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo BGP Configuración

RFC 4271: A Border Gateway Protocol 4 (BGP-4)


BGP es un protocolo de vector distancia avanzado.
► Utiliza TCP para obtener una comunicación confiable.
► Utiliza el puerto 179 de TCP.
Distancia administrativa
► iBGP tiene una distancia administrativa de 200.
► eBGP tiene una distancia administrativa de 20.
Propiedad intelectual de Daniel Díaz @ 2014

Al inicio de la conexión BGP intercambia las tablas


de enrutamiento completamente
► Después sólo se envía los cambios.

ddiaz@inictel-uni.edu.pe
► Se envían las nuevas rutas y las que no existen (withdraw)
Mensaje BGP tiene entre 19 y 4096 bytes de longitud
BGP envía mensajes keepalive en vez de hello.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

0 8 16 31

Ver HLEN ToS Longitud Total

Identificador Indicador/Desplazam.
Protocolo
TTL Suma de Chequeo
06
Dirección IP de Origen

Dirección IP de Destino
Propiedad intelectual de Daniel Díaz @ 2014

TCP, Puerto 179

ddiaz@inictel-uni.edu.pe
Protocolo BGP

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo BGP Configuración

RFC 4271: A Border Gateway Protocol 4 (BGP-4)


Formato Cabecera de Mensaje (http://www6.ietf.org/rfc/rfc4271)
0 7 8 15 16 23 24 31

Marcador
► Cada mensaje tiene una
Marcador
cabecera de tamaño fija.
Marcador
► Estos mensajes pueden tener
Marcador
una porción de datos o no.
Longitud Tipo ► Marcador.- Campo de 16
Propiedad intelectual de Daniel Díaz @ 2014

bytes y debe estar en UNOS.


► Longitud.- Campo de 02 bytes e indica el total del mensaje.
Permite localizar el siguiente mensaje dentro del flujo TCP.
El valor de este campo varía entre 19 y 4096 bytes.

ddiaz@inictel-uni.edu.pe
► Tipo.- Campo de 01 byte e indica el tipo de mensaje.
Valor Mensaje Valor Mensaje Valor Mensaje
1 OPEN 3 NOTIFICATION 5 ROUTE-REFRESH
(rfc 2918)
2 UPDATE 4 KEEPALIVE

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo BGP Configuración

RFC 4271: A Border Gateway Protocol 4 (BGP-4)


Después de establecer la conexión TCP, el primer
mensaje enviado por cada lado es el mensaje OPEN.
► Si el mensaje OPEN es aceptado, un mensaje KEEPALIVE
confirmando el OPEN es enviado de retorno.
0 7 8 15 16 23 24 31
► Versión.- Indica la versión
Versión del protocolo. Está en 4.
Mi Sistema Autónomo Tiempo de espera
Propiedad intelectual de Daniel Díaz @ 2014

► Mi Sistema Autónomo.- De
Identificador BGP
02 bytes e indica el número
Long. Parámetro Marcador
Opcional del sistema autónomo del
Marcador
que envía el mensaje.

ddiaz@inictel-uni.edu.pe
► Tiempo de espera.- De 02 bytes e indica el número de segundos
que el emisor del mensaje propone para el valor de tiempo de
espera. Es el tiempo máximo entre dos KEEPALIVE sucesivos.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

RFC 4271: A Border Gateway Protocol 4 (BGP-4)

0 7 8 15 16 23 24 31 ► Identificador BGP.- Campo


Versión de 04 bytes e identifica el BGP.
Mi Sistema Autónomo Tiempo de espera Es un número IP de sus interfaces
Identificador BGP ► Long. de Parámetro
Long. Parámetro Opcional.- Campo de 01 bytes
Opcional

Parámetros Opcionales (variable) e indica la longitud total del


campo Parámetros Opcionales.
Propiedad intelectual de Daniel Díaz @ 2014

Si este campo está en CERO,


no se usa Parámetros Opcional.
Parámetros Opcionales

ddiaz@inictel-uni.edu.pe
► Contiene una lista de parámetros opcionales; donde cada
parámetro presenta los siguientes campos: Mínimo valor
0 7 8 15
del mensaje
Tipo de Longitud de Valor del Parámetro (variable) OPEN es de
Parámetro Parámetro 29 bytes

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo BGP Configuración

Mensaje KEEPALIVE
► Debe ser enviado periódicamente para asegurar que la conexión
está disponible.
► Un mensaje KEEPALIVE consiste solo de la cabecera del mensaje
BGP y tiene una longitud de 19 bytes.
Lo 0: 44.4.4.4/32
Propiedad intelectual de Daniel Díaz @ 2014

Router de Router de
borde R6 borde Rg
15.5.5.1 15.5.5.2

Sistema Autónomo Sistema Autónomo

ddiaz@inictel-uni.edu.pe
4000 2000

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo BGP Configuración

0 7 8 15 16 23 24 31 0 7 8 15 16 23 24 31

FF FF Marcador FF FF FF FF Marcador FF FF

Cabecera BGP

Cabecera BGP
FF FF Marcador FF FF FF FF Marcador FF FF

FF FF Marcador FF FF FF FF Marcador FF FF

FF FF Marcador FF FF FF FF Marcador FF FF

00 2D 01 00 13 04
Longitud (45) Tipo Longitud (19 Bytes) Tipo
Propiedad intelectual de Daniel Díaz @ 2014

Mensaje OPEN Mensaje


04 KEEPALIVE
Versión
OF A0 00 B4
Sistema Autónomo (4000) Tiempo de espera (180 seg)
1B 07 07 06

ddiaz@inictel-uni.edu.pe
Identificador BGP (27.7.7.6)
10
16 bytes de log.
Parámetros Opcionales (variable)

INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI


Protocolo BGP Configuración

RFC 4271: A Border Gateway Protocol 4 (BGP-4)


Son usados para transferir información de
enrutamiento entre pares BGP (BGP peers).
► La información en el mensaje UPDATE puede ser usado para
construir un gráfico que describe la relación entre varios Sistemas
Autónomos.
Formato del Mensaje UPDATE.
Propiedad intelectual de Daniel Díaz @ 2014

► Longitud de Rutas Retiradas (Withdrawn


Longitud del campo “Rutas
Retiradas” (02 bytes) Routes Length).- Campo de 02 bytes, indica
Rutas Retiradas (variable)

Longitud del campo “Path


la longitud total de campo “Rutas Retiradas”.
Attribute” (02 bytes)
Un valor 0 en este campo indica que ninguna

ddiaz@inictel-uni.edu.pe
Path attribute (variable)

Información de Capa de
ruta está siendo retirada de servicio y que el
Red accesible (variable)
campo “Rutas Retiradas” no está en UPDATE
► Rutas Retiradas (Withdrawn Routes).- Campo variable y
contiene una lista de prefijos IP de las rutas retiradas de servicio.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

RFC 4271: A Border Gateway Protocol 4 (BGP-4)

Longitud del campo “Rutas ► Longitud de Atributo de trayecto (Path


Retiradas” (02 bytes)
Rutas Retiradas (variable) Attribute).- Campo de 02 bytes, indica
Longitud del campo “Path
Attribute” (02 bytes)
la longitud total de campo “Atributo de
Path attribute (variable)
trayecto”.
Información de Capa de
Red accesible (variable)

► Atributo de trayecto (Path Attribute).- Campo variable y


Propiedad intelectual de Daniel Díaz @ 2014

y contiene una secuencia de atributos (excepto en mensajes


UPDATE que lleva rutas retiradas).Detalles en pag. 23 RFC 4271

Cada atributo contiene:

ddiaz@inictel-uni.edu.pe
<Tipo de atributo, longitud de atributo, valor de atributo>
ORIGIN, AS_PATH, NEXT_HOP,
Flag atributo Tipo Código atributo MULTI_EXIT_DISC_LOCAL_PREF,
ATOMIC_AGGREGATE,
AGGREGATOR
Tipo de atributo
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

RFC 4271: A Border Gateway Protocol 4 (BGP-4)


El mensaje NOTIFICATION es enviado cuando una
condición de error es detectado.
► La conexión BGP es cerrado inmediatamente después que se
envíe este mensaje.

0 7 8 15

Código de Subcódigo de Datos (variable)


Propiedad intelectual de Daniel Díaz @ 2014

Error
Detalles en Pag. 30 RFC 4271
Error

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

Los mensajes de actualización BGP incluyen


información sobre la métrica BGP.
► Se conoce como ATRIBUTOS DE RUTA.
Atributo obligatorio bien conocido:
Debe aparecer en la descripción de
una ruta.
 Ruta de sistema autónomo
Propiedad intelectual de Daniel Díaz @ 2014

Atributos bien conocido  Próximo salto


Todas las implementaciones  Origen, etc
BGP lo deben reconocer Atributo discrecional bien conocido:

ddiaz@inictel-uni.edu.pe
No necesita aparecer en la
descripción de una ruta.
 Preferencia local
 Etc.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

Atributo transitivo opcional:


Si un router no lo soporta, lo debe
pasar a otro router BGP.
Atributos opcionales  Agregador
No necesariamente son  Comunidad
soportadas en todas las  Etc
Propiedad intelectual de Daniel Díaz @ 2014

implementaciones BGP.
Atributo no transitivo opcional:
Puede tratarse de un Es eliminado por un router que no
atributo privado. tenga implementado el atributo.

ddiaz@inictel-uni.edu.pe
 Discriminador de salida múltiple.
 Origen, etc
Lectura Recomendada 
http://www.cisco.com/en/US/docs/internetworking/technology/handbook/bgp.html
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

Cuando un AS proporciona tránsito a otro AS es


necesario que todas las rutas del AS tengan valores
estables debido a un protocolo IGP (OSPF, RIP, etc):
deben estar sincronizados.

En los router CISCO la sincronización está habilitada.


Propiedad intelectual de Daniel Díaz @ 2014

Es aconsejable deshabilitar la sincronización de BGP


para acelerar el proceso de convergencia habilitada:

ddiaz@inictel-uni.edu.pe
no synchronization
► Si los AS no son de tránsito.
► Todos los router en el AS corren iBGP.
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

CONFIGURACIÓN
DE
CONFIGURACION
Propiedad intelectual de Daniel Díaz @ 2014

BGP
http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

Activar el protocolo BGP


Router de
borde Ra

Sistema Autónomo Ra(config)#router bgp 45560


45,560
Número de Sistema
Autónomo

Definir eBGP
Router de Router de
Propiedad intelectual de Daniel Díaz @ 2014

borde Ra borde Rb
20.1.1.1 20.1.1.2
35.5.5.1 47.8.8.5
Sistema Autónomo Sistema Autónomo
45,560 48,800

ddiaz@inictel-uni.edu.pe
Ra(config)#router bgp 45560 Por default eBGP tiene TTL=1
Ra(config-router)#neighbor 20.1.1.2 remote-as 48800
ebgp-multihop permite conexión entre pares
Ra(config)#router bgp 45560 que no están directamente conectados
Ra(config-router)#neighbor 39.9.9.9 remote-as 53629
Entre router de borde puede existir una
Ra(config-router)#neighbor 39.9.9.9 ebgp-multihop 17 red; aquí eBGP tiene TTL=17
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

Definir la sesión TCP por donde se intercambiarán


las tablas: iBGP y eBGP Lo 1: 55.7.7.7/32 Lo 2: 96.3.3.3/32
Router de Router de Router de
borde Ra borde Rb borde Rc
20.1.1.1 20.1.1.2
35.5.5.1 47.8.8.5
Sistema Autónomo Sistema Autónomo
45,560 48,800
Propiedad intelectual de Daniel Díaz @ 2014

Ra(config)#router bgp 45560


Ra(config-router)#neighbor 20.1.1.2 remote-as 48800
Rb(config)#router bgp 48800
Define eBGP
Rb(config-router)#neighbor 20.1.1.1 remote-as 45560

ddiaz@inictel-uni.edu.pe
Rb(config-router)#neighbor 96.3.3.3 remote-as 48800 Define iBGP
Rb(config-router)#neighbor 96.3.3.3 update-source loopback 1 Define loopback para iBGP

Rc(config)#router bgp 48800


Define iBGP Rc(config-router)#neighbor 55.7.7.7 remote-as 48800
Define loopback para iBGP Rc(config-router)#neighbor 55.7.7.7 update-source loopback 2
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

Permitir que BGP publique una red


► Se usa el comando network <prefijo de red> mask <máscara>
► Indica a BGP que redes debe originar desde el router configurado.
► Debe haber una lista de comandos network con todas las redes
del sistema autónomo que desea publicar (limitado por la NVRAM)
200.1.1.0/25
Propiedad intelectual de Daniel Díaz @ 2014

Red LAN Lo 1: 55.7.7.7/32 Lo 2: 96.3.3.3/32


Router de Router de Router de
borde Ra borde Rb borde Rc
20.1.1.1 20.1.1.2
35.5.5.1 47.8.8.5

ddiaz@inictel-uni.edu.pe
Sistema Autónomo Sistema Autónomo
45,560 48,800

Ra(config)#router bgp 45560


Ra(config-router)#network 200.1.1.0 mask 255.255.255.128
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/25 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa1/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
Fa0/0
.5

.6 .1 .1 .6
Fa0/1 Fa0/1 Fa1/1
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
R3 33.3.3.3/32 .1
R6
.1
Ra .6
.6 Rb
Fa1/0
11.1.1.0/30 .2 .2
.1
.2
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Fa1/0 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17

Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .130
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .129

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa0/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
Fa0/0
.5

R1#configure terminal
R2#configure terminal
R1(config)#interface fastethernet 0/0
.6 R3#configure .1 .6
Fa0/1
.1
R1(config-if)#ip addressterminal
R2(config)#interface fastethernet
30.3.3.1 0/0
255.255.255.252 Fa1/1
R3(config)#interface fastethernet 0/0 Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

R2(config-if)#ip
R1(config-if)#no
Lo 0: address 26.6.6.10
shutdown 255.255.255.252
R3 R3(config-if)#ip
R2(config-if)#no
R1(config-if)#exit
33.3.3.3/32 address 26.6.6.1 255.255.255.252 .1
shutdown R6
.1
R3(config-if)#no Rn#configure
shutdown terminal
R2(config-if)#exit
R1(config)#interface fastethernet .6 0/1
RaR3(config-if)#exit Rn(config)#interface
Rb
Rm#configure fastethernet 0/0
terminal
R2(config)#interface
R1(config-if)#ip .6 fastethernet
address 26.6.6.9
Fa1/0 0/1
255.255.255.252
Rn(config-if)#ip
R3(config)#interface
11.1.1.0/30 fastethernet address
Rm(config)#interface
0/1 200.1.8.1 255.255.255.0
fastethernet 0/0
R2(config-if)#ip
R1(config-if)#no
.1 address
shutdown .2 26.6.6.2 255.255.255.252
.2 Rn(config-if)#no
Rm(config-if)#ip shutdown
R3(config-if)#ip
.5 R2(config-if)#no
Fa0/1
R1(config-if)#exit Costo
address
shutdown
10 Fa0/0 26.6.6.6
.9 0: address 200.1.9.1 255.255.255.0
Lo 255.255.255.252
Fa1/0 Rn(config-if)#exit
Rm(config-if)#no shutdown
.17R3(config-if)#no
R2(config-if)#exit
R1(config)#interface shutdown
Fa0/1
fastethernet 1/0 22.2.2.2/32

ddiaz@inictel-uni.edu.pe
R3(config-if)#exit Rn(config)#interface
Rm(config-if)#exit fastethernet 0/1
R2(config)#interface
R1(config-if)#ip fastethernet
address 26.6.6.5 1/1
255.255.255.252
Rn(config-if)#ip
R3(config)#interface fastethernet address
Rm(config)#interface
1/0 30.3.3.2 255.255.255.252
fastethernet 0/1
R2(config-if)#ip
R1(config-if)#no address 30.3.3.5
shutdown 255.255.255.252
Fa0/1
OSPF
R3(config-if)#ip Rn(config-if)#no
Rm(config-if)#ip
address 14.4.4.1
.18
shutdown
address 30.3.3.6 255.255.255.252
255.255.255.252
R2(config-if)#no
.6 R1(config-if)#
Fa0/0 shutdown .10
Rn(config-if)#exit
Rm(config-if)#no shutdown
R3(config-if)#no shutdown
R2(config-if)#
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Rc R3(config-if)# Rn}m(config-if)#exit
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .130
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .129

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa0/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 R1#configure terminal Fa1/1 R5 Rq
Fa0/0
R1(config)#ip routeterminal
R2#configure 200.1.8.0 .5 255.255.255.0 30.3.3.2
R1(config)#router
R2(config)#ip ospf
R3#configure 1terminal
route 200.1.9.0 255.255.255.0 30.3.3.6
R1(config-router)#network
Rn#configure terminal
R2(config)#router
R3(config)#routerospf30.3.3.0
1 1 0.0.0.3 area 0
ospf
.6 .1 R1(config-router)#network
Rn(config)#ip route
Rm#configure terminal 26.6.6.4
0.0.0.0 0.0.0.0 30.3.3.1
R2(config-router)#network
R3(config-router)#network 0.0.0.3
30.3.3.4 area
0.0.0.3
26.6.6.4 0area.1 area
0.0.0.3 0 .60
Fa0/1 R1(config-router)#network
Rn(config)#exit R2(config-router)#network
Rm(config)#ip route 0.0.0.0 0.0.0.0 26.6.6.8
R3(config-router)#network 0.0.0.3
26.6.6.0
30.3.3.5 area
0.0.0.3
26.6.6.0 0.0.0.3
Fa0/1 0 0Fa1/1
0area area
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
R1(config-router)#redistribute
Rn#Rm(config)#exit
R2(config-router)#network static subnets
26.6.6.8 0.0.0.3 area area
0 0R6
R3 33.3.3.3/32
R3(config-router)#network 14.4.4.0 0.0.0.3
.1
.1 Rm# R1(config-router)#exit
R2(config-router)#redistribute
R3(config-router)#passive-interfacestatic subnets
fastethernet 1/0
RaR1(config)#interface .6
fastethernet
R2(config-router)#exit
R3(config-router)#exit
.6 Rb 0/1
R1(config-if)#ip Fa1/0
ospf cost fastethernet
R2(config)#interface 2 fastethernet0/0 0/0
.1
R3(config)#interface
11.1.1.0/30 .2
R1(config-if)#exit
R2(config-if)#ip ospf ospf
R3(config-if)#ip cost cost
2
Lo 0: 1
.2
.5 Fa0/1 Costo 10 Fa0/0 .9
Fa1/0 R1(config)#interface
R2(config-if)#exit fastethernet
R3(config-if)#exit 1/0
22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17
R1(config-if)#ip ospf cost fastethernet
R2(config)#interface
R3(config)#interface 4 fastethernet0/1 0/1
R1(config-if)#exit
R2(config-if)#ip ospf ospf
R3(config-if)#ip cost cost
1 4
R1(config)# Fa0/1
OSPF
R2(config-if)#exit
R3(config-if)#exit .18
.10
.6 Fa0/0 R2(config)#
R3(config)#
Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .130
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .129

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa0/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 .2 Costo 3 Fa0/1.5
R6#configure
Fa1/0 .5 terminal Fa1/1 R5 Rq
Fa0/0
R6(config)#router ospf 1
R5#configure terminal .5
Rp#configure terminal
R6(config-router)#network
R5(config)#ip 27.7.7.0255.255.255.0
routeterminal
R4#configure 212.2.5.0 0.0.0.3 area 0 40.4.4.6
Rp(config)#ip route
Rq#configure 0.0.0.0 0.0.0.0ospf
R6(config-router)#network
terminal
R5(config)#router
R4(config)#ip 40.4.4.1
27.7.7.4
route 0.0.0.3
1 212.2.4.0 area 0
255.255.255.0 40.4.4.2
Rp(config)#exit
R6(config-router)#network
Rq(config)#ip.6 route 0.0.0.0
R5(config-router)#network
R4(config)#router
.1 15.5.5.0
0.0.0.0 0.0.0.3
40.4.4.5
ospf 27.7.7.4
1 area 0
0.0.0.3 area 0 .1 .6
Rp# Rq(config)#exit
Fa0/1
R6(config-router)#passive-interface
R5(config-router)#network
R4(config-router)#network fastEthernet
27.7.7.8 0.0.0.3
40.4.4.0 0/00area 0
area
0.0.0.3 Fa0/1 Fa1/1
Propiedad intelectual de Daniel Díaz @ 2014

Rq# R6(config-router)#exit Lo 0:
R3R5(config-router)#network
R4(config-router)#network 40.4.4.4 0.0.0.3
27.7.7.0
33.3.3.3/32
area 0area 0
0.0.0.3 .1
R6
R6(config)#interface
.1 fastethernet
R5(config-router)#redistribute
R4(config-router)#network 0/1static subnets
27.7.7.8 0.0.0.3 area 0 .6
R6(config-if)#ip ospf cost
R5(config-router)#exit 2 Ra
R4(config-router)#network 15.5.5.4 0.0.0.3.6 areaFa1/0 0 Rb
R6(config-if)#exit
R5(config)#interface fastethernet .10/1 11.1.1.0/30
R4(config-router)#passive-interface fastEthernet 1/1
.2
R6(config)#interface
R5(config-if)#ip fastethernet
.2
ospf cost .53 1/1
R4(config-router)#redistribute static subnets
Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
R6(config-if)#ip ospf
R5(config-if)#exit cost 6
Fa1/0
R4(config-router)#exit .17 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
R6(config-if)#exit
R5(config)#interface fastethernet
R4(config)#interface 1/0 0/1
fastethernet
R6(config)#
R5(config-if)#ip ospf cost
R4(config-if)#ip ospf 6cost 3
Fa0/1
R5(config-if)#exit
R4(config-if)#exit OSPF .18
.10
.6 Fa0/0
R5(config)#
R4(config)#interface fastethernet 0/0
Fa0/1
Rc ospf cost 2
R4(config-if)#ip
11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
R4(config-if)#exit 211.2.2.0/24
211.1.1.0/24
R4(config)#
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


Ra#configure
200.1.9.0/24 terminal
Rb#configureospf
Ra(config)#router terminal
1
.2 Rb(config)#router
Ra(config-router)#network
.2
ospf 1
14.4.4.0 0.0.0.3 area 0
.2
OSPF .1 Rm Rb(config-router)#network 11.1.1.0 OSPF 0.0.0.3 Fa0/0 .2 .1
Fa0/0 .1 Rn
Rc#configure terminal Fa0/0 Fa0/0 .1
Ra(config-router)#network 11.1.1.0 0.0.0.3 area 0 area 0
R2 Rb(config-router)#network
Ra(config-router)#network 11.1.1.411.1.1.8
0.0.0.30.0.0.3
area 0 area 0
Fa0/1 R1 ospf 1AS 3000
Rc(config)#router
.2Rd#configure
.6
Rp Fa0/1 R4 AS 4000 .6
.1 terminal .5 Rb(config-router)#network
Fa0/1Ra(config-router)#network 15.5.5.0
11.1.1.16 0.0.0.3
0.0.0.3 area
area 0 .10 0 .5
Rc(config-router)#network
30.3.3.0/30 .9 11.1.1.4 0.0.0.3
26.6.6.8/30 .10 area 0 30.3.3.4/30 .2 .1 .9 27.7.7.8/30 Fa0/1
Rd(config)#router ospf 1 Fa1/1 Rb(config-router)#network
40.4.4.0/30 Fa1/0
Ra(config-router)#network 33.3.3.3 15.5.5.4
Fa0/10.0.0.0
0.0.0.3
area area 0 Fa1/1
3 0Fa0/1
Fa0/0 Fa0/1
Rc(config-router)#network 11.1.1.12 Fa0/0
0.0.0.3 area 0
Rd(config-router)#network Costo 2
11.1.1.8 0.0.0.3 area 0 Rb(config-router)#network Costo
22.2.2.2
fastEthernetarea
0.0.0.0 1/1.50 R5 Rq
.5 .2 Fa1/1 .2
Fa1/0
Rc(config-router)#network 211.1.1.0 0.0.0.255 area 0 Ra(config-router)#passive-interface Fa0/0
Rd(config-router)#network 11.1.1.12 0.0.0.3 area 0 Ra(config-router)#exit Rb(config-router)#passive-interface
.5 fastethernet 1/0
Rc(config-router)#exit
Rd(config-router)#network 11.1.1.16 0.0.0.3 area 0 Ra(config)# Rb(config-router)#passive-interface
interface fastethernet 0/0 fastethernet 1/1
Rc(config)# interface fastethernet 0/0
Rd(config-router)#network 211.2.2.0 0.0.0.255 area 0 Ra(config-if)#ip Rb(config-router)#exit
ospf cost 7
Rc(config-if)#ip ospf cost 4
Rd(config-router)#exit
.6 Ra(config-if)#exit interface fastethernet 0/0 .1 .6
Rb(config)#
Rc(config-if)#exit .1
Rd(config)#Fa0/1
interface fastethernet 0/0 Rb(config-if)#ip
Ra(config)#interface ospf cost 10
fastethernet 0/1 Fa0/1 Fa1/1
Rc(config)#interface fastethernet 0/1
Propiedad intelectual de Daniel Díaz @ 2014

Rd(config-if)#ip ospf cost 2


R3ospf Lo 0: Rb(config-if)#exit
Ra(config-if)#ip ospf cost 10 R6
Rc(config-if)#ip cost 2 33.3.3.3/32 .1
Rd(config-if)#exit .1 Rb(config)#interface
Ra(config-if)#exit fastethernet 0/1
Rc(config-if)#exit
Rd(config)#interface fastethernet 0/1 Ra Rb(config-if)#ip
Ra(config)#interface
.6
Rb ospf cost 11/0
fastethernet
.6 Fa1/0
Rd(config-if)#ip ospf cost 1 Rb(config-if)#exit
Ra(config-if)#ip ospf.2 cost 4
.1 11.1.1.0/30 .2
Rd(config-if)#exit .2 Ra(config-if)#exit
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Rd(config)#interface fastethernet 1/1 Fa1/0
Fa0/1 22.2.2.2/32

ddiaz@inictel-uni.edu.pe
.17
Rd(config-if)#ip ospf cost 7
Rd(config-if)#exit
Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa1/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
Fa0/0
.5
R1#show ip route
R2#show ip route
.6 26.0.0.0/30 is subnetted, 3 subnets .1 .6
.1
Fa0/1 C R3#show
26.6.6.8 is ip route
directly connected, FastEthernet0/1 Fa1/1
26.0.0.0/30 is subnetted, 3 subnets Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

R3 O C26.6.6.0
Lo 0: [110/3]
26.6.6.8 via 26.6.6.10,
is directly 00:21:31,
connected, FastEthernet0/1 R6
FastEthernet0/0
33.3.3.3/32
C C26.6.6.4 26.0.0.0/30
is directly is subnetted,
connected, 3 subnets
FastEthernet1/0 .1
.1 26.6.6.0 is directly connected, FastEthernet0/1
O
S 200.1.8.0/24
Ra 26.6.6.8
[1/0] via[110/3]
.6 via 26.6.6.2, 00:24:48, FastEthernet0/0
30.3.3.2
O
C
26.6.6.4 [110/5]
.6
26.6.6.0 isFa1/0
directly
Rb
via 26.6.6.1, 00:23:04, FastEthernet0/1
connected, FastEthernet0/0
O E2O200.1.9.0/24
E2 [110/20]
200.1.8.0/24 via
[110/20] 26.6.6.10,
via 00:21:31,
.2 26.6.6.9, FastEthernet0/1
00:23:04, FastEthernet0/0
.1 11.1.1.0/30
C is26.6.6.4 is directly
.2 connected, FastEthernet0/1
.2 14.0.0.0/30
S Fa0/1 subnetted,
200.1.9.0/24 Fa0/0 1 subnets
[1/0] via 30.3.3.6
O
.5 O E2
14.4.4.0 200.1.8.0/24
Costo [110/20]
10 via 26.6.6.10,
[110/4] .9 Lo
via0:26.6.6.2,
00:21:31, 00:24:48, FastEthernet0/0
FastEthernet0/1
Fa1/0 14.0.0.0/30 is subnetted,
Fa0/1 1 subnets
22.2.2.2/32

ddiaz@inictel-uni.edu.pe
.17 O E2is200.1.9.0/24
30.0.0.0/30 subnetted, 2[110/20]
subnets via 26.6.6.2, 00:24:48, FastEthernet0/0
O 14.4.4.0 [110/2] via 26.6.6.1, 00:23:04, FastEthernet0/1
O 30.3.3.414.0.0.0/30
[110/3] viais26.6.6.10,
subnetted,00:21:31,
1 subnetsFastEthernet0/1
30.0.0.0/30 is subnetted, 2 subnets
C C30.3.3.0 C is14.4.4.0
directly isconnected,
directly connected, FastEthernet1/0
FastEthernet0/0
Fa0/1
R1# O
OSPF
30.3.3.4 is directly connected,
.18
30.0.0.0/30 is subnetted, 2.10
FastEthernet1/1
subnets
.6 Fa0/0 30.3.3.0 [110/3] via 26.6.6.9, 00:23:04, FastEthernet0/0
Fa0/1R2# O 11.1.1.12/30
30.3.3.4 [110/2] via 26.6.6.2,
Fa0/0 Rd00:24:48, FastEthernet0/0
Rc O 30.3.3.0
Fa1/0 .13 Costo 2 [110/4] .14via 26.6.6.2, 00:24:48, FastEthernet0/0
Fa1/0
211.1.1.0/24 R3# 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 R1
Fa0/1 Ra#show ipAS 3000
route R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 Fa0/1 .5 .5
Fa0/1
30.3.3.0/30 33.0.0.0/32
.9 Rb#show is
ipsubnetted,
route .101 subnets 30.3.3.4/30
26.6.6.8/30 .2 .1 .9 27.7.7.8/30 .10
Fa1/1 40.4.4.0/30 Fa1/0 Fa1/1
Fa0/0 C Fa0/1
33.3.3.3Costo
is is
directlyFa0/0
connected, Loopback0 Fa0/1 Costo 3 Fa0/1.5
.5 33.0.0.0/32 subnetted,
2 .2 1 subnets Fa1/1 .2 Rq
Fa1/0 22.0.0.0/32 is subnetted, 1 subnets
O 33.3.3.3 [110/8] via 11.1.1.10, 00:06:15, FastEthernet0/1 Fa0/0 R5
.5
O 22.2.2.2 [110/8]
22.0.0.0/32 via 11.1.1.6,
is subnetted, 00:02:18, FastEthernet1/0
1 subnets
11.0.0.0/30
C is subnetted,
22.2.2.2 is directly5 subnets
connected, Loopback0
O 11.1.1.8 [110/7]
11.0.0.0/30 via 11.1.1.6,
is subnetted, 00:02:18, FastEthernet1/0
5 subnets
.6 .1 .6
O C11.1.1.12 .1 [110/6]
11.1.1.8 via 11.1.1.6,
is directly connected, 00:02:18, FastEthernet1/0
FastEthernet0/1
Fa0/1 Fa0/1 Fa1/1
C O11.1.1.0 is directly connected, FastEthernet0/1
Propiedad intelectual de Daniel Díaz @ 2014

11.1.1.12 [110/3] via 11.1.1.10,


Lo 0: 00:06:15, FastEthernet0/1
R3
C C11.1.1.4 is directly connected,
11.1.1.0 is directly33.3.3.3/32 FastEthernet1/0
connected, FastEthernet0/0 .1
R6
.1
C O11.1.1.16 is directly connected,
11.1.1.4 [110/7] via 11.1.1.10, FastEthernet0/0
00:06:15, FastEthernet0/1
.6
O 211.2.2.0/24 [110/7] via 11.1.1.6,
Ra 00:02:18, FastEthernet1/0
.6 Rb
O 11.1.1.16 [110/8] via 11.1.1.10, 00:06:15, FastEthernet0/1
Fa1/0
.2
11.1.1.0/30FastEthernet0/1
14.0.0.0/30 is subnetted,
O 211.2.2.0/24 [110/2]1viasubnets
11.1.1.10,
.1 00:06:15, .2
.2
C 14.4.4.0 is directly
14.0.0.0/30 connected,
is subnetted, FastEthernet1/1
Fa0/1 Costo 10 Fa0/0
.5 1 subnets .9 Lo 0:
O 211.1.1.0/24 [110/5] Fa1/0
via via
11.1.1.6,
O 14.4.4.0 [110/8] .1700:02:20,
11.1.1.10, FastEthernet1/0
00:06:15, FastEthernet0/1
Fa0/1 22.2.2.2/32

ddiaz@inictel-uni.edu.pe
15.0.0.0/30 is subnetted,
O 211.1.1.0/24 [110/4]2viasubnets
11.1.1.10, 00:06:16, FastEthernet0/1
O 15.5.5.4 [110/8]
15.0.0.0/30 via 11.1.1.6,
is subnetted, 00:02:21, FastEthernet1/0
2 subnets Fa0/1
O C15.5.5.0 [110/8]
15.5.5.4 via 11.1.1.6,
is directly 00:02:22,
connected, OSPF
FastEthernet1/0
FastEthernet1/0 .18
.10
.6 Fa0/0
Ra# C 15.5.5.0 is directly connected, FastEthernet1/1
Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Rb# .13 Costo 2
Fa1/0 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF Ra#traceroute OSPF Fa0/0 .2 .1
Fa0/0 22.2.2.2
Rn .1 Rm
Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 Type escape
.5 sequence
Fa0/1 to abort.
.2 .1
.5
Fa0/1
30.3.3.0/30 .9 26.6.6.8/30 .10 30.3.3.4/30 .9 27.7.7.8/30 .10
Fa0/1 Tracing
Fa0/0 the route
Fa1/1 to 22.2.2.240.4.4.0/30 Fa1/0
Fa0/1
Fa1/1
Fa0/0 Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
Fa0/0
1 11.1.1.6 20 msec 44 msec 20 msec.5
2 11.1.1.14 20 msec 32 msec 40 msec
3 11.1.1.9 68 msec 64 msec 48 msec
.6 .1
Ra# .1 .6
Fa0/1 Fa0/1 Fa1/1
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
R3 33.3.3.3/32 .1
R6
.1
Ra .6
.6 Rb
Fa1/0
11.1.1.0/30 .2 .2
.1
.2
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Fa1/0 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17

Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 .14 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
.2 .1
30.3.3.0/30 .9 26.6.6.8/30 .10 30.3.3.4/30R3#configure terminal
40.4.4.0/30 Fa1/0
.9 27.7.7.8/30 .10
Fa1/1
Fa0/1 Fa0/0 Fa1/1
Fa0/0 Costo 2 .2 bgp 3000.2 Fa0/1 Costo 3 Fa0/1.5
R3(config)#routerFa1/1
Fa1/0 .5
R3(config-router)#neighbor 14.4.4.2
Fa0/0 remote-as 1000 R5 Rq
.5
R3(config-router)#network 200.1.8.0 mask 255.255.255.0
R3(config-router)#network 200.1.9.0 mask 255.255.255.0
R3(config-router)#exit
.6 .1 .1 .6
Fa0/1
R3(config)# Fa1/1
Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
R3 33.3.3.3/32 Ra#configure terminal .1
R6
.1
Ra(config)#router
.6
bgp 1000
Ra Rb
Ra(config-router)#neighbor
.6 14.4.4.1 remote-as 3000
Fa1/0
11.1.1.0/30 .2
Ra(config-router)#network 211.1.1.0 mask 255.255.255.0
.1 .2
.2 Ra(config-router)#network
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0: 211.2.2.0 mask 255.255.255.0
Fa1/0 Ra(config-router)#exit 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17
Ra(config)#
Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 .14 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24
Ra#show ip route
.2
.2 .2
33.0.0.0/32 is subnetted, 1 subnets
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 C Rm Fa0/0 .1
33.3.3.3 is directly connected, Loopback0
.2 Fa0/1 R1 AS 3000 R2 .6 22.0.0.0/32Rp is subnetted, R4
Fa0/11 subnets AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
30.3.3.0/30 .9 26.6.6.8/30 .10 O
30.3.3.4/30 22.2.2.2 [110/8] .2 via .1 11.1.1.6,
.9 00:11:55, FastEthernet1/0
27.7.7.8/30 .10
Fa0/1 Fa0/0 Fa1/1 40.4.4.0/30 Fa1/0 Fa1/1
Fa0/0 Costo 2 11.0.0.0/30 is subnetted, 5 subnets Fa0/1 Costo 3 Fa0/1.5
.5 .2 Fa1/1 .2 Rq
Fa1/0 O 11.1.1.8 [110/7] via 11.1.1.6,Fa0/0 00:11:55, FastEthernet1/0 R5
.5
O 11.1.1.12 [110/6] via 11.1.1.6, 00:11:55, FastEthernet1/0
R3#show ip route
C 11.1.1.0 is directly connected, FastEthernet0/1
26.0.0.0/30 is subnetted, 3 subnets
C 11.1.1.4 is directly connected, FastEthernet1/0
.6 O 26.6.6.8 [110/3] via 26.6.6.2, 00:18:22,.1FastEthernet0/0
.6
.1 C 11.1.1.16 is directly connected, FastEthernet0/0
Fa0/1 C 26.6.6.0 is directly connected, FastEthernet0/0
Fa0/1 Fa1/1
B 200.1.8.0/24 [20/20] via 14.4.4.1, 00:04:42
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0: C 26.6.6.4 is directly connected, FastEthernet0/1R6


R3 33.3.3.3/32 OO E2 211.2.2.0/24 [110/7] via 11.1.1.6, 00:11:55, .1FastEthernet1/0
.1 200.1.8.0/24 [110/20] via 26.6.6.2, 00:18:22, FastEthernet0/0
B 200.1.9.0/24 [20/20] .6 [20/7] via 14.4.4.1, 00:04:11
Ra B 211.2.2.0/24
14.0.0.0/30
.6 Rb via1 14.4.4.2,
is subnetted, subnets
00:10:48
Fa1/0
O E2 200.1.9.0/24 [110/20] via 26.6.6.2, 00:18:22, FastEthernet0/0
.2
.1 C 11.1.1.0/30
14.4.4.0.2is directly connected, FastEthernet1/1
.2 14.0.0.0/30 is subnetted, 1 subnets
.5 O Costo
Fa0/1 211.1.1.0/24
Fa0/0 [110/5]
10 14.4.4.0 via
Lo11.1.1.6,
0: 00:11:58, FastEthernet1/0
Fa1/0 C is .9directly connected, FastEthernet1/0
15.0.0.0/30Fa0/1
is subnetted, 2 subnets
22.2.2.2/32

ddiaz@inictel-uni.edu.pe
.17
B 211.1.1.0/24 [20/5] via 14.4.4.2, 00:10:48
O 15.5.5.4 [110/8] via 11.1.1.6, 00:11:59, FastEthernet1/0
30.0.0.0/30 is subnetted, 2 subnets
O 15.5.5.0 [110/8] via 11.1.1.6, Fa0/1
00:12:00, FastEthernet1/0
OOSPF30.3.3.4 [110/2] via 26.6.6.2, 00:18:22, FastEthernet0/0
Fa0/0
Ra# .18
.10
.6 O 30.3.3.0 [110/4] via 26.6.6.2, 00:18:22, FastEthernet0/0
Rc
Fa0/1 11.1.1.12/30
R3# Fa0/0 Rd
Fa1/0 .13 Costo 2 .14 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
R1#show ip route
.2 .2 .2
Fa0/0 .1 Rn OSPF .1 Rm ip route
Fa0/0Rd#show Fa0/0 .1
26.0.0.0/30 is subnetted, 3 subnets
OSPF Fa0/0 .1

R1 R2 33.0.0.0/32 is subnetted, 1 subnets


AS 3000 C.6 Fa0/126.6.6.8 isRp Fa0/1 R4FastEthernet0/1
AS 4000
Fa0/1 directly connected, .6
.2
.1
.10
.5 O 33.3.3.3 [110/7] via 11.1.1.13,
.2 26.6.6.10,
.1 01:12:43, FastEthernet0/0
.10
.5
Fa0/1
30.3.3.0/30 .9 26.6.6.8/30 O30.3.3.4/30
26.6.6.0 40.4.4.0/30
[110/3] via Fa1/0 .9 01:11:13, FastEthernet0/1
27.7.7.8/30 Fa1/1
Fa0/1 Fa0/0 Fa1/1 22.0.0.0/32 is subnetted, 1 subnetsFa0/1
Fa0/0 Costo 2 .2 C 26.6.6.4 is directlyFa1/1 Costo 3 Fa0/1.5
connected,.2FastEthernet1/0
Fa1/0 .5 O 22.2.2.2 [110/2] via 11.1.1.9,
S 200.1.8.0/24 [1/0] via 30.3.3.2 Fa0/0
01:12:43, FastEthernet0/1 R5 Rq
11.0.0.0/30 is subnetted, .5 5 subnets
O E2 200.1.9.0/24 [110/20] via 26.6.6.10, 01:11:13, FastEthernet0/1
C 11.1.1.8 is directly connected, FastEthernet0/1
14.0.0.0/30 is subnetted, 1 subnets
C 11.1.1.12 is directly connected, FastEthernet0/0
O 14.4.4.0 [110/4] via 26.6.6.10, 01:11:13, FastEthernet0/1
.6 .1 O 11.1.1.0 [110/11] via 11.1.1.9, 01:12:43, FastEthernet0/1
.1 .6
Fa0/1 30.0.0.0/30 is subnetted, 2 subnets Fa1/1
O 11.1.1.4 [110/6] via 11.1.1.13, 01:12:43, FastEthernet0/0
[110/3] via 26.6.6.10, 01:11:13,Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

Lo O 0: C 30.3.3.4 FastEthernet0/1
11.1.1.16 is directly connected, FastEthernet1/1 R6
R3 33.3.3.3/32 C 30.3.3.0 is directly connected, FastEthernet0/0 .1
.1 C 211.2.2.0/24 is directly connected, FastEthernet1/0
R1# .6
Ra 14.0.0.0/30
.6
is subnetted,
Rb 1 subnets
O 11.1.1.0/30 Fa1/0
14.4.4.0 [110/7].2via 11.1.1.13, 01:12:43, FastEthernet0/0
.1 .2
.2 O 211.1.1.0/24
Fa0/1 Costo 10 Fa0/0
[110/3] via 11.1.1.13, 01:12:45, FastEthernet0/0
.5 .9 Lo 0:
Fa1/0 15.0.0.0/30 is subnetted, 2 subnets
22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17
O 15.5.5.4 [110/2] via 11.1.1.9, 01:12:45, FastEthernet0/1
O 15.5.5.0 [110/2] via 11.1.1.9, 01:12:45, FastEthernet0/1
Fa0/1
Fa0/0
Rd#OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 .14 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2 R3(config)#router bgp 3000


.2 .2
Fa0/0 .1 OSPF .1 Rm R3(config-router)#redistribute OSPF
ospf 1 Fa0/0 .2 .1
Rn Fa0/0 Fa0/0 .1
R3(config-router)#exit
.2 Fa0/1 R1 AS 3000 R2 .6
Rp
R3(config)#router R4 1
Fa0/1 ospf AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 R3(config-router)#redistribute
40.4.4.0/30 Fa1/0
.9 bgp 3000 subnets Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
Fa0/0
.5

Ra(config)#router bgp 1000


Ra(config-router)#redistribute ospf 1
.6 .1 Ra(config-router)#exit .1 .6
Fa0/1 Fa1/1
Ra(config)#router ospf 1 Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
R3 33.3.3.3/32
Ra(config-router)#redistribute bgp 1000
.1
R6
subnets
.1
Ra .6
.6 Rb
Fa1/0
11.1.1.0/30 .2 .2
.1
.2
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Fa1/0 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17

Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24
R1#show ip routeR3#show 212.2.4.0/24
200.1.9.0/24 ip route 212.2.5.0/24
33.0.0.0/32
33.0.0.0/32 is subnetted, is subnetted, 1 subnets
1 subnets
.2 B 33.3.3.3
O E2 33.3.3.3
.2 [110/1] via .2 [20/0]
26.6.6.10, via 14.4.4.2,
00:14:01, 00:02:33
FastEthernet0/1
Fa0/0 .1 Rn OSPF .1 OSPF Fa0/0 .2 .1
22.0.0.0/32
Fa0/0 Rm 22.0.0.0/32
is subnetted,Fa0/0 is
1 subnets.1 subnetted, 1 subnets
R2O E2 .622.2.2.2 [110/1] B 22.2.2.2
via [20/8]
26.6.6.10, via 14.4.4.2,
00:14:01, 00:02:33
.2 Fa0/1 R1 AS 3000 Rp Fa0/1 R4 FastEthernet0/1
AS 4000 .6
.1 .5 26.0.0.0/30 26.0.0.0/30
Fa0/1 is subnetted, is
3 subnets
.2
subnetted,
.1
3 subnets .5
Fa0/1
30.3.3.0/30 .9 26.6.6.8/30 .10 30.3.3.4/30 .9 27.7.7.8/30 .10
Fa0/1 Fa0/0 C Fa1/126.6.6.8 O
is directly26.6.6.8
connected,
40.4.4.0/30 [110/3]
Fa1/0 via 26.6.6.2,
FastEthernet0/1 00:03:31, FastEthernet0/0Fa1/1
Fa0/0 Costo 2 Fa0/1 Costo 3 Fa0/1.5
.2 O C
26.6.6.0 [110/3] 26.6.6.0
via isFa1/1
26.6.6.10, directly connected,
00:14:58, FastEthernet0/0
.2 FastEthernet0/1
Fa1/0 .5
Fa0/0 FastEthernet0/1 R5 Rq
C 26.6.6.4 isC directly 26.6.6.4
connected,is directly
.5 connected,
FastEthernet1/0
11.0.0.0/30
11.0.0.0/30 is subnetted, is subnetted, 5 subnets
5 subnets
O E2 B
11.1.1.8 [110/1] 11.1.1.8
via [20/7]
26.6.6.10, via 14.4.4.2,
00:14:01, 00:02:33
FastEthernet0/1
O E2 11.1.1.12 B[110/1] 11.1.1.12
via 26.6.6.10, [20/6] via 14.4.4.2,
00:14:01, 00:02:33
FastEthernet0/1
.6 .1 B 11.1.1.0 [20/0] via 14.4.4.2, 00:02:33.1 .6
O E2 11.1.1.0 [110/1] via 26.6.6.10, 00:14:01, FastEthernet0/1
Fa0/1 Fa0/1 Fa1/1
O E2 B
11.1.1.4 [110/1] 11.1.1.4
via [20/0]
26.6.6.10, via 14.4.4.2,
00:14:01, 00:02:33
FastEthernet0/1
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
R3 O E2
33.3.3.3/32
11.1.1.16 B[110/1] 11.1.1.16
via 26.6.6.10, [20/0] via 14.4.4.2,
00:14:06, 00:02:36.1
FastEthernet0/1 R6
.1 S 200.1.8.0/24 O E2 200.1.8.0/24
[1/0] via 30.3.3.2 [110/20] via 26.6.6.2, 00:03:34, FastEthernet0/0
.6
O E2Ra 211.2.2.0/24 B[110/1] 211.2.2.0/24
.6 via 26.6.6.10, Rb[20/7] via 14.4.4.2,
00:15:04, 00:38:08
FastEthernet0/1
O[110/20] Fa1/0
E2 200.1.9.0/24
O E2 200.1.9.0/24 11.1.1.0/30 via 26.6.6.10, .2[110/20] via 26.6.6.2,
00:15:04, 00:03:34, FastEthernet0/0
FastEthernet0/1
.1 .2
.2 14.0.0.0/30
14.0.0.0/30 is subnetted, 1 subnets is subnetted, 1 subnets
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Fa1/0 O C
14.4.4.0 [110/4] 14.4.4.0
via is directly
26.6.6.10, connected,
00:15:04, FastEthernet1/0
FastEthernet0/1
Fa0/1 22.2.2.2/32

ddiaz@inictel-uni.edu.pe
.17
O E2 211.1.1.0/24 B[110/1] 211.1.1.0/24
via 26.6.6.10, [20/5]00:15:04,
via 14.4.4.2, 00:38:08
FastEthernet0/1
30.0.0.0/30
30.0.0.0/30 is subnetted, is subnetted, 2 subnets
2 subnets
O O
30.3.3.4 [110/3] 30.3.3.4
via 26.6.6.10,[110/2] via
00:15:04,26.6.6.2,
Fa0/1 00:03:34, FastEthernet0/0
FastEthernet0/1
C
OSPF O 30.3.3.0 .18
[110/4]
30.3.3.0 is directly connected, FastEthernet0/0 via
.10 26.6.6.2, 00:03:34, FastEthernet0/0
.6 Fa0/0
Fa0/115.0.0.0/30 15.0.0.0/30
is subnetted,
11.1.1.12/30 is subnetted, 2Rd
2 subnets
Fa0/0 subnets
Rc O E2 15.5.5.4 [110/1] B 15.5.5.4 [20/8] via 14.4.4.2, 00:02:36
Fa1/0 .13 Costo 2via 26.6.6.10, 00:14:06,
Fa1/0
FastEthernet0/1
211.1.1.0/24 O E2 15.5.5.0 [110/1] B 15.5.5.0
via 26.6.6.10,[20/8] via211.2.2.0/24
14.4.4.2,
00:14:06, 00:02:36
FastEthernet0/1
R1# R3#
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24
Rd#showRa#show
200.1.9.0/24 ip route ip route
212.2.4.0/24 212.2.5.0/24
33.0.0.0/32
33.0.0.0/32 is subnetted,
is subnetted, 1 subnets 1 subnets
.2 C 33.3.3.3 is
viadirectly connected, Loopback0
.2O 33.3.3.3 [110/7]
.2 11.1.1.13, 00:21:19, FastEthernet0/0
Fa0/0 .1 Rn OSPF 22.0.0.0/32
.1 22.0.0.0/32 is subnetted, 1 OSPF
subnets Fa0/0 .2 .1
Fa0/0 Rm is subnetted,
Fa0/0 .1 1 subnets
O 22.2.2.2 [110/8] via 11.1.1.6, 00:26:28, FastEthernet1/0
Fa0/1 R1 AS 3000 R2 .6 O 22.2.2.2 [110/2] via 11.1.1.9,
R4 00:21:19,
AS FastEthernet0/1
4000 .6
.2
.1 .5 Fa0/1 26.0.0.0/30 Rp
26.0.0.0/30
is subnetted,Fa0/1
is subnetted,
3 subnets3 subnets .5
30.3.3.0/30 .9 26.6.6.8/30 .10 30.3.3.4/30 .2 .1 .9 27.7.7.8/30 .10 Fa0/1
O E2 B 40.4.4.0/30
26.6.6.8 26.6.6.8
[110/1] [20/3]
via
Fa1/0 via 14.4.4.1,
11.1.1.13, 00:29:02
00:21:19, FastEthernet0/0 Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 B
O E2 26.6.6.0 26.6.6.0
[110/1]Fa1/1 [20/0]
via via 14.4.4.1,
11.1.1.13, .2 00:21:19,00:29:02
Costo 3 Fa0/1.5
FastEthernet0/0
Fa1/0 .5
B 26.6.6.4 [20/0] via 14.4.4.1,
Fa0/0 00:29:02 R5 Rq
O E2 26.6.6.4 [110/1] via .5 11.1.1.13, 00:21:19, FastEthernet0/0
11.0.0.0/30
11.0.0.0/30 is subnetted,
is subnetted, 5 subnets 5 subnets
C O
11.1.1.8 11.1.1.8
is directly [110/7] via 11.1.1.6,
connected, 00:26:28, FastEthernet1/0
FastEthernet0/1
C O
11.1.1.12 11.1.1.12
is directly [110/6] via 11.1.1.6,
connected, 00:26:28, FastEthernet1/0
FastEthernet0/0
.6 C 11.1.1.0 .1 .6
.1 O 11.1.1.0 [110/11]isvia directly connected,
11.1.1.9, 00:21:19,FastEthernet0/1
FastEthernet0/1
Fa0/1 C 11.1.1.4 Fa1/1
O 11.1.1.4 [110/6] is viadirectly
11.1.1.13,connected,
00:21:19,FastEthernet1/0
Fa0/1
FastEthernet0/0
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
R3 33.3.3.3/32
C C
11.1.1.16 11.1.1.16
is directly is directly
connected, connected,
FastEthernet1/1
.1
R6
FastEthernet0/0
.1 B 200.1.8.0/24
O E2 200.1.8.0/24 [110/1] via [20/20] via 14.4.4.1,
11.1.1.13, 01:02:52
00:21:21, FastEthernet0/0
Ra C 211.2.2.0/24 O 211.2.2.0/24.6 [110/7] via 11.1.1.6, 00:26:29, FastEthernet1/0
.6 Rb
is directly connected, FastEthernet1/0
B Fa1/0
200.1.9.0/24 [20/20] via 14.4.4.1, 01:02:52
O E2 200.1.9.0/24 [110/1].2 via 11.1.1.13, 00:21:22,
11.1.1.0/30 FastEthernet0/0
.1 .2
14.0.0.0/30 is subnetted, 1 subnets
.2 14.0.0.0/30 is subnetted, 1 subnets
Fa0/1 Costo 10 C Fa0/014.4.4.0 .9 is Lo 0: connected, FastEthernet1/1
Fa1/0
.5 O 14.4.4.0 [110/7] viadirectly
11.1.1.13, 00:21:22, FastEthernet0/0
Fa0/1 22.2.2.2/32

ddiaz@inictel-uni.edu.pe
.17 O 211.1.1.0/24 [110/5] via 11.1.1.6, 00:26:29, FastEthernet1/0
O 211.1.1.0/24 [110/3] via 11.1.1.13, 00:21:22, FastEthernet0/0
30.0.0.0/30
30.0.0.0/30 is subnetted,
is subnetted, 2 subnets 2 subnets
O E2 B
30.3.3.4 30.3.3.4
[110/1] [20/2] via 14.4.4.1,
via 11.1.1.13,
Fa0/1 00:29:03
00:21:23, FastEthernet0/0
OSPF
O E2 B 30.3.3.0 [20/4]
.18
30.3.3.0 [110/1] via 11.1.1.13, via
.10 14.4.4.1, 00:29:03
00:21:23, FastEthernet0/0
.6 Fa0/0
15.0.0.0/30
15.0.0.0/30 is subnetted, is subnetted,
2 subnets 2 subnets
Rc
Fa0/1 11.1.1.12/30
O
Fa0/0
15.5.5.4 [110/8]
Rd
via 11.1.1.6, 00:26:29, FastEthernet1/0
O 15.5.5.4
Costo 2 [110/2] via 11.1.1.9, 00:21:24, FastEthernet0/1
Fa1/0 .13 O 15.5.5.0 Fa1/0
[110/8] via 11.1.1.6, 00:26:29, FastEthernet1/0
211.1.1.0/24 O 15.5.5.0 [110/2] via 11.1.1.9, 00:21:24,
211.2.2.0/24 FastEthernet0/1
Rd#1000 Ra#
AS
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa1/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
Fa0/0
.5

.6 .1 .1 .6
Fa0/1 Fa0/1 Fa1/1
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
R3 33.3.3.3/32 .1
R6
.1
Ra .6
.6 Rb
Fa1/0
11.1.1.0/30 .2 .2
.1
.2
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Fa1/0 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17

Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
R6#configure.9terminal26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 30.3.3.4/30 40.4.4.0/30 Fa1/0
.9
Fa1/1
Fa0/1bgp 4000 Fa0/0 Fa1/1 Fa0/1
Fa0/0
R6(config)#router Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
R6(config-router)#neighbor 15.5.5.2 remote-as 1000 Fa0/0
.5
R6(config-router)#network 212.2.4.0 mask 255.255.255.0
R6(config-router)#network 212.2.5.0 mask 255.255.255.0
R6(config-router)#exit
R6(config)#Fa0/1 .6 .1 .1 .6
Fa1/1
Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
Rb#configureR3
terminal 33.3.3.3/32 .1
R6
.1
Rb(config)#router bgp 1000 .6
Rb(config-router)#neighbor 15.5.5.1 remote-asRa4000 .6 Rb
Fa1/0
Rb(config-router)#network 211.1.1.0 mask 255.255.255.0 11.1.1.0/30 .2 .2
.1
.2
Rb(config-router)#network 211.2.2.0 mask 255.255.255.0
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Rb(config-router)#exit Fa1/0 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17
Rb(config)#
Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 .14 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración
Rb#show ip route
33.0.0.0/32 is subnetted, 1 subnets
O 33.3.3.3 [110/8] via 11.1.1.10, 00:07:19, FastEthernet0/1
200.1.8.0/24
22.0.0.0/32 is subnetted, 1 subnets 200.1.9.0/24 212.2.4.0/24 212.2.5.0/24
C 22.2.2.2 is directly connected, Loopback0
.2
26.0.0.0/30 is subnetted, 3 subnets .2 .2
Fa0/0 .1 Rn OSPF .1 Rm OSPF Fa0/0 .2 .1
O E2 26.6.6.8 [110/1] via 11.1.1.10, 00:07:19, Fa0/0FastEthernet0/1 Fa0/0 .1
O E2Fa0/126.6.6.0
R1 [110/1] AS via 11.1.1.10,R2 00:07:19,.6 FastEthernet0/1
3000 Fa0/1 R4 AS 4000 .6
.2
.1 .5 Fa0/1 Rp .5
O E2 26.6.6.4
30.3.3.0/30 .9
[110/1] via 11.1.1.10,
26.6.6.8/30 .10 00:07:19, FastEthernet0/1
30.3.3.4/30 .2 .1 .9 27.7.7.8/30 .10 Fa0/1
Fa1/1 40.4.4.0/30 Fa1/0 Fa1/1
Fa0/011.0.0.0/30
Fa0/1is subnetted, 5 subnets
Costo 2
Fa0/0 Fa0/1 Costo 3 Fa0/1.5
.2 .2
C .5
11.1.1.8 is directly connected, FastEthernet0/1
Fa1/0 Fa1/1
Fa0/0 R5 Rq
O 11.1.1.12 [110/3] via 11.1.1.10, 00:07:19, FastEthernet0/1 .5

C 11.1.1.0 is directly connected, FastEthernet0/0


O 11.1.1.4 [110/7] via 11.1.1.10, 00:07:19, FastEthernet0/1 Observar que desde Rb se
O 11.1.1.16.6[110/8].1 via 11.1.1.10, 00:07:21, FastEthernet0/1 llega a todas las redes.1 LAN .6
Fa0/1 [110/1] via 11.1.1.10, 00:07:21, FastEthernet0/1
O E2 200.1.8.0/24 Fa0/1 Fa1/1
(06) que son los usuarios
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
B R3 [20/20] via 15.5.5.1,33.3.3.3/32
212.2.5.0/24 00:07:34 finales. .1
R6
O .1
211.2.2.0/24 [110/2] via 11.1.1.10, 00:07:21, FastEthernet0/1
Ra .6
B 212.2.4.0/24 [20/20] via 15.5.5.1, 00:07:34 .6 Rb
Fa1/0
O E2 200.1.9.0/24 [110/1] via 11.1.1.10, 00:07:21, .1
FastEthernet0/1
11.1.1.0/30 .2 .2
14.0.0.0/30 is subnetted, 1 subnets .2
Fa0/1 Costo 10 Fa0/0 Lo 0:
.5 .9
O 14.4.4.0 [110/8] via 11.1.1.10, Fa1/000:07:21, FastEthernet0/1
Fa0/1 22.2.2.2/32

ddiaz@inictel-uni.edu.pe
.17
O 211.1.1.0/24 [110/4] via 11.1.1.10, 00:07:21, FastEthernet0/1
30.0.0.0/30 is subnetted, 2 subnets
Fa0/1
O E2 30.3.3.4 [110/1] via 11.1.1.10, 00:07:21, FastEthernet0/1 OSPF .18
.10
.6 Fa0/0
O E2 30.3.3.0 [110/1] via 11.1.1.10, 00:07:21, FastEthernet0/1
15.0.0.0/30 is subnetted, 2Rc subnets Fa0/1 11.1.1.12/30 Fa0/0 Rd
.13
Fa1/0 FastEthernet1/0 Costo 2 Fa1/0
C 15.5.5.4 is directly connected, 211.2.2.0/24
211.1.1.0/24
C 15.5.5.0 is directly connected, FastEthernet1/1
AS 1000
Rb#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa1/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0
R6#show ip route Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
40.0.0.0/30 is subnetted, 2 subnets .5
Fa0/0
O 40.4.4.0 [110/3] via 27.7.7.2, 00:36:32, FastEthernet0/1
O 40.4.4.4 [110/6] via 27.7.7.2, 00:36:32, FastEthernet0/1
27.0.0.0/30 is subnetted, 3 subnets
.6 .1 .1 .6
O 27.7.7.8
Fa0/1[110/5] via 27.7.7.2, 00:36:32, FastEthernet0/1 Fa1/1
Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

C 27.7.7.0 is directly connected, FastEthernet0/1


Lo 0:
C R3is directly connected, FastEthernet1/1
27.7.7.4 33.3.3.3/32 .1
R6
.1
O E2 212.2.5.0/24 [110/20] via 27.7.7.2, 00:36:32, Ra FastEthernet0/1 .6
B 211.2.2.0/24 [20/2] via 15.5.5.2, 00:35:56 .6 Rb
Fa1/0
11.1.1.0/30 .2 .2
O E2 212.2.4.0/24 [110/20] via 27.7.7.2, 00:36:32,.1 FastEthernet0/1 Observar que desde R6 no
.2
B 211.1.1.0/24 [20/4] via 15.5.5.2, 00:35:56 Fa0/1 Costo 10 Fa0/0 Lo 0:aun a las redes LAN
Fa1/0
.5 se llega
.9
15.0.0.0/30 is subnetted, 2 subnets Fa0/1 22.2.2.2/32

ddiaz@inictel-uni.edu.pe
.17
200.1.8.0/24 y 200.1.9.0/24
O 15.5.5.4 [110/3] via 27.7.7.2, 00:36:32, FastEthernet0/1
C 15.5.5.0 is directly connected, FastEthernet0/0 Fa0/1
R6# OSPF .18
.10
.6 Fa0/0

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa1/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0
R4#show ip route Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
40.0.0.0/30 is subnetted, 2 subnets .5
Fa0/0
C 40.4.4.0 is directly connected, FastEthernet1/0
O 40.4.4.4 [110/4] via 27.7.7.10, 00:44:41, FastEthernet0/1
27.0.0.0/30 is subnetted, 3 subnets
.6 .1 .1 .6
C 27.7.7.8
Fa0/1is directly connected, FastEthernet0/1 Fa1/1
Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

C 27.7.7.0 is directly connected, FastEthernet0/0


Lo 0:
O R3 [110/8] via 27.7.7.1, 00:44:41,
27.7.7.4 FastEthernet0/0
33.3.3.3/32 .1
R6
.1
O E2 212.2.5.0/24 [110/20] via 27.7.7.10, 00:44:41,
Ra FastEthernet0/1 .6
S 212.2.4.0/24 [1/0] via 40.4.4.2 .6 Rb
Fa1/0
11.1.1.0/30 .2 .2
15.0.0.0/30 is subnetted, 2 subnets .1 Observar que desde R4 solo
.2
C Fa0/1
15.5.5.4 is directly connected, FastEthernet1/1 Fa0/0
Fa1/0
.5 Costo 10 llegaLoa 0:
.9 dos (02) redes LAN
O 15.5.5.0 [110/3] via 27.7.7.1, 00:44:41,.17 FastEthernet0/0 Fa0/1 22.2.2.2/32

ddiaz@inictel-uni.edu.pe
212.2.5.0/24 y 212.2.5.0/24
R4#
Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
R6(config)#router
Fa0/0 .1 Rn bgp 4000 OSPF .1 OSPF Fa0/0 .2 .1
Fa0/0 Rm Fa0/0 .1
R6(config-router)#redistribute ospf 1 R2
Fa0/1
.2R6(config-router)#exit R1 AS 3000 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9
R6(config)#router ospf 1 30.3.3.4/30 40.4.4.0/30 Fa1/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 bgp 4000
R6(config-router)#redistribute .2 subnets .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
Fa0/0
.5

Rb(config)#router bgp 1000


Rb(config-router)#redistribute ospf 1
.6
Rb(config-router)#exit
.1 .1 .6
Fa0/1 Fa1/1
Rb(config)#router ospf 1 Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

Lo 0:
R3
Rb(config-router)#redistribute bgp 100033.3.3.3/32
subnets .1
R6
.1
Ra .6
.6 Rb
Fa1/0
11.1.1.0/30 .2 .2
.1
.2
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Fa1/0 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17

Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Rb#show ip route
33.0.0.0/32 is subnetted,Protocolo
1 subnets BGP Configuración
O 33.3.3.3 [110/8] via 11.1.1.10, 00:02:12, FastEthernet0/1
22.0.0.0/32 is subnetted, 1 subnets
C 22.2.2.2 is directly connected, Loopback0
200.1.8.0/24 40.0.0.0/30 is subnetted, 2 subnets
212.2.4.0/24 212.2.5.0/24
B 40.4.4.0 [20/3] via 15.5.5.1, 00:03:53 200.1.9.0/24
B 40.4.4.4 [20/6] via 15.5.5.1, 00:03:53
.2
27.0.0.0/30 is subnetted, 3 subnets .2 .2
Fa0/0 .1 Rn OSPF .1 Rm OSPF Fa0/0 .2 .1
B 27.7.7.8 [20/5] via 15.5.5.1, 00:03:53 Fa0/0 Fa0/0 .1
B 27.7.7.0 [20/0] via 15.5.5.1, R200:03:53.6
.2 Fa0/1 R1 AS 3000 Rp Fa0/1 R4 AS 4000 .6
B .1 27.7.7.4 [20/0] via 15.5.5.1, 00:03:53 .5 Fa0/1 .5
30.3.3.0/30 .9 26.6.6.8/30 .10 30.3.3.4/30 .2 .1 .9 27.7.7.8/30 .10 Fa0/1
26.0.0.0/30 is subnetted, 3 subnets 40.4.4.0/30 Fa1/0 Fa1/1
Fa0/1 Fa1/1
Fa0/0 00:02:12, FastEthernet0/1 Fa0/1
Fa0/0O E2 26.6.6.8 Costo
[110/1]2via 11.1.1.10,
.2 .2 Costo 3 Fa0/1.5
OFa1/0
E2
.5
26.6.6.0 [110/1] via 11.1.1.10, 00:02:13, FastEthernet0/1
Fa1/1
Fa0/0 R5 Rq
O E2 26.6.6.4 [110/1] via 11.1.1.10, 00:02:13, FastEthernet0/1 .5
11.0.0.0/30 is subnetted, 5 subnets
C 11.1.1.8 is directly connected, FastEthernet0/1 Observar que desde Rb se
O 11.1.1.12
.6 .1
[110/3] via 11.1.1.10, 00:02:13, FastEthernet0/1 llega a todas las redes LAN .1 .6
C Fa0/111.1.1.0 is directly connected, FastEthernet0/0 (06) que son los usuarios Fa1/1
Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

O 11.1.1.4 [110/7] via 11.1.1.10, 00:02:13,Lo 0: FastEthernet0/1


O R311.1.1.16 [110/8] via 11.1.1.10, 00:02:13, FastEthernet0/1 finales. R6
33.3.3.3/32 .1
O E2 200.1.8.0/24.1 [110/1] via 11.1.1.10, 00:02:13, FastEthernet0/1
Ra .6
B 212.2.5.0/24 [20/20] via 15.5.5.1, 00:55:14 .6 Rb
O 211.2.2.0/24 [110/2] via 11.1.1.10, 00:02:13, FastEthernet0/1 Fa1/0
11.1.1.0/30 .2 .2
B 212.2.4.0/24 [20/20] via 15.5.5.1, .1
.2 00:55:14
O E2 200.1.9.0/24 [110/1] via 11.1.1.10, Fa0/1
.5 00:02:13, Costo 10 Fa0/0
FastEthernet0/1 .9 Lo 0:
Fa1/0 22.2.2.2/32
14.0.0.0/30 is subnetted, 1 subnets .17 Fa0/1

ddiaz@inictel-uni.edu.pe
O 14.4.4.0 [110/8] via 11.1.1.10, 00:02:13, FastEthernet0/1
O 211.1.1.0/24 [110/4] via 11.1.1.10, 00:02:13, FastEthernet0/1
Fa0/1
30.0.0.0/30 is subnetted, 2 subnets OSPF .18
.10
O E2 .6 Fa0/0
30.3.3.4 [110/1] via 11.1.1.10, 00:02:13, FastEthernet0/1
O E2 30.3.3.0 [110/1] via 11.1.1.10,Fa0/1
Rc
11.1.1.12/30
00:02:13, FastEthernet0/1 Fa0/0 Rd
15.0.0.0/30 is subnetted, 2 subnets Costo 2
Fa1/0 .13 Fa1/0
C 15.5.5.4 is directly connected,
211.1.1.0/24 FastEthernet1/0 211.2.2.0/24
C 15.5.5.0 is directly connected, FastEthernet1/1 AS 1000
Rb#
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

R6#show ip route
33.0.0.0/32 is subnetted, 1 subnets
200.1.8.0/24
200.1.9.0/24 212.2.4.0/24 212.2.5.0/24
B 33.3.3.3 [20/8] via 15.5.5.2, 00:14:10
.1
22.0.0.0/32 is subnetted, 1 subnets
.2
B .2 22.2.2.2 [20/0] via 15.5.5.2, 00:14:10 .2
Fa0/0 .2 .1
Fa0/0 Rn OSPF
40.0.0.0/30 is subnetted, 2 subnets Fa0/0
.1 Rm Fa0/0 .1 OSPF
O.2 Fa0/1 R1[110/3]AS
40.4.4.0 via3000 R2 FastEthernet0/1
27.7.7.2, 00:14:56, .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
O 40.4.4.4.9 [110/6]26.6.6.8/30 .10
via 27.7.7.2, 00:14:56, FastEthernet0/1 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 30.3.3.4/30 40.4.4.0/30 Fa1/0 .9
Fa1/1
Fa1/1
27.0.0.0/30.5Fa0/1
Fa0/0 is subnetted, Fa0/0
Costo3 2subnets .2 .2
Fa0/1 Costo 3 Fa0/1.5
O Fa1/0
27.7.7.8 [110/5] via 27.7.7.2, 00:14:56, FastEthernet0/1
Fa1/1
Fa0/0 R5 Rq
.5
C 27.7.7.0 is directly connected, FastEthernet0/1
C 27.7.7.4 is directly connected, FastEthernet1/1
11.0.0.0/30 is subnetted, 5 subnets
.6 .1 15.5.5.2, 00:14:10 .1 .6
B 11.1.1.8 [20/0]
Fa0/1 via Fa1/1
Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

B 11.1.1.12 [20/3] via 15.5.5.2, 00:14:11 Lo 0:


B 11.1.1.0R3[20/0] via 15.5.5.2, 00:14:11 33.3.3.3/32 .1
R6
.1
B 11.1.1.4 [20/7] via 15.5.5.2, 00:14:11 .6 Observar que desde R6 no
Ra Rb
B 11.1.1.16 [20/8] via 15.5.5.2, 00:14:11 .6 Fa1/0
O E2 212.2.5.0/24 [110/20] via 27.7.7.2, 00:14:58,.1FastEthernet0/1 11.1.1.0/30 .2 se .2 llega aun a las redes LAN
B 211.2.2.0/24 [20/2] via 15.5.5.2, 01:06:12
.2
.5 Fa0/1 Costo 10 Fa0/0 200.1.8.0/24
.9 Lo 0: y 200.1.9.0/24
Fa1/0 22.2.2.2/32
O E2 212.2.4.0/24 [110/20] via 27.7.7.2, 00:14:58,.17 FastEthernet0/1 Fa0/1

ddiaz@inictel-uni.edu.pe
14.0.0.0/30 is subnetted, 1 subnets
B 14.4.4.0 [20/8] via 15.5.5.2, 00:14:11 Fa0/1
B 211.1.1.0/24 [20/4] via 15.5.5.2, 01:06:12 OSPF .18
.10
.6 Fa0/0
15.0.0.0/30 is subnetted, 2 subnets Fa0/1 11.1.1.12/30 Fa0/0 Rd
O 15.5.5.4 [110/3] via 27.7.7.2, Rc 00:14:58, FastEthernet0/1
Fa1/0 .13 Costo 2 Fa1/0
C 15.5.5.0 is directly connected,
211.1.1.0/24 FastEthernet0/0 211.2.2.0/24
R6# AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24
R4#show
.2
ip route
33.0.0.0/32 is subnetted, 1 subnets .2 .2
Fa0/0 .1 Rn OSPF .1 Rm OSPF Fa0/0 .2 .1
O E2 Fa0/0
33.3.3.3 [110/1] via 27.7.7.1, 00:19:24, FastEthernet0/0 Fa0/0 .1

Fa0/1 R1is subnetted,


22.0.0.0/32 AS 3000 1 subnets R2 .6
Fa0/1 R4 AS 4000 .6
.2
.1 .5 Fa0/1 Rp .5
O E2
30.3.3.0/30
22.2.2.2.9[110/1] via 27.7.7.1, 00:19:24,
26.6.6.8/30 .10 FastEthernet0/0
30.3.3.4/30 .2 .1 .9 27.7.7.8/30 .10 Fa0/1
40.0.0.0/30Fa0/1
is subnetted, 2 subnets Fa0/0 Fa1/1 40.4.4.0/30 Fa1/0 Fa1/1
Fa0/0 Fa0/1 Costo 3 Fa0/1.5
.5 is directlyCosto 2 .2 .2
C 40.4.4.0
Fa1/0 connected, FastEthernet1/0 Fa1/1
Fa0/0 R5 Rq
O 40.4.4.4 [110/4] via 27.7.7.10, 00:20:11, FastEthernet0/1 .5
27.0.0.0/30 is subnetted, 3 subnets
C 27.7.7.8 is directly connected, FastEthernet0/1
C 27.7.7.0 is .6
directly connected, FastEthernet0/0 .1 .6
.1
O 27.7.7.4
Fa0/1[110/8] via 27.7.7.1, 00:20:11, FastEthernet0/0 Fa1/1
Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

11.0.0.0/30 is subnetted, 5 subnets Lo 0:


O E2 R3[110/1] via 27.7.7.1, 00:19:24,
11.1.1.8 FastEthernet0/0
33.3.3.3/32 .1
R6
.1
O E2 11.1.1.12 [110/1] via 27.7.7.1, 00:19:25, FastEthernet0/0 .6
O E2
Ra
11.1.1.0 [110/1] via 27.7.7.1, 00:19:25, FastEthernet0/0 .6 Rb
Fa1/0
O E2 11.1.1.4 [110/1] via 27.7.7.1, 00:19:25, FastEthernet0/0 11.1.1.0/30 .2 .2
.2
.1 Observar que desde R4 no
O E2 11.1.1.16 [110/1] via 27.7.7.1, 00:19:25, FastEthernet0/0
Fa0/1 Costo 10 Fa0/0 Lo 0:al sistema
O E2 212.2.5.0/24 [110/20] via 27.7.7.10, Fa1/0
.5
00:20:12, FastEthernet0/1 se llega
.9
Fa0/1 22.2.2.2/32

ddiaz@inictel-uni.edu.pe
.17
O E2 211.2.2.0/24 [110/1] via 27.7.7.1, 00:20:12, FastEthernet0/0 autónomo 3000
S 212.2.4.0/24 [1/0] via 40.4.4.2
Fa0/1
14.0.0.0/30 is subnetted, 1 subnets OSPF .18
.10
O E2 .6 Fa0/0 FastEthernet0/0
14.4.4.0 [110/1] via 27.7.7.1, 00:19:25,
O E2 211.1.1.0/24 [110/1] via 27.7.7.1, 00:20:12,
Rc
Fa0/1FastEthernet0/0
11.1.1.12/30 Fa0/0 Rd
15.0.0.0/30 is subnetted, 2 subnets Fa1/0 .13 Costo 2 Fa1/0
C 15.5.5.4 is directly connected,
211.1.1.0/24FastEthernet1/1 211.2.2.0/24
O 15.5.5.0 [110/3] via 27.7.7.1, 00:20:12, FastEthernet0/0 AS 1000
R4# INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa1/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 .2 Costo 3 Fa0/1.5
Fa1/0 .5 Fa1/1 R5 Rq
Fa0/0
.5

.6 .1 .1 .6
Fa0/1 Fa0/1 Fa1/1
Propiedad intelectual de Daniel Díaz @ 2014

R3 Lo 0:
.1
R6
.1 33.3.3.3/32
Ra .6
.6 Rb
Fa1/0
11.1.1.0/30 .2 .2
.1
.2
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Fa1/0 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17

Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2 .2
Fa0/0
Ra(config)#router
.1 Rn OSPF
bgp 1000 Rm Fa0/0 .1
Fa0/0
.1 OSPF Fa0/0 .1

Ra(config-router)#neighbor
Fa0/1 R1 AS 300022.2.2.2 R2remote-as
.6 1000 Fa0/1 R4 AS 4000 .6
.2
.1 .5 Fa0/1 Rp .5
Ra(config-router)#neighbor
30.3.3.0/30 .9 26.6.6.8/3022.2.2.2
.10 update-source
30.3.3.4/30 loopback 0 .2 .1 .9 27.7.7.8/30 .10 Fa0/1
Fa0/1 Fa0/0 Fa1/1 40.4.4.0/30 Fa1/0
Rb#traceroute 33.3.3.3 Fa1/1
Fa0/0
Ra(config-router)#exit Costo 2 Fa0/1 Costo 3 Fa0/1.5
.2 .2
Fa1/0 .5 Fa1/1
Fa0/0 32 msec 48 msec 16R5
1 11.1.1.10 msecRq
.5
Rb(config)#router bgp 1000 2 11.1.1.13 16 msec 96 msec 24 msec
Rb(config-router)#neighbor 33.3.3.3 remote-as 1000 3 11.1.1.5 104 msec 80 msec 84 msec
Rb(config-router)#neighbor
.6
33.3.3.3. update-source loopback 0 Rb# .1 .6
.1
Rb(config-router)#exit
Fa0/1 Fa0/1 Fa1/1
Propiedad intelectual de Daniel Díaz @ 2014

R3 Lo 0:
.1
R6
.1 33.3.3.3/32
Ra .6
.6 Rb
Fa1/0
11.1.1.0/30 .2 .2
.1
.2
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Fa1/0 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17

Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24 212.2.4.0/24 212.2.5.0/24


200.1.9.0/24

.2
.2 .2
Fa0/0 .1 OSPF .1 OSPF Fa0/0 .2 .1
Rn Fa0/0 Rm Fa0/0 .1

.2 Fa0/1 R1 AS 3000 R2 .6
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
26.6.6.8/30 .10 .2 .1 27.7.7.8/30 .10
30.3.3.0/30 .9 30.3.3.4/30 40.4.4.0/30 Fa1/0
.9
Fa1/1
Fa0/1 Fa0/0 Fa1/1 Fa0/1
Fa0/0 Costo 2 .2 O E2 212.2.5.0/24 Costo
[110/20].2via 27.7.7.10, 3 Fa0/1
00:30:27, FastEthernet0/1
R4#show ip route
Fa1/0 .5 Fa1/1
Fa0/0
.5
R5 Rq
33.0.0.0/32 is subnetted, 1 subnets O E2 211.2.2.0/24.5[110/1] via 27.7.7.1, 00:29:54, FastEthernet0/0
O E2 33.3.3.3 [110/1] via 27.7.7.1, 00:29:48, FastEthernet0/0S 212.2.4.0/24 [1/0] via 40.4.4.2
22.0.0.0/32 is subnetted, 1 subnets O E2 200.1.9.0/24 [110/1] via 27.7.7.1, 00:19:41, FastEthernet0/0
O E2 22.2.2.2 [110/1] via 27.7.7.1, 00:30:18, FastEthernet0/0 14.0.0.0/30 is subnetted, 1 subnets
.6 .1 .1 .6
40.0.0.0/30 is
Fa0/1 subnetted, 2 subnets O E2 14.4.4.0 [110/1] via 27.7.7.1, 00:29:54, FastEthernet0/0
Fa1/1
Fa0/1
Propiedad intelectual de Daniel Díaz @ 2014

C 40.4.4.0 is directly connected, FastEthernet1/0Lo 0:


O E2 211.1.1.0/24 [110/1] via 27.7.7.1, 00:29:54, FastEthernet0/0
O R3[110/4] via 27.7.7.10, 00:30:22,
40.4.4.4 FastEthernet0/1
33.3.3.3/32 30.0.0.0/30 is subnetted, 2 subnets .1 R6
.1 O E2 30.3.3.4 [110/1] via 27.7.7.1, 00:19:41, FastEthernet0/0
27.0.0.0/30 is subnetted, 3 subnets .6
C 27.7.7.8 is directly connected, FastEthernet0/1
Ra O E2 .6 30.3.3.0 Rb [110/1] via 27.7.7.1, 00:19:41, FastEthernet0/0
Fa1/0
C 27.7.7.0 is directly connected, FastEthernet0/0.1 11.1.1.0/3015.0.0.0/30
.2
is subnetted, 2 subnets
.2

O 27.7.7.4 [110/8] via 27.7.7.1, 00:30:22, .2 FastEthernet0/0C


Fa0/1 Costo 10 Fa0/0
15.5.5.4 is directly connected, FastEthernet1/1
.5 .9 Lo 0:
26.0.0.0/30 is subnetted, 3 subnetsFa1/0 O 15.5.5.0 [110/3] via 27.7.7.1, 00:30:27, FastEthernet0/0
22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17
O E2 26.6.6.8 [110/1] via 27.7.7.1, 00:19:35, FastEthernet0/0R4#
O E2 26.6.6.0 [110/1] via 27.7.7.1, 00:19:41, FastEthernet0/0
Observar
Fa0/1 que desde R4
O E2 26.6.6.4 [110/1] via 27.7.7.1, 00:19:41, FastEthernet0/0 OSPF .18
ahora
.10 si se llega al sistema
11.0.0.0/30 is subnetted, 5 subnets .6 Fa0/0
O E2 11.1.1.8 [110/1] via 27.7.7.1, 00:30:24,Fa0/1
Rc
11.1.1.12/30
FastEthernet0/0 Fa0/0 autónomo Rd 3000
O E2 11.1.1.12 [110/1] via 27.7.7.1, 00:29:54,
Fa1/0 .13 FastEthernet0/0 Costo 2 Fa1/0
O E2 11.1.1.0 [110/1] via 27.7.7.1, 00:30:24, FastEthernet0/0
211.1.1.0/24 211.2.2.0/24
O E2 AS 1000
11.1.1.4 [110/1] via 27.7.7.1, 00:29:54, FastEthernet0/0
O E2 11.1.1.16 [110/1] via 27.7.7.1, 00:29:54, FastEthernet0/0
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

200.1.8.0/24
212.2.5.2 212.2.4.0/24
200.1.9.0/24
Rn#traceroute 212.2.5.0/24
1 30.3.3.1 32 msec 56 msec 20 msec
.2
2 26.6.6.10.2 48 msec 36 msec 64.2 msec
Fa0/0 .1 OSPF .1 Rm OSPF Fa0/0 .2 .1
Rn Fa0/0 Fa0/0
3 26.6.6.1 48 msec 56 msec 64 msec .1

.2 Fa0/1 R1 AS 3000 R2
4 14.4.4.2
.6 100 msec 76 msec 72 msec
Rp Fa0/1 R4 AS 4000 .6
.1 .5 Fa0/1 .5
Fa0/1
30.3.3.0/30 .9 26.6.6.8/30 .10 5 11.1.1.6 144 msec 88 msec 100.2 msec.1
30.3.3.4/30 .9 27.7.7.8/30 .10
Fa0/1 Fa1/1 40.4.4.0/30
Fa0/06 11.1.1.14 120 msec 120 msec 120 msecFa1/0 Fa1/1
Fa0/0 Costo 2 Fa0/1 Costo 3 Fa0/1.5
.2 .2
Fa1/0 .5
7 11.1.1.9 148 msec 144 msec 172 msec
Fa1/1
Fa0/0 R5 Rq
.5
8 15.5.5.1 136 msec 148 msec 160 msec
9 27.7.7.2 184 msec 188 msec 188 msec
10 27.7.7.10 228 msec 164 msec 216 msec
.6 .1 .6
.1 11 40.4.4.6 228 msec 256 msec 220 msec
Fa0/1 Fa0/1 Fa1/1
12 212.2.5.2 244 msec 216 msec 244 msec
Propiedad intelectual de Daniel Díaz @ 2014

R3 Lo 0:Rn#
.1
R6
.1 33.3.3.3/32
Ra .6
.6 Rb
Fa1/0
11.1.1.0/30 .2 .2
.1
.2
.5 Fa0/1 Costo 10 Fa0/0 .9 Lo 0:
Fa1/0 22.2.2.2/32
Fa0/1

ddiaz@inictel-uni.edu.pe
.17

Fa0/1
Fa0/0
OSPF .18
.10
.6

Rc
Fa0/1 11.1.1.12/30 Fa0/0 Rd
Fa1/0 .13 Costo 2 .14 Fa1/0
211.1.1.0/24 211.2.2.0/24
AS 1000
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

LABORATORIO
LABORATORIO
PARA EL PARCIAL
Propiedad intelectual de Daniel Díaz @ 2014

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

Rb Rc
.2 .5 20.1.1.4/30 .6 .9
Lo 1: Costo 12 Lo 2:
45.5.5.5/24 .21 .26 46.6.6.6/24
AREA 0
.1 .22 Re .25 .10
Ra 20.1.1.12/30 20.1.1.16/30 Rd
.13 Costo 15 .14 .17 Costo 18 .18
ASN 3000 ASN 2000 ASN 4000
R1 .1 .5 .1 .5 R6
Propiedad intelectual de Daniel Díaz @ 2014

AREA 0 AREA 0
.2 Costo 1 .6 .2 Costo 7 .6
R2 .9 30.1.1.8/30 .10 R3 R7 .9 40.1.1.8/30 .10 R8
.13 .17 .13 .17
30.1.1.16/30

40.1.1.16/30
30.1.1.12/30

40.1.1.12/30
Enrutamiento

Costo 2
Costo 3

AREA AREA
estático al
1 RIPv2 1

ddiaz@inictel-uni.edu.pe
200.4.5.0/24
.14 .18 .14 .18
R4 R5 R9 R10
Enrutamiento
.1 .1 .1 por default .1

.2 .2 .2 .2

200.3.4.0/24 200.3.5.0/24 200.4.4.0/24 200.4.5.0/24


INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI
Protocolo BGP Configuración

BGP Case Studies-CISCO


http://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/26634-bgp-toc.html

Configuración de una Red BGP Básica


http://www.cisco.com/cisco/web/support/LA/111/1116/1116
297_irg-basic-net.pdf
Propiedad intelectual de Daniel Díaz @ 2014

ddiaz@inictel-uni.edu.pe
INSTITUTO NACIONAL DE INVESTIGACION Y CAPACITACION DE TELECOMUNICACIONES, INICTEL-UNI