Вы находитесь на странице: 1из 82

Учебное руководство по Concept HDL

Версия продукта 15.1

Ноябрь 2003

Ноябрь 2003 Версия продукта 15.1


2000-2003 Cadence Design Systems, Inc. Все права защищены.
Документ напечатан в Соединенных Штатах Америки.

Cadence Design Systems, River Oaks Parkway, San Jose, CA 95134, USA.
Торговые марки: Торговые марки и марки обслуживания Cadence Design Systems, Inc
(Cadence), содержащиеся в этом документе, являются признаком Cadence с соответствующим
знаком. По вопросам относительно торговых марок Cadence свяжитесь с корпоративным
юридическим отделом по адресу, указанному выше, или звоните 1-800-862-4522.
Все другие торговые марки - собственность их соответствующих обладателей.
Ограниченное разрешение печати: Эта публикация защищена авторским правом, и любое
несанкционированное использование этой публикации может нарушить авторское право,
торговую марку, и другие законы. Кроме того, как определено в этом утверждающем
разрешении, эта публикация не может быть скопирована, воспроизведена, изменена, издана,
загружена, отправлена, передана, или распространена в любом случае, без предварительного
письменного разрешения от Cadence. Это утверждение предоставляет Вам разрешение
напечатать одну (1) документальную копию этой публикации, подлежащей следующим
условиям:
1. Публикация может использоваться исключительно в личных, информационных и
некоммерческих целях;
2. Публикация не может в любом случае быть изменена;
3. Любая копия публикации или ее части должна включать все оригинальное авторское право,
торговую марку, и другие составляющие собственность уведомления и данное разрешение;
4. Cadence резервирует право отменить это разрешение в любое время, и любое
использование документа должно быть прекращено после письменного уведомления от
Cadence.
Правовая оговорка: Информация в этой публикации является предметом для внесения
изменений без уведомления и не представляет обязательство со стороны Cadence.
Информация, содержащаяся в данном документе, является собственностью и
конфиденциальной информацией Cadence или ее лицензиаров, и предоставлена в
соответствии с ними, также может использоваться только клиентом Cadence в соответствии с
письменным соглашением между Cadence и ее клиентом. Cadence не предоставляет и
отказывается от предоставления гарантии относительно законченности, точности или
полноценности информации, содержавшейся в этом документе. Cadence не гарантирует, что
использование такой информации не будет нарушать прав третьего лица, и при этом Cadence
не принимает ответственности за убытки или затраты любого вида, связанные с
использованием такой информации.
Ограниченные Права: Незаконное использование, дублирование или обнаружение данной
информации правительством являются предметом для возбуждения уголовного наказания в
соответствии с FAR52.227-14 и DFAR252.227-7013 и т.д., или его преемником.

Ноябрь 2003 Версия продукта 15.1


Содержание

1
Введение в учебное руководство по Concept HDL………………5
Краткий обзор....................................................................... …………………………………..5
Concept HDL в потоке проектирования печатных плат (PCB)………………………………6
Как использовать это учебное руководство…………............................................................. 8
Краткое оглавление.................................................................................................................... 8

2
Создание проекта………………………………………………………………11
Краткий обзор............................................................................................................................ 11
Что представляют собой библиотеки?.....................................................................................11
Что представляет собой файл cds.lib?.....................................................................................16
Создание проекта..................................................................................................................... .17
Добавление библиотек при помощи установок проекта....................................................... 23
Что представляет собой проектный файл

3
Создание схем: Основы……………………………………………………….31
Краткий обзор........................................................................................................................... 31
Введение в Concept HDL......................................................................................................... 32
Настройки предизбранной модели........................................................................................ 34
Добавление ограничивающей рамки..................................................................................... 35
Добавление ограничивающей рамки вручную............................................................ 36
Настройка параметров добавления ограничивающей рамки…................................. 37
Добавление текста (примечания)............................................................................................ 44
Выбор и добавление компонентов.......................................................................................... 47
Соединение элементов………………………….………........................................................ 50
Обозначение проводов............................................................................................................. 54
Добавление портов................................................................................................................... 55
Питание и заземление.............................................................................................................. 57

Сохранение схемы………………………………………..................................................... 70

Рассмотрение Verilog описания ….. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71


Добавление страниц к схеме…………………………………............................................. 72
Создание шин…….. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75
Отвод шин…………………………………………….......................................................... 81
Добавление физических данных. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83
Ноябрь 2003 Версия продукта 15.1
Сохранение и просмотр ошибок………………………….................................................. 87

4
Создание схемы: Расширенная информация……………………………....95
Использование групп…………………………………............................................................ 96
Созданий группы по выражению........................................................................................... 96
Создание группы с помощью прямоугольника………………………………………………97
Создание группы с помощью многоугольника...................................................................... 99
Создание иерархических проектов......................................................................................... 100
Метод нисходящего проектирования………………………................................................. 101
Метод восходящего проектирования……………….………................................................ 102
Создание иерархического проекта при помощи метода нисходящего проектирования.. 102
Создания иерархического проекта при помощи метода восходящего проектирования . 120
Создание Символа................................................................................................................... 123
Создание страничного проекта на высоком уровне иерархии………….…...................... 125
Изменение высокоуровневого проектирования. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 128
Подготовка схематического проекта..….……………………............................................. 130
Настройка параметров проектирования………………………........................................... 130
Предварительный просмотр проекта. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 133
Проектирование схемы…………………………………....................................................... 135
Иерархическое проектирование………………………….................................................... 136
Упаковка проекта………........................................................................................................ 142
Использование Глобального поиска..................................................................................... 144
Исправление ошибок в Assigning Physical Parts ………………….…. ............................. 146
Упаковка проекта после исправления ошибок................................................................... 149

Ноябрь 2003 Версия продукта 15.1


1
Введение в учебное руководство по Concept HDL

Эта глава содержит следующую информацию:

• Краткий обзор – стр. 5

• Как использовать учебное руководство – стр. 8

Краткий обзор
Данное учебное руководство демонстрирует главные задачи, связанные с
созданием схем, с использованием Concept HDL. Concept HDL является
инструментом, используемым для ввода проекта (также известный как Design
Capture) в потоке проектирования печатных плат. Concept HDL позволяет Вам
создавать схему, размещать компоненты (части), соединять их, обозначать сигналы,
добавлять порты, и сохранять проекты. Когда Вы сохраняете проект, Concept HDL
осуществляет проверку его на ошибки, и помогает Вам локализовать места на схеме,
содержащие ошибки.

В составе Concept HDL имеются две модели - постизбранная и предизбранная, в


которых Вы можете непосредственно работать. Используя постизбранную модель,
Вы сначала выбираете команду, затем выбираете схемный компонент. При
использовании предизбранной модели сначала выбирается схематический
компонент, а затем - сама команда.

Например, Вы хотите удалить схемный компонент.

В постизбранной модели необходимо выполнить следующие шаги:

• Выбрать Edit > Delete

• Выбрать компонент, который следует удалить.

В предизбранной модели шаги следующие:

• Выбрать компонент, который следует удалить.

• Выбрать Edit > Delete.

Ноябрь 2003 Версия продукта 15.1


По умолчанию Concept HDL поддерживает постизбранную модель для схематических
операций. Это учебное руководство отображаетася в предизбранном режиме. Чтобы
узнать больше о предизбранном режиме, см. Настройка предизбранной модели на
странице 34.

Concept HDL в потоке проектирования печатных плат

Целью данного учебного руководства является объяснение процесса


создания схематического проекта при использовании Concept HDL.
Concept HDL поможет Вам овладеть навыками проектирования печатных плат в
схематическом представлении. Процесс проектирования осуществляется и встроен
в Allegro, а также позволяет выполнять размещение и трассировку. Полностью
спроектированное изделие направляют на предприятие для производства
печатных плат. Следующий рисунок иллюстрирует полный цикл проектирования
печатной платы и освещает моменты, в которых Concept HDL вступает в силу.

Ноябрь 2003 Версия продукта 15.1


Как пользоваться этим руководством

Эта обучающее руководство позволяет приобрести опыт в области создания


проекта, используя Concept HDL. Чтобы понять, как можно использовать Concept
HDL при создании проекта, Вы должны следовать за шагами в той
последовательности, в которой они появляются в главах этого обучающего
руководства.

Обратите внимание
Обучающее руководство по Concept HDL написано в порядке, в котором
большинство пользователей обычно создает схематические проекты.
Следуйте за шагами в обучающем руководстве в указанной
последовательности. Таким образом Вы ускорите процесс освоения
методов, необходимых для создания схематического проекта.
Рекомендуется закончить это обучающее руководство за одну сессию,
которая потребует приблизительно 8 часов напряженной работы. Если
Вы планируете пройти обучающее руководство за несколько дней, то
Вам следует ежедневно осваивать не менее одной главы.

Прежде, чем использовать обучающее руководство, Вы должны разархивировать


файл <your_inst_dir>/doc/concepthdl_tut/tutorial_examples/local_lib.zip в операционной
среде Windows NT, или
<your_inst_dir>/doc/concepthdl_tut/tutorial_examples/local_lib.tar.z
на UNIX, и сохранить этот файл. Библиотека local_lib, которая является
справочником, содержит главы, которые Вы будете использовать для создания
схематического проекта.

Краткий обзор глав

Руководство по Concept HDL разделено на три главы:

■ Создание проекта – стр. 11


В этой главе поясняется, что представляет собой проект. В ней также содержится
описание библиотек, файла cds.lib и проектного файла. Приводится
последовательность действий по созданию и настройке проекта.

■ Создание схематического проекта: Основы – стр. 31


Эта глава объясняет основные задачи, связанные с созданием простых
многостраничных схематических проектов. Рассмотрены задачи, связанные с
добавлением компонентов, их соединением, сохранением и проверкой проекта,
созданием электрических шин и их подключением, добавлением физических данных.

■ Создание схематического проекта: Переход на страницу 95


В данной главе приводятся основные задачи, которые Вы выполняете, создавая

Ноябрь 2003 Версия продукта 15.1


иерархические проекты. В связи с этим существует два метода, которые
используются для создания иерархического проекта. Для этого выполняются
соответствующие процедуры, в основе которых лежат методы нисходящего the Top
Down и восходящего the Bottom Up проектирования. В главе также приводится
способы надлежащего оформления проекта. Если во время оформления проекта
обнаружены ошибки, с помощью утилиты Глобальный поиск можно будет
определить местонахождение компонентов. Чтобы отредактировать свойства,
примененные к компонентам, необходимо воспользоваться диалоговым окном
Attributes. После того, как все ошибки устранены, требуется повторная упаковка
проекта.

Ноябрь 2003 Версия продукта 15.1


2
Создание проекта

Эта глава содержит следующую информацию:

❑ Краткий обзор – стр. 11

❑Что представляют собой библиотеки – стр. 11

❑ Что представляет собой файл cds.lib? – стр. 16

❑ Что представляет собой проектный файл? – стр. 16

■ Создание проекта – стр. 17

■ Добавление библиотек при использовании установок проекта – стр. 23

Краткий обзор

Первоначальной задачей, которую Вы выполняете при проектировании


печатных плат (PCB), является создание проекта. Создание проекта - герметизация
путей к библиотекам, таблицам элементов, настройкам инструментальных средств,
глобальным настройкам, обзору имен директорий, и другим настройкам для
проектирования PCB в соответствии с необходимыми спецификациями.

Процесс проектирования проекта состоит из следующих составных частей:

• Справочная библиотека,

• Встроенные библиотеки (библиотеки проектирования),

• Файл cds.lib

Ноябрь 2003 Версия продукта 15.1


• Проектный файл (.cpm файл)

Ниже приводится полная информация по каждому вышеуказанному разделу.

Что представляют собой библиотеки?

Процесс проектирования начинается с создания схематического проекта и


затем на уровне плат осуществляется передача логического проекта к
непосредственному изготовителю печатных плат. Для выполнения этого процесса
инструментальные средства нуждаются в программном обеспечении, которое
предоставляет различные компоненты, которые будут использоваться в проекте.
Представления этих компонентов организованы в библиотеки.

Различные инструментальные средства, используемые на различных стадиях цикла


проекта, нуждаются в различных представлениях или информации о той же самом
компоненте. Некоторые из этих представлений являются схематическими,
посадочными местами, а также имитацией.

Эти представления организованы в несколько библиотек. Например, посадочные


места различных компонентов объединены в единственную проектную библиотеку.

Организация инструментальных средств библиотеки Cadence Board Design


приведена ниже:

Ноябрь 2003 Версия продукта 15.1


■ Схематические библиотеки
Эти библиотеки содержат информацию, необходимую для входа в среду
проектирования или схематического создания проекта. Информация,
содержавшаяся в этих обзорах, включает логические символы (графические
представления компонентов), выводы, и упаковочную информацию.

■ Библиотеки Layout
Эти библиотеки содержат посадочные места, которые соответствуют физическим
компонентам, определенных в схематических библиотеках. Эти библиотеки
требуются на этапе разработки топологии в процессе проектирования.

■ Библиотеки моделирования
Данные библиотеки моделируют поведение компонентов на языках Verilog или
VHDL. Эти библиотеки требуются во время фазы проверки.

Cadence поставляет ряд справочных библиотек, которые содержат представления


компонентов, принадлежащих различным сериям логическим схем. Стандартная
библиотека (The Standard Library) - пример справочной библиотеки. Эти библиотеки
обычно хранятся в области, для доступа к которой Вы не имеете письменного
разрешения, и управляются библиотекарем.

Стандартная библиотека Cadence расположена в директории


<your_inst_dir>/share/library.

Ноябрь 2003 Версия продукта 15.1


Следующая таблица описывает каждый компонент, находящийся в справочной
библиотеке.

Обзор названий Описание

Ноябрь 2003 Версия продукта 15.1


sym_1 Содержит схематический символ
entity Содержит основной список выводов. Его можно
просмотреть после сохранения схематического символа.
chips Отображает логическую ИС согласно физической
упаковке.
part_table Содержит дополнительные свойства, которые помогают
настроить элементы для группы.

Локальные библиотеки (также известные как библиотеки проекта) используются


проектировщиками на локальном проектном уровне. Вы можете импортировать
справочные библиотеки и изменять их согласно требованиям Вашего проекта, или
можете использовать справочные библиотеки в том виде, какие они есть.

Ноябрь 2003 Версия продукта 15.1


Следующая таблица описывает каждое представление в библиотеке проекта.
Обзор названий Описание
sch_1 Содержит описание схем
entity Содержит высокоуровневое описание проекта
packaged Содержит результаты упаковки
physical Содержит узлы посадочных мест

Что представляет собой файл cds.lib?


Concept HDL является схематическим редактором с ссылками. Это означает, что в
Ноябрь 2003 Версия продукта 15.1
Concept HDL можно обратиться ко всем элементам схематического редактора из
различных библиотек, расположенных в справочной библиотеке или локальной
области.

Файл cds.lib определяет все библиотеки, используемые в Вашем схематическом


проекте, которые отображаются согласно их физическим местоположениям.

Содержание типичного cds.lib файла:


DEFINE lsttl ../../library/lsttl
DEFINE memory ../../library/memory
DEFINE54alsttl ../../library/54alsttl
DEFINE 54fact ../../library/54fact

Что представляет собой файл проекта?


Когда Вы создаете новый проект, менеджер проектов Project Manager создает
проектный файл, называемый <projectname>.cpm в директории проекта. Файл
<Projectname>.cpm включает следующую настроечную информацию для Вашего
проекта:

• Название высокоуровневого проекта и библиотеки, в которой он расположен.

• Список библиотек проекта.

• Название и расположение текстового редактора, предназначенного для


редактирования текстовых файлов с помощью инструментов Cadence.

• Местоположение временной директории, где с помощью инструментальных


средств генерируются промежуточные данные.

• Инструкции по установке индивидуальных инструментов, таких Concept HDL,


Packager-XL, Programmable IC, and Allegro.

• Инструкции для настройки Project Manager (настроенное меню Tools или


настроенные потоки).
• Название текущей сессии.

Ноябрь 2003 Версия продукта 15.1


Создание проекта
Чтобы создать проект, следует использовать Project Manager. Вы можете начать
работу Project Manager следующими способами:

• В Windows NT выберите Start > Программы > Cadence 15.0 > Project Manager .

• В UNIX наберите projmgr в командной строке.

Появляется окно Project Manager.

Ноябрь 2003 Версия продукта 15.1


Кнопка Open Project используется, чтобы открыть существующий проект. Чтобы

создать новый проект, следует использовать кнопку Create Design Project. В этой

главе Вы научитесь создавать новые проекты, названные tutorial. Проектные файлы

будут храниться в папке theDesigns на диске D:\.

1. Чтобы начать создание проекта, нажмите на Create Design Project.


Появляется Мастер Новых проектов (New Project Wizard).

2. В первом окне мастера определите название проекта и местоположение, где


будут создаваться файлы проекта. В качестве имени проекта выберите tutorial.
Мастер проектов создаст файл с названием tutorial.cpm.
3. Откройте диск, на котором хранится папка с вашим проектом, то есть D:\Designs.
Если директории Designs не существует, Project Manager создаст ее. Вы также
можете использовать кнопку просмотра для определения местоположения проекта.
4. Щелкните Next.

Ноябрь 2003 Версия продукта 15.1


Появится окно The New Project Wizard - Project Libraries.

Окно The Project Libraries позволяет выбирать библиотеки для Вашего проекта из
списка доступных библиотек. По умолчанию, библиотека, названная tutorial_lib
(<project_name> _lib), добавлена к списку библиотек проекта. Это название является
логическим именем библиотеки. После того, как проект создан, физическое
название этой библиотеки будет worklib. Файл cds.lib определяет библиотеку
tutorial_lib как worklib.
The Standard Library также добавлена по умолчанию в список библиотек проекта.
Примечание: Чтобы добавить другие библиотеки к списку доступных библиотек,
Вам следует отредактировать файл cds.lib. За дополнительной информацией
обратитесь к разделу Добавление библиотек при помощи настроек проекта – стр. 23
5. В этом проекте Вы добавляете две библиотеки, lsttl и memory, к библиотеке
проекта. Выберите lsttl из списка доступных библиотек.
6. Нажмите Add .

Ноябрь 2003 Версия продукта 15.1


Мастер Менеджера проектов (Project Manager Wizard) добавит lsttl к списку
библиотек проекта.
7. Выберите библиотеку memory из списка доступных библиотек.
8. Нажмите Add .
Мастер Менеджера проектов добавит библиотеку memory к списку библиотек
проекта.
9. Щелкните Next.
Появится окно The Design Name.

10. В качестве библиотеки проекта выберите tutorial_lib.


Высокоуровневый проект будет размещен ниже библиотеки tutorial_lib.
11. Выберите desexample как название высокоуровневого проекта.

Ноябрь 2003 Версия продукта 15.1


12. Щелкните Next.

В итоге отображается окно, содержащее информацию, указанную Вами при помощи


Project Manager. Чтобы изменить детали, Вы можете щелкнуть на Previous, за счет
чего возвратитесь к предыдущему окну.

13.Щелкните Finish.

Ноябрь 2003 Версия продукта 15.1


Менеджер проектов создает проект и отображает поток управлением проекта.

Ноябрь 2003 Версия продукта 15.1


Ноябрь 2003 Версия продукта 15.1
Добавление библиотек при помощи установок проекта
После того, как при помощи Мастера создания проекта был создан проект, Вы
можете вносить в него изменения, такие как добавление новых библиотек и
элементов к проекту. В этом разделе Вам следует добавить библиотеку local_lib к
списку библиотек проекта.
1. В Windows NT разархивируйте файл local_lib.zip, доступный в директории
<your_inst_dir>/doc/concepthdl_tut/tutorial_examples и извлеките его содержимое
в D:\Designs\local_lib.
В UNIX распакуйте файл local_lib.t.Z, доступный в директории <your_inst_dir> /
doc/concepthdl_tut/tutorial_examples и извлеките его содержимое в директорию
/ Designs/local_lib/.
Примечание: библиотека local_lib создана только для текущего обучающего
руководства и не является стандартным файлом библиотеки.
2. Щелкните на значок Setup в окне Project Manager.
Появится диалоговое окно Project Setup.

3. Нажмите на Edit рядом с областью cds.lib.


Менеджер проектов откроет файл cds.lib в текстовом редакторе.

Ноябрь 2003 Версия продукта 15.1


4. В файле cds.lib добавьте следующую строку.
DEFINE local_lib local_lib
Эта строка в файле cds.lib добавляет библиотеку thelocal_lib к списку доступных
библиотек.
5. Сохраните и закройте cds.lib файл. Менеджер проектов показывает следующее
сообщение.

6. Щелкните Yes. Менеджер проектов обновляет список Доступных Библиотек.


7. Выберите local_lib из списка Доступных Библиотек.
8. Нажмите Add.

9. Выберите local_lib из списка библиотек проекта.

Ноябрь 2003 Версия продукта 15.1


10. Нажмите на Up, пока библиотека local_lib не расположится после tutorial_lib
в списке Библиотек проекта (Project Libraries).

11. Нажмите Apply.


12. Нажмите на вкладку Part Table .

Ноябрь 2003 Версия продукта 15.1


13. Нажмите Add около области Physical Part Table Files.
Появится диалоговое окно Add Physical Part Table.

14. Выберите File.


Откроется окно с обзором файлов.

Ноябрь 2003 Версия продукта 15.1


15. Откройте папку local_lib.

16. Выберите файл local_lib.ptf и щелкните на Open.

Ноябрь 2003 Версия продукта 15.1


Диалоговое окно Add Physical Part Table отображает путь к файлу local_lib.ptf.

17. Нажать OK.

Ноябрь 2003 Версия продукта 15.1


Область Physical Part Table Files в Part Table показывает путь к local_lib.ptf файлу.

18. Нажать OK.

Ноябрь 2003 Версия продукта 15.1


3
Создание схем: Основы

Краткий обзор

Эта глава содержит следующую информацию:

• Запуск Concept HDL – стр. 32

• Добавление ограничивающей рамки – стр. 35

• Добавление текста (Примечания) – стр. 44

• Выбор и добавление компонентов – стр. 47

• Соединение частей – стр. 50

• Обозначение проводов – стр. 54

• Добавление портов – стр. 55

• Добавление питания и заземления – стр. 57

• Сохранение схем – стр. 70

• Рассмотрение описания Verilog – стр. 71

• Добавление страниц к схематическому проекту – стр. 72

• Создание шин – стр. 75

• Выявление (отвод) шины – стр. 81

• Добавление Физических данных – стр. 83

• Сохранение и просмотр Ошибок – стр. 87

Ноябрь 2003 Версия продукта 15.1


Запуск Concept HDL
Первым шагом в создании логического проекта является запуск Concept HDL.
Используя Concept HDL, Вы можете размещать компоненты из библиотек проекта и
соединять их. Чтобы создать логический проект Project Manager щелкните на
Design Entry.

Появляется окно Concept HDL, отображающее имя проекта в области заголовка.

Следующий рисунок объясняет соглашения в области обозначений, принятые


согласно Concept HDL.

Ноябрь 2003 Версия продукта 15.1


Строка заголовка также отображает термин in hierarchy в пределах квадратных
скобок. In hierarchy является одним из трех режимов, используемых в Concept HDL.

Иерархический режим
Когда Вы открываете проект в Concept HDL, отображается чертеж высокого уровня,
и строка названия показывает имя проекта in hierarchy в пределах квадратных
скобок. Это означает, что Concept HDL распознает проект со всеми его страницами
и уровнями.

Вы можете переходить на следующие и возвращаться на предыдущие страницы и


уровни в этом проекте, используя Edit Hierarchy > Ascend и File > Edit Hierarchy >
Descend, соответственно. Вы можете также использовать File > Return, чтобы
возвратиться к предыдущей странице, которую Вы просмотрели.
Когда Вы открываете чертеж, который не используется в проекте и не находится в
иерархии схемы, Concept HDL отображает только название проекта в строке
заголовка. Вы не можете использовать File > Return в этом случае.

Ноябрь 2003 Версия продукта 15.1


Настройка предизбранной модели

Concept HDL поддерживает две модели - предизбранную и постизбранную.


Постизбранная модель используется по умолчанию. Чтобы работать в
предизбранной модели, следует изменить параметры настройки Concept HDL. Чтобы
в Concept HDL установить предизбранную модель, выполните следующие шаги:
1. Выберите Tools > Options.
В диалоговом окне Concept Options отображается вкладка General c выбранными
позициями.
Во вкладке the Preferences выберите флажок Enable Pre-select Mode.

2. Нажмите OK, чтобы сохранить настройки и закрыть диалоговое окно Concept


Options.
Предизбранный режим запущен.
Примечание: Вы можете проверить, доступна ли предизбранная модель или нет,
обратившись к раскрывающемуся меню Edit. В предизбранной модели возможности
команд, таких как Copy, Move, Delete, Rotate и Spin - отключены по умолчанию. Эти
возможности доступны только после того, как Вы выбрали схематический
компонент.

Ноябрь 2003 Версия продукта 15.1


Редактирование раскрывающегося меню в предизбранном режиме

3. В рамках данного руководства мы будем работать в постизбранном режиме.


Отмените опцию Enable Pre-select Mode во вкладке General диалогового окна
Concept Options.

Добавление ограничивающей рамки


Первым шагом при создании любого проекта является добавление ограничивающей
чертежной рамки. В Вашем проекте может отсутствовать ограничивающая рамка, но
лучше взять в привычку добавление ограничивающих рамок. Границы требуются в
том случае, когда Вы выходите за рамки проекта. Когда Вы подготавливаете
схематический проект, часто трудно проследить сигнал или части элемента.
Перекрестная ссылка (Cross Referencer) прослеживает сигналы и элементы в схеме
и описывает местоположение каждого из них в файле. Перекрестная ссылка
записывает номер страницы и местоположение элемента или сигнала относительно
ограничивающей рамки.

Существует два пути, воспользовавшись которыми, Вы сможете добавить


ограничивающую рамку. Первый метод состоит в добавлении ограничивающей рамки

Ноябрь 2003 Версия продукта 15.1


вручную на каждой странице, а второй метод состоит в установке опций в Concept
HDL таким образом, чтобы ограничивающая рамка добавлялась, как только была
создана новая страница.

Добавление ограничивающей рамки вручную

Concept HDL рассматривает ограничивающие рамки как компоненты.


1. Чтобы выбрать и поместить ограничивающую рамку, следует выбрать Component
> Add.
Появляется окно с обзором компонентов, как показано на следующем рисунке.

2. Выберите Standard в поле библиотек.


Компоненты, содержащиеся в стандартной библиотеке, отобразятся в списке

Ноябрь 2003 Версия продукта 15.1


элементов.
3. Выберите CADENCE A SIZE PAGE из списка элементов.
4. Щелкните в окне проекта.
Concept HDL показывает ограничивающую рамку.
5. Щелкните Close.

Настройка опций для добавления ограничивающей рамки

Вы также можете задать опции в Concept HDL таким образом, чтобы


ограничивающая рамка добавлялась по умолчанию всякий раз, когда новая
страница добавлена к проекту.
1. Чтобы установить опции для автоматического добавления ограничивающих рамок,
следует выбрать Tools > Options.
Откроется диалоговое окно Concept Options с вкладкой General и выбранными
позициями.

Ноябрь 2003 Версия продукта 15.1


2. Во вкладке Page Border установите название и версию символа ограничивающей
рамки, которая должна быть добавлена ко всем страницам.
Чтобы определить название символа, щелкните Browse.
Откроется диалоговое окно View Open.

Ноябрь 2003 Версия продукта 15.1


3. В диалоговом окне View Open, выберите Library как Standard.
Появится список компонентов, доступных в библиотеке Standard.

4. В списке выберите ограничивающую рамку. В рамках данного учебного


руководства, выберите CADENCE A SIZE PAGE and нажмите Open.
Вновь появится диалоговое окно Concept Options с опциями Symbol and Version

Ноябрь 2003 Версия продукта 15.1


ограничивающей рамки.

5. Нажмите OK, чтобы сохранить настройки.


6. В окне проектирования Concept HDL выберите File > New .
В результате будет добавлена новая страница с ограничивающей рамкой. У всех
страниц, добавленных к проекту, теперь будут подобные ограничивающие рамки.

Ноябрь 2003 Версия продукта 15.1


Добавление Текста (Примечаний)
Вы можете также добавлять такие детали, как:

• Название (имя проекта),

• Инженер (имя инженера, который создал проект),

• Дата (дата создания),

• Страница (номер страницы),

Чтобы добавить текст на ограничивающую рамку, Вы должны изменить масштаб


изображения той области, куда Вы хотите разместить текст.

Чтобы изменить масштаб в области

1. Щелкните кнопкой Zoom Points на стандартной панели инструментов.

2. Нажмите на окно проекта и протяните таким образом мышью, чтобы


сформировать прямоугольник для изменения масштаба в области ограничивающей
рамки.

3. Как только прямоугольник, который Вы нарисовали, обозначил область, масштаб


которой Вы хотели изменить, щелкните снова в окне проекта.

Ноябрь 2003 Версия продукта 15.1


Concept HDL изменяет масштаб выделенной области.

Чтобы добавить текст (примечания) в ограничивающую рамку


1. Выберите Text > Note. Откроется диалоговое окно Note.

Ноябрь 2003 Версия продукта 15.1


2. Введите следующий текст в область примечаний:

• DESEXAMPLE

• JIM

• 2-2-2000

• 1
3. Щелкните в следующих областях в ограничивающей рамки в порядке, указанном
ниже:

a. TITLE

b. ENGINEER

c. DATE

d. PAGE
Concept HDL добавляет примечания на ограничивающую рамку в порядке, в котором Вы
вводили их в область примечаний.

4. Щелкните Close в диалоговом окне Note.

Ноябрь 2003 Версия продукта 15.1


5. Щелкните кнопкой Zoom Fit на стандартной панели инструментов, чтобы
просмотреть всю страницу.

Concept HDL показывает всю страницу целиком в окне проекта.

Выбор и добавление компонентов


Создание проекта при использовании Concept HDL включает различные шаги,
такие как добавление компонентов, соединение компонентов проводами, и
добавление портов ввода-вывода.

Компоненты хранятся в различных библиотеках. Используя Браузер элементов


(Component Browser), Вы можете выбирать компоненты из проектных библиотек и
размещать их в окне проекта Concept HDL.
1. Щелкните Zoom by Points и измените масштаб области, показанной ниже.

Concept HDL изменяет масштаб выбранной области.

2. Чтобы начать процедуру добавления компонентов, выберите Component > Add.


Появится браузер элементов.

Ноябрь 2003 Версия продукта 15.1


3. Выберите библиотеку local_lib в области Библиотек.
Элементы библиотеки local_lib появятся в списке элементов.
4. Выберите LS74 из списка Cells.
5. Щелкните в окне проекта.

Concept HDL помещает LS74 в окно проекта.


6. Поместите другой образец LS74 рядом с первым элементом LS74.

Ноябрь 2003 Версия продукта 15.1


7. Щелкните Close, чтобы закрыть браузер элементов.
Помещая различные образцы одного компонента, Concept HDL
автоматически задает свойства PATH. Это свойство обладает уникальным
значением, которое помогает идентифицировать элемент. Значения могут быть
следующие - I1, I2, I3...In.
На рисунке, показанном выше, приведены два образца элемента LS74. Они
идентифицированы как I1 и I2.

Соединение частей
После размещения компонентов в окне проектирования Concept HDL, Вам нужно
соединить различные части компонентов, используя провода. В этой разделе Вы
научитесь рисовать провода, чтобы соединить два компонента проекта.
1. Выберите Wire > Draw.

2. Сначала щелкните на конце вывода Q элемента I1 и затем на конце D элемента


I2, чтобы соединить элементы.
Concept HDL соединяет выводы Q и D соответственно элементов I1 и I2 как
показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


Примечание: Рисуя провода, Вы должны быть уверены, что провода начинаются с
концов выводов и не закрывают вывод полностью.
3. Расположите компонент LS04 между выводом Q элемента I1 и выводом D
элемента I2. Выберите Component > Add. Появится браузер элементов.

4. Выберите библиотеку lsttl.


5. Выберите LS04 из списка элементов и поместите на провод, соединяющий I1 и I2.
6. Щелкните Close , чтобы закрыть Браузер элементов.

Ноябрь 2003 Версия продукта 15.1


LS04 связан с I1 и I2 как показано на рисунке ниже.

7. Выберите File > Save, чтобы сохранить схему. Concept HDL сохраняет схему без
ошибок.
8. Добавьте еще провода к элементам, как показано на следующем рисунке.

Примечание: Дважды щелкните, чтобы завершить рисование провода в области, не


являющейся выводом или другим проводником.
9. Щелкните правой кнопкой мыши и выберите Done .

Ноябрь 2003 Версия продукта 15.1


Обозначение проводов
Concept HDL поддерживает соединение по имени. Если у двух сигналов на одних и
тех же или различных страницах того же самого проекта одинаковые названия,
Concept HDL рассматривает их как идентичные. Concept HDL не требует
использования соединителей вне страницы для сигналов, охватывающих
многократные страницы.
1. Выберите Wire > Signal Name.
Появится аналоговое окно Signal Name.

2. Введите в поле Signal Names текстовую информацию в следующей


последовательности:

• PRESET

• D

• CLOCK

• RESET

• AB1

• Q
Ноябрь 2003 Версия продукта 15.1
• QB2
3. Щелкните провода один за другим, чтобы обозначить каждый из них, как
показано на следующем рисунке.

Добавление портов
Cadence предоставляет порты ввода и вывода в стандартной библиотеке. Вы
можете использовать Браузер элементов, чтобы выбрать и разместить порт в схеме.
1. Выберите Component > Add.
Появится Браузер элементов.
2. Выберите библиотеку Standard.
3. Выберите INPORT из списка элементов.
4. Щелкните на конце провода под названием PRESET, чтобы разместить INPORT.
PRESET идентифицируется как входной порт.
5. Щелкните на схему, чтобы создать копию вывода INPORT снова.
6. Щелкните еще раз на конце провода D, чтобы разместить INPORT.
Точно так же создайте копию вывода INPORT и разместите его на проводах, как
показано на рисунке ниже.

Ноябрь 2003 Версия продукта 15.1


7. В Браузере элементов выберите OUTPORT из списка элементов и щелкните на
конце провода с именем Q, чтобы разместить OUTPORT, как показано на
следующем рисунке.

8. Щелкните Close , чтобы закрыть Браузер Элементов.

Добавление питания и заземления


Следующим шагом является добавление питания к проводнику AB1 и земли к
проводнику QB2. Необходимые питание и заземление доступны в библиотеке
local_lib.

Ноябрь 2003 Версия продукта 15.1


1. Щелкните на кнопку Zoom Fit, располагающуюся на стандартной панели
инструментов.

Concept HDL отображает страницу схемы полностью в окне проектирования.


2. Нажмите кнопку Zoom Points, располагающуюся на стандартной панели
инструментов.
3. Выберите область, масштаб которой необходимо изменить, как показано на
следующем рисунке.

Concept HDL изменяет масштаб выбранной области.


4. Выберите Wire > Draw.
5. Протяните горизонтальный провод так, как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


6. Щелкните правой кнопкой мыши и выберите Done.
7. Выберите Edit > Copy.

8. Выделите провод и щелкните над ним, чтобы вставить новый провод, как
показано на следующем рисунке.

9. Щелкните правой кнопкой мыши и выберите Done.

10. Продлите провод так, как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


11. Щелкните правой кнопкой мыши и выберите Done.
12. Выберите Wire > Signal Name.

Появится диалоговое окно Signal Name.


13. Введите AB1 и QB2, которые будут выступать названиями сигналов, и выделите
провод, как показано на следующем рисунке.

Concept HDL обозначил провода так, как показано ниже.

Ноябрь 2003 Версия продукта 15.1


14. Щелкните Close в диалоговом окне Signal Name.
15. Выберите Component > Add.
Откроется Браузер элементов.

16. Выберите в качестве библиотеки local_lib.


17. Выберите RES из списка элементов.
18. Щелкните в окне проекта, чтобы разместить резистор так, как показано на
следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


19. Выберите Edit > Rotate и выделите резистор.
Concept HDL поворачивает резистор как показано ниже.

20. Щелкните правой кнопкой мыши и выберите Done.


21. Выберите Edit > Copy.
22. Выделите RES и щелкните еще раз, чтобы вставить копию RES как показано на
следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


23. Выберите Edit > Move.
24. Выделите резистор и соедините его с проводом.
25. Выделите второй резистор, чтобы соединить его со вторым проводом так, как
показано на следующем рисунке.

26. Выберите Wire > Draw.


27. Соедините проводом резисторы так, как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


28. Выберите Component > Add.
Появится Браузер элементов.
29. Выберите в качестве библиотеки local_lib.
30. Выберите VCC из списка элементов.
31. Щелкните в окне проекта, чтобы поместить VCC как показано на следующем
рисунке.

Ноябрь 2003 Версия продукта 15.1


32. Выберите GND из списка элементов.
33. Щелкните в окне проекта, чтобы поместить GND как показано на следующем
рисунке.

34. Выберите библиотеку lsttl.


35. Выберите LS04 из списка элементов.
36. Поместите LS04 на AB1 и QB2, как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


37. Щелкните Close на Component Browser.
38. Щелкните правой кнопкой мыши и выберите Done.
39. Нажмите на кнопку Zoom Points, располагающуюся на стандартной панели
инструментов.
Concept HDL отображает страницу целиком в окне проекта.

Сохранение схемы
Когда Вы сохраняете проект, Concept HDL записывает текущий проект на диск.

Чтобы сохранить проект, выберите File > Save.

Concept HDL обеспечивает опцию записи списка цепей netlist всякий раз, когда
сохраняется проект. Чтобы получить доступ к этой опции, выберите Tools > Options.

В диалоговом окне Concept Options выберите вкладку Output.

Список цепей на языке Verilog создается в том случае, если выбрана опция Create
Netlist. По умолчанию, эта опция включена. Если Вы не хотите создавать netlist,
снимите флажок Create Netlist.

Если выбрана опция Create Netlist, то Вы можете создавать список цепей на языках
VHDL и Verilog одновременно. Чтобы создать VHDL netlist, выберите опцию VHDL.

Если netlist создается после того, как сохранен проект, Concept HDL отображает в
окне Console Command следующую информацию:
...HDL Written

Рассмотрение Verilog описания


1. Выберите File > Open.
Появится диалоговое окно View Open.

Ноябрь 2003 Версия продукта 15.1


2. Выберите библиотеку tutorial_lib.
3. В списке, имеющего вид дерева, дважды щелкните на DESEXAMPLE.
4. Дважды щелкните на sch_1.
5. Выберите verilog.v.
6. Щелкните File > Open.
Concept HDL открывает описание Verilog элемента DESEXAMPLE в текстовом
редакторе по умолчанию.

Добавление страниц к схеме


Создавая проект, его не всегда возможно представить на одной единственной
странице. Concept HDL поддерживает процедуру создания многостраничных
проектов.
1. Чтобы добавить новую страницу к схеме, выберите File > Edit
Page/Symbol > Add New Page.
Concept HDL переносит Вас на следующую страницу и показывает
[DESEXAMPLE.SCH.1.2] в строке заголовка.

Ноябрь 2003 Версия продукта 15.1


На следующем рисунке представлены соглашения в области обозначений, принятые
в с Concept HDL.

2. Появляется новая страница с добавленной ограничивающей рамкой.


Добавьте текст в ограничивающую рамку, чтобы задать имя инженера, название
проекта, дату создания и номер страницы. В качестве номера страницы выберите 2.
3. Нажмите на кнопку Zoom Points на стандартной панели инструментов.

Concept HDL отображает страницу в окне проекта.


4. Выберите область, масштаб которой необходимо изменить так, как показано на
следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


Concept HDL изменяет масштаб выделенной области.
5. Добавьте компонент MC68020 к странице схемы. Выберите Component > Add.
Появится Component Browser как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


6. Выберите local_lib из списка Библиотек.
7. Выберите MC68020 из списка элементов.
8. Нажмите на окно проекта, чтобы поместить MC68020.
9. Щелкните Close , чтобы закрыть Component Browser .

Создание шин
Создание шин подобно созданию проводов, но соглашения относительно
обозначений различны. В соглашении используется обозначение вида <n-1.. 0>, где
n характеризует размер шины в битах. 16-битная шина, названная DATA,
представляется как DATA <15.. 0>, и 32-битная шина с тем же самым названием
представляется как DATA <31.. 0>.
1. Выберите Wire > Draw.
2. Протяните провод от вывода D 31-0 как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


3. Выберите Wire > Signal Name. Появляется диалоговое окно Signal Name.

4. Введите DATA <15.. 0> в качестве название сигнала.


5. Выделите провод, чтобы обозначить его.
Concept HDL привязывает название к проводу и утолщает провод, чтобы
преобразовать его к 16-битной шине как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


6. Затем, добавьте 32-битную шину к выводу A31-0. Выберите Wire > Draw.
7. Протяните провод от вывода 31- 0 как показано на следующем рисунке.

8. Выберите Wire > Signal Name.


Появится диалоговое окно Signal Name.

9. В качестве названия сигнала введите ADDRESS <31.. 0>.


10. Выделите провод, чтобы обозначить его.
Concept HDL привязывает название к проводу и утолщает провод, чтобы
преобразовать его к 32-битной шине как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


11. Добавьте провод к выводу BG как показано на следующем рисунке.

12. Определите BG как название провода.

13. Добавьте 3-битную шину к выводу FC 2-0 как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


14. Добавьте провод к SIZ1-0 и обозначьте его K <1, как показано на следующем
рисунке.

Отвод шины
При проектировании схемы Вы можете использовать специфический бит, взятый из
шины, в качестве входа к компоненту в схеме. Чтобы извлечь специфический бит из
шины, Вам следует выявить шину. В этом разделе Вы научитесь выявлять 3-битную
шину FC <2.. 0>, чтобы извлечь значение, хранящееся в бите 1.
1. Увеличьте FC <2.. 0>, используя кнопку Zoom Points, располагающуюся на
стандартной панели инструментов.
Concept HDL изменяет масштаб шины, как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


2. Чтобы выявить шину, выберите Wire > Bus Tap.
3. Нажмите на FC <2.. 0>, и чтобы разместить символ выявленной шины, продлите
провод вниз двойным щелчком мыши.
4. Щелкните правой кнопкой мыши и выберите End Tap.

5. Появится вопросительный знак на символе выявленной шины. Вы должны


заменить этот символ числом бита, которое должно быть извлечено. Чтобы
заменить вопросительный знак, выберите Text > Change.
6. Нажмите на вопросительный знак.
Concept HDL помещает курсор возле вопросительного знака.

Ноябрь 2003 Версия продукта 15.1


7. Чтобы указать, что Вы хотите извлечь бит 1 в схематическом проекте, удалите
вопросительный знак и введите 1.
8. Нажмите Enter.
Concept HDL рассматривает 1 как значение свойства BN (значение бита).
Примечание: Если выявленный сигнал не обозначен, Concept HDL обозначает
сигнал автоматически.

Добавление физических данных

Одним из факторов, влияющих на процесс проектирования печатных плат, является


поведение компонентов, используемых в схеме. В частности, на него оказывают
влияние такие факторы, как температура и допуск на элемент схемы. При
проектировании Вы можете определить физические данные компонента.
Физические данные добавляются к компоненту за счет использования Physical Part
Filter в Component Browser. Physical Part Filter отображает файл Part Table (.ptf),
связанный с компонентом или библиотекой.

Part Table File связывает логические части с физическими, имеющими различные


физические свойства. Каждый ряд в файле Part Table (и в Physical Part Filter)
соответствует физической части.
Примечание: Вы можете создать таблицу элементов, используя разработчик
элементов (Part Developer).

В этом разделе добавьте в схематический проект резистор вместе с его

Ноябрь 2003 Версия продукта 15.1


физическими данными.
1. Выберите Component > Add. Появится Component Browser.
2. Выберите библиотеку local_lib.
3. Выберите RES из списка и щелкните на кнопку Physical.

Появится окно Physical Part Filter.

4. При создании схематического проекта для оптимальной работы значение


резистора должно составлять 100 омов, а допустимый предел - 10 %. Вы можете
задать эту информацию в проекте, используя Physical Part Filter. Выберите первую

Ноябрь 2003 Версия продукта 15.1


строку в Physical Part Filter.
5. Нажмите в окне проекта, чтобы разместить элементы с физическими свойствами
как показано на следующем рисунке.

6. Добавьте проводники к RES как показано на следующем рисунке.

7. Присвойте название проводнику A22.

Ноябрь 2003 Версия продукта 15.1


Сохранение и просмотр ошибок
Concept HDL осуществляет различные проверки, такие как электрическая проверка,
графическая проверка, и проверка имени проекта до его сохранения. Вы можете
изменить настройки, которые заданы по умолчанию и выбрать проверки, которые
должны быть выполнены в Concept HDL во время сохранения проекта.
Чтобы просмотреть настройки, заданные по умолчанию или изменить их, выберите
Tools > Options > Check . Появится диалоговое окно Concept Options .

Примечание: Concept HDL выполняет различные проверки до сохранения проекта,


потому что, по умолчанию, установлена опция Check On Write. Если Вы снимите этот
флажок, Concept HDL не будет выполнять никаких проверок во время сохранения
проекта.
В рамках этого обучающего руководства, мы не будем изменять настройки,
заданные по умолчанию. Выберите OK, чтобы закрыть диалоговое окно Concept
Options.

В дополнение к проверкам, доступным в Tools > Options > Check, Concept HDL также
выполняет другой набор проверок на ошибки соединения.
Ноябрь 2003 Версия продукта 15.1
1. Чтобы сохранить проект, выберите File > Save.
Появится диалоговое окно Concept Errors.

2. Щелкните на View Errors. Появляется диалоговое окно Markers, содержащее


сообщения об ошибках.

3. Нажмите на первую ошибку.


Concept HDL высвечивает местоположение ошибки на схеме.
Эта ошибка вызвана тем, что провод не обозначен. Назовите провод, используя
Wire > Signal Name.
4. Нажмите на вторую ошибку.
Concept HDL высвечивает местоположение ошибки на схеме.
Эта ошибка вызвана тем, что провод не обозначен.
Примечание: Если выявленный сигнал связан с компонентом, Concept HDL
автоматически обозначит его. В вышеупомянутом примере сигнал не связан еще ни с
каким выводом, поэтому мы должны назвать его.

Назовите провод, используя Wire > Signal Name.


Ноябрь 2003 Версия продукта 15.1
5. Выберите Wire > Signal Name, чтобы назвать провода - FG и FC, как показано на
следующем рисунке.

6. Щелкните Close.
7. Закройте диалоговое окно Markers.
8. Выберите File > Save снова. Concept HDL выполняет проверку для обнаружения
ошибок соединения и сообщает о них.

9. Щелкните Yes. Появляется диалоговое окно Markers, отображающее ошибки


соединения.

10. Выделите первую ошибку.


Concept HDL высвечивает местоположение ошибки на схеме.
Ошибка в синтаксисе вызвана неправильным обозначением сигнала.

Ноябрь 2003 Версия продукта 15.1


11. Выберите Text > Change.
12. Нажмите на K <1..
13. Измените текст на K <1.. 0>.
14. Нажмите Enter.
15. Выделите вторую ошибку.
Concept HDL высвечивает местоположение ошибки на схеме.

16. Измените название провода с FC на FC1, используя Text > Change.


17. Выделите следующую ошибку.

Concept HDL высвечивает местоположение ошибки на схеме.

Ноябрь 2003 Версия продукта 15.1


Эти ошибки произошли, потому что мы соединили 16-битную шину с выводом 32-
битной.
18. Выберите Text > Change.
19. Нажмите на DATA <15.. 0> и измените его на DATA <31.. 0>.
20. Нажмите Enter.
21. Выберите File > Close для закрытия окна Markers.
22. Выберите File > Save, чтобы сохранить проект.
Concept HDL сохраняет проект, который Вы создали, без ошибок.

Ноябрь 2003 Версия продукта 15.1


4
Создание схемы : Расширенная информация

Эта глава содержит следующую информацию:

❑ Использование групп – стр. 96

❑ Создание иерархических проектов – стр. 100

❑ Метод нисходящего проектирования – стр. 101

❑ Метод восходящего проектирования – стр. 102

❑ Создание иерархического проекта при помощи метода нисходящего


проектирования – стр. 102

❑ Создание иерархического проекта при помощи метода восходящего


проектирования – стр. 120

❑ Подготовка схематического проекта – стр. 130

❑ Настройка параметров проектирования – стр. 130

❑ Предварительный просмотр проекта – стр. 133

❑ Проектирование схемы – стр. 135

❑ Иерархическое проектирование – стр.136

❑ Упаковка проекта – стр.142

❑ Использование Глобального поиска – стр.144

❑ Исправление ошибок в Assigning Physical Parts – стр.146


❑Упаковка проекта после исправления ошибок – стр.149

Ноябрь 2003 Версия продукта 15.1


Использование групп

При наличии множества объектов, таких как элементы и проводники, которые Вы


хотите перемещать, копировать или выполнять над ними другие операции
редактирования, Вы можете включить их в группу и выполнить операции над всеми
объектами вместе в группе.

Группы полезны, когда Вы хотите выполнить единственную операцию над


множеством объектов. Concept HDL обеспечивает три метода для создания групп:

• По выражению;

• С помощью прямоугольника;

• С помощью многоугольника.

Чтобы создать группу, Вам сначала необходимо открыть схематический проект.


Запустите Project Manager и загрузите учебный проект. Когда Вы открываете проект
в Concept HDL, отображается DESEXAMPLE.SCH.1.1.

Создание группы по выражению

В этом разделе Вы создадите группу объектов в схеме, у которых присутствует в


названии текстовая строка PORT.
1. Выберите Group > Create > By Expression.
Откроется диалоговое окно Pattern.

Ноябрь 2003 Версия продукта 15.1


2. Наберите *PORT* в области Pattern.
3. Нажмите OK.
Concept HDL выделяет все объекты в схеме, у которых есть слово PORT в их
названии.
При создании групп Вы можете удалять, копировать или перемещать множество
объектов, имеющих слово PORT в своем названии, за один шаг.
4. Чтобы удалить все объекты в группе, выберите Group > Delete.
Concept HDL удаляет все выделенные объекты.
5. Выберите Edit > Undo.
Concept HDL помещает все удаленные объекты назад в их первоначальную позицию
в схеме.

Создание группы с помощью прямоугольника

Второй метод создания группы заключается в выборе элементов схемы. Выделение


элементов производится путем рисования прямоугольника. Элементы схемы,
которые заключены в прямоугольник, формируют группу.
1. Выберите Group > Create > By Rectangle.
2. Щелкните, протянув мышь по диагонали, и щелкните снова, чтобы создать
прямоугольник, который выделит объекты в группу, как показано на следующем
рисунке.

Ноябрь 2003 Версия продукта 15.1


3. Чтобы перемещать группу объектов к различным элементам схемы, выберите
Group > Move.
Выделенная группа прикреплена к курсору.

4. Щелкните на область схемы, чтобы разместить группу.


5. Щелкните правой кнопкой мыши и нажмите Done.

Создание группы с помощью многоугольника


Если часть схемы не может быть помещена в прямоугольник, Вы можете создать
группу, которая включит требуемые элементы схемы.
1. Чтобы создать группу путем рисования многоугольника, выберите Group > Create
> By Polygon.
2. Щелкните мышью, затем переместите ее и щелкните снова, чтобы нарисовать
одну сторону многоугольника.
3. Закончите многоугольник как показано на следующем рисунке.

Ноябрь 2003 Версия продукта 15.1


4. Щелкните правой кнопокой мыши и выберите Done.
Часть схемы в пределах многоугольника выдвинута на первый план.

Вы можете выполнить требуемые операции, такие как копирование, перемещение и


удаление группы.

Создание иерархических проектов

Метод иерархического проектирования - эффективный подход для разработки


сложных проектов, которые могут быть организованы в модули. Этот метод полезен
для проектов, в которых наблюдается повторное использование функций схем и
для того, чтобы изолировать части проекта для налаживания взаимодействий.

Результаты иерархического проектирования легко читать в распечатанном виде и


позволяют производить модули, которые могут быть эффективно отлажены.
Иерархические проекты, как и структурные, уменьшают количество входных данных
и взаимосвязей, требуемых в соответствии с проектом, таким образом уменьшая
возможности появления ошибок.

Создание иерархического проекта является естественным расширением всего


процесса проектирования. Если итогом проектирования является компьютером, то
Вы начнете проектирование с планирования составных частей компьютера.

Ноябрь 2003 Версия продукта 15.1


Компьютер может быть разделен на центральный процессор, память, и модули
ввода / вывода (CPU, MEMORY, и I/O modules). Модуль центрального процессора
может быть, в свою очередь, разделен на арифметико-логические устройства,
память, и управляющие модули (ALU, MEMORY, и CONTROL modules). Этот процесс
можно представить в виде трех уровней иерархии проектирования. Нет никаких
пределов числу уровней, которые Вы можете включить в иерархический проект.

Ноябрь 2003 Версия продукта 15.1

Оценить