Вы находитесь на странице: 1из 18

NAT

Network Address Translation


Адреса
• Публичный IP адрес
(Белый IP)
• Частный IP адрес
(Серый IP)
Частный IP адрес (Серый IP)
• От 10.0.0.0 до 10.255.255.255 с маской
255.0.0.0 (сеть класса А – около 16 млн.
адресов)
• От 172.16.0.0 до 172.31.255.255 с маской
255.255.0.0 (сеть класса В – около 65 тыс.
адресов)
• От 192.168.0.0 до 192.168.255.255 с маской
255.255.255.0 (сеть класса С – 256 млн.
адресов)
Типы NAT
1. Статический – для преобразования серого
адреса в белый – для доступа из сети
интернет к локальному серверу
2. Динамический – для преобразования серого
адреса в один из группы белых адресов
3. Перегруженный – РАТ для преобразования
несколько серых адресов в один белый
Небольшой офис
Настроить ip-адреса на компах
192.168.2.2
192.168.2.3
192.168.2.4

Сервер выделить в отдельный сегмент с адресом 192.168.3.2


На коммутаторе создать vlanы

• В режиме конфигурирования
• vlan 2
• name users
• exit
• vlan 3
• name server
• exit
Настроить интерфейсы
• Определить интерфейсы, ведущие к компам, во
vlan2, access
• Определить интерфейс, ведущий к серверу во
vlan3, access
• Определить интерфейс, ведущий к
маршрутизатору , как trunk. Разрешить vlan 2 и 3
• Просмотреть настройки
• Сохранить
Настроить роутер
В режиме конфигурирования
int fa0/1
no shutdown
exit
Создадим подинтерфейсы
int fa0/1.2
encapsulasion dot1Q 2
ip address 192.168.2.1 255.255.255.0
no shutdown
Exit
аналогично, для vlan3
Проверить, сохранить
Проверяем настройки
1. Пропинговать шлюз с компов
2. Пропинговать сервер с компов
Организуем выход в интернет. Соединяем
маршрутизаторы
• На маршрутизаторе провайдера установим белый
ip- адрес. Поднять интерфейсы
• interface fa0/0 (c маршрутизатором)
• ip address 213.234.10.1 255.255.255.252
• no showdown
• exit
• interface fa0/1 (c сервером)
• ip address 213.234.20.1 255.255.255.252
• no showdown
• exit
• wr mem
Настроим сервер

• Зададим ему статический адрес: 213.234.20.2


• Маска: 255.255.255.252
• Шлюз адрес роутера: 213.234.20.1
На нашем маршрутизаторе установим ip-адрес,
выделенный провайдером 213.234.10.2
255.255.255.252
• interface fa0/0
• ip address 213.234.10.2 255.255.255.252
• end
• int fa0/0
• no shoutdown
• Exit
• Настроим шлюз по умолчанию
• ip route 0.0.0.0 0.0.0.0 213.234.10.1
• end
• Проверить связь с провайдером с роутера и компов
Настройка PAT
Определяем, какой интерфейс будет являться
внешним, а какой внутренним (на обоих роутерах)
• В режиме конфигурирования
• int fa0/0 (к маршрутизатору )
• ip nat outside
• exit
• int fa0/1.2 (к коммутатору)
• ip nat inside
• exit
• int fa0/1.3
• ip nat inside
• еnd
Создаем access-листы: какой трафик
натить
• В режиме конфигурирования
• ip access-list standard FOR-NAT(это имя)
• permit 192.168.2.0 0.0.0.255 (Wildcard-
маска)
• permit 192.168.3.0 0.0.0.255
• end
• Посмотреть, что получилось
Магическая строчка
• В режиме конфигурирования
• ip nat inside source list FOR-NAT interface fastEthernet 0/0
over load
• end
• сохранить
• Попробовать пинг с компа на внешний сервер
• Посмотеть на маршрутизаторе
• show ip nat translations
• Просмотреть в режиме симуляции изменения адресов в
пакетах PDU
• Попробовать пинг с нашего сервера в интернет
Настроим статический NAT, то есть
настроить доступ к локальному веб-серверу
из внешней сети
• Перейдем в настройки самого сервера
• НТТР
• Поменять на страничке «Welcome to Nat»
• В браузере внешнего сервера набрать
213.234.10.2
На нашем маршрутизаторе
• В режиме конфигурации
• ip nat inside source static tcp192.168.3.2 80
213.234.10.2 80
• Сохранить
• С внешнего сервера обратиться к нашему
веб-серверу